Hub Firmware Release Notes - 25.26

Regarding which, sadly, we are given even less information. Hub updates are much better documented/shared with the user community!

2 Likes

Wouldn’t changes to Z-Wave structure be local? Platform changes are merely a storage problem, but how the hub handles Z-Wave devices must come through firmware updates. Thinking out loud here… :wink:

Nope. There’s a cloud component for the abstraction layer. That’s why your Custom DTHs can run in the cloud.

1 Like

Thank your stars for not getting this buggy update.

Any progress? It’s been almost a month since this bug was introduced and it’s still not fixed.

Again, I don’t want to be pain in the ass, but I take smart home and home security very seriously, and SmartThings is simply not reliable at this point. Your attitude with forced updates and zero possibility to rollback is the key problem here, not that somebody messed up, that’s normal in software engineering.

You simply cannot introduce major bug, which renders some smart home devices unusable and say: “Yeah, we know, where’s the issue, but we cannot tell you, when it’s going to be fixed.” and then nothing happens in a month?!

1 Like

Yeah the issue still exists. I’ve got a hub disconnected message 40 minutes ago. I can still control all my devices and the app doesn’t show it disconnected either. Still haven’t received any follow up it’s online message as yet even though everything is working.

Ever since the firmware got updated to 25.26, my Schlage Camelot Z-wave locks stopped sending any messages. I have reinstalled lock DTHs, Lock Manager, deleted the sophisticated DTH and tried the simple one, installed Smart Locks, rebooted everything multiple times. I am out of basic and semi-pro ideas. :slight_smile:
Can anybody advise? It’d be great if a staff member could look into my hub remotely and tell me what’s going on.

Additional info: I have V2 hub. The locks can still be controlled (locked/unlocked, armed etc.) though Smartthings Classic app, they just don’t send a message back with the used codes, manual lock/unlock etc.

See my post here: [OBSOLETE] Lock Manager - #2045 by Babar_Khan

1 Like

You guys will never get a switch to allow firmware updates unless they totally abandon the cloud architecture, so please stop asking. With the cloud, they only want to make the cloud work with the current and the previous firmware version.

Which means that they’ve coupled the two parts too tightly.

1 Like

I understand, that they tightly coupled their cloud with hub firmware. I don’t agree with it, but I understand that.

Here’s a question – why they didn’t rollback both firmware and cloud API implementation, since it’s broken as hell?

I have to constantly walkthrough people, how to fix their devices, because I am the unlucky creator of the DTH. Not to mention, that I’ve lost something around thirty hours trying to debug my DTH pointlessly, since the error was all along on the Samsung side of things. I might have catch that, but you know, silent updates are a thing.

1 Like

I have done some more troubleshooting on this issue, which I just posted in the Devices and Integrations section (under my original post about "Fibaro Light Switches NO LONGER SYNC . . . ).

If Tom Manley is monitoring this forum, I am hoping he will see this post.
In short, I added a V3 hub (to a new location - shows current 25.27 firmware) along with my V2 hub -(which only shows 25.26 firmware) - did not fix the problem. I removed a Fibaro Dimmer 2 from my V2 hub and added it to the V3 hub, but the problem remains the same (will not SYNC config parameter change without using Zwave Tweaker).

My Fibaro Motion sensor doesn’t synch either any more if using the new local DTH, nor reports on motion. Are these related to this last firmware release?

I see on my Fibaro device it is saying * networkSecurityLevel: ZWAVE_S0_FAILED

I suspect it is related to some back-end cloud server changes made by Smartthings in connection with the recent firmware updates (25.26 for V2 hubs and 25.27 for V3 hubs). Samsung maintains a status page at status.smartthings.com which details some of these issues.

Sounds like the Smartthings engineers are aware of these problems, but havent yet found/implemented a solution.

1 Like

They have moved on since programmers can’t seem to get anything working it seems to me. SmartThings was then actually was working decent for a very short period followed by the current decline is getting aggravating. It seems like they try something & when it doesn’t work move to something else and no thoughts to customers who have spent a lot of money on current products.

Polite request for any news on this please.

Thanks

2 Likes

I second the polite request. That would be great.

Out of curiosity, my new V3 hub shows firmware 25.27, while my V2 hub still shows 25.26.
Both exhibit this same problem.
But I’m wondering whether Smartthings (or someone else on this forum) can confirm whether different firmware updates are released to V2 v V3 hubs, or are both hub versions treated the same in this regard?

I too have .27 on V3 and .26 on V2 and this is how it should be, as described in post above this one.