SmartThings Community

Hub Firmware Release Notes - 25.26

Did you guys push this update to Samsung connect as well ?

Ah right! I needed to re-program the thermostat “System Code” found here:
https://zenecosystems.com/zenthermostat/install/install.php?hub=smartthings

Thanks Jessica - I’m back up now!

@SmartThings - This was a dangerous upgrade and I hope there will be a thorough after action review. If this had happened during a colder time of year and I wasn’t home to intervene?!

Also think you might want to re-visit the policy of “we’re not notifying you of upgrades” for exactly this reason…

Glad it is working now! Did you receive the firmware update for the Zen thermostat? The latest version is 0x00000220.

No. The Connect Home and SmartThings Wifi were not updated as part of this update.

I tried updating it in the app and it didn’t seem to do anything, so I am not sure if it is updated or not

Yay! I’m glad to hear that. If it was like the middle of April here, it might not have been bad. My husband had to manually shut off the central air so that it wouldn’t get ruined.

1 Like

We have released 0.25.27 only to hubs that were experiencing the issue described in the following post

Recap:
If your hub’s Z-Wave Node ID was NOT 0x01, you most likely have been experiencing communication problems with only secure Z-Wave devices on 0.25.26 release (not all Z-Wave devices use security to transfer messages). We fixed that issue in 0.25.27 and pushed that change to only hubs that were experiencing this particular issue.

You can determine if your hub had this issue by checking the Node ID of your hub, by checking the Z-Wave section of the hub info page (https://graph.api.smartthings.com).

For example:

How do you determine if a device uses security?

If the raw description of your Z-Wave device has “s” (lower case) in the “zw:” section, then the device uses security to transfer messages. Capital “S” means that device is of sleepy type. “F” is for FLiRs devices, “L” is for listening devices. You can only be either “F”, “L” or “S”, and “s” can be combined with any of those types.

An example of a secure device Raw Description:

Feel free to ping me if your hub has a different node ID than 0x01 but you do not have 0.25.27.

2 Likes

Took a bit but you’re up to date. We’re also in contact with Zen to see if we can find out more about the issues you and others are seeing.

1 Like

Actually, you can delete those ghost devices yourself – just follow the instructions in the following link:

/cc @Kianoosh_Karami, @jsulliweb

Yup, I know. Sometimes that works but I have 1 device in particular that neither ST nor I could clean up.

FYI, That works, but if the device is still in the network and responding, it will fail to be deleted, however the classic app forcefully deletes the device record in the cloud, and the user gets the wrong impression that the ghost device was removed. However, if you the new app, “force delete” will only be successful if the device (ghost device in this case) was actually removed from the network.

Thanks for sharing that with others.

3 Likes

They are definitely not The same across the many different hubs. There are different development teams working on all of the specialty hubs, including the Wi-Fi mesh ones, the Nvidia one, and the ADT one. They will not all have the same firmware number nor receive firmware updates at the same time.

2 Likes

I found that did not work in my cases as I too followed this hoping it would. I suspect it is based n how the device became phantom to begin with as in my case the devices just disappeared one day. Regardless, Support will backstop this
if you can’t do it manually.

24.x is only one major revision behind 25.x. So not far behind at all.

1 Like

Is that related to the “stale” DTH issue, or is that a separate problem?

1 Like

Yes, this is the stale DTH issue.

1 Like

Something has definitely changed for the worst on Z-Wave. I am consistently seeing very slow updates of state from devices manually operated. This did NOT happen before this FW update.

It’s a real pain for a number of reasons… one being I have several smart switches with no load that have a Smart Lighting rule to mirror to another device. So now when I operate the switch at the wall the device that should mirror the switch might take a minute or two to kick in. If I had delays before it was seconds.

@Kianoosh_Karami, I appreciate you trying to help but you said what you saw was expected behavior because I have many devices and some do not report status so I have to wait on polling and my mesh is large. Respectfully I have to point out that I did not get these issues before this update…

My problem is not with just one or two devices but so far every device I have tried.

Operating via the app is fine. This looks like a change in the polling or whatever was changed with Z-Wave in this update has affected polling, badly.

After getting rid of a few bad devices in my network some time back I had been so happy with my Z-Wave stuff - all was performing very well. Now things have taken a step or two backwards and all that changed was the hub FW.

EDIT: My door locks are taking even longer to report state so my automations based on those are also useless right now.

My Zen is fine, it has been all the way through this beta rollout. It updated to the latest Zen firmware that was included.

My hub is still on 26. Zw node ID shows as 01. All zw devices in new smart things app show as disconnected. Is this a separate issue or the same as everyone mentioned this morning? Because the devices are working, but not showing as connected in the app since the update yesterday.

Unless you’re using math ADT hub which was touted as the latest and greatest less than a year ago and is still on 20.x – which means it is missing out on an awful lot of local device handlers…