SmartThings Community

Hub Firmware Release Notes - 24.20


#61

My hub kept going online/offline for a few days around this upgrade timeline. It seems to have stabilized and has been online consistently the past 15 or so hours.

I’m still not getting a connection/actions to my sengled bulbs and inovelli switches/extenders through either smart things app.

Is the next step to reinstall everything? Smartthings wife acceptance is at an all time low this week.


#62

Doubt that will help to be honest.

I just powered down my hub a few minutes ago (using an Iris wifi plug and their app). I’m leaving it down for an hour. When it comes back up, zigbee mesh will rebuild and then I’ll run another zwave repair just for fun.


(Steve White) #63

I wouldn’t let the device count scare you! I’ve got over 400 but I’m willing to make the sacrifice again. I moved to SmartThings from Iris (v2) because I could not see a future for it. Too many month of broken promises, new and regressive bugs, severe cloud issues, lights turning on at random times, sirens going off in the middle of the night.

It almost sounds exactly like what’s going on with ST right now. The only difference is that I do see a future for SmartThings, but only as a system targeted at users who want to control their Samsung appliances and TV’s along with a few lights and other simple devices. That’s not me.


#64

Since the update on Monday, every time I open the Smartthings mobile app, it knocks out the internet in my house. Wifi is still there but no internet access via wifi or wired. In the app my hub shows as disconnected and nothing works. I have never had this kind of problem before this update.

Exiting the app and power cycling my modem/router gets the internet back, and as long as I don’t open the Smartthings mobile app, my schedules and routines are working.

Anyone know of a fix for the mobile app killing my internet? I think I will try the Smartthings Classic app to see what happens with that.

UPDATE: Smartthings Classic app works for me (doesn’t cause my internet to drop). :+1:t3:


(Dan Bodette) #65

I have 2 V2 hubs in different states, one took the update and is working the other went offline and is flashing red since the update. I’ve tried every kind of reset available and it’s still flashing red. It was working fine prior. Anyone know where to go from here?


(Mark C) #66

I’m uk v2 and all my stuff is randomly working or not working. Came home
Christmas lights on (mi home custom app and dh).
Alarm armed when i was at HOME (Yale custom dh) to
30min for mobile pressence to see gf home.
Motion sensor alerted 30min after it should have
Routines only turning on/off some things in them (thermostats, switchs)
Smart lighting app only doing some actions

What’s going on !


(jkp) #67

Contact ST support at https://support.smartthings.com


#68

I’ve not heard of something like this before, so I’d contact support. Stick with the Classic app unless you must use the new app.


(Mark C) #69

Using classic. Normally do nothing and these bugs seam to work there way out. But i think I’ll try a hard reboot battery out n see


(Kevin) #70

I’ve kept the new app partly because I created a lot of scenes using it and they aren’t backward compatible. So, to edit them I need the new app. The room assignments I see I can do with the old app also by going to the room tab and adding devices from there. In the new app, you go to Devices and edit from the three dots, select your device and there’s an entry for room. Just was more logical than the old app so that’s where I was looking for the setting (in the devices settings).

The old app definitely seems like the better app, the new app seems like the dumbed down version. @SteveWhite sounds like he’s got Samsung’s roadmap about right. with what he says about the future.

Edit: The new app said it couldn’t connect to the misbehaving GE Switch but the old app just did nothing. So that was an improvement actually.


(Christopher Howard) #71

I have 7 of the Daylight version of the Cree bulbs. I have personally seen 4 of them flash multiple times since getting updated to firmware version 0x0000020A. If they are on, they blink off and back on. If they are off, they blink on and back off. Prior to that they were all rock solid. This is a huge pain. I’ve had to remove the bulb from my daughter’s room as it wakes her up in the middle of the night when it does it. It’s unacceptable and a shame that no one is willing to do anything other than point fingers. Samsung points at Cree, Cree points at Samsung. Meanwhile their loyal users get the middle finger from both companies.

I have a Hubitat that I bought when I had a coupon code. Maybe it’s time to make that move.


#72

So weird. Ours are all in bedrooms, and if they’d flash/blink my family would shoot me. It’s too bad the Live Logging couldn’t stay up long enough to see if it would capture anything coming from these bulbs when that happens.


(Kianoosh Karami) #73

@johnconstantelo PM me and I will work with you to figure out the cause of your GE Switches turning on and off without your discretion


(Kianoosh Karami) #74

@SteveWhite Can you also PM me and I can work with you to figure out what is going on wrong with your hub?


(Glen King) #75

IF
the Cree bulbs worked fine for years,
BUT
after a Smartthings hub firmware update the Cree bulbs cease working fine,
THEN
it is utterly clear that the Cree bulbs are not the issue.

IF
Samsung is pointing the finger at Cree,
AND
we know of Samsung’s horrendous history of broken promises and shoddy customer service,
THEN
we can rationally deduce that the problem is on the Smartthings side.

Samsung… if you’re trying to drive customers away and kill this platform, you’re on the right track.


#76

I think there’s a webCore piston for that logic? lmao, I couldn’t resist…


(Paul Osborne) #77

Cree provided us with an OTA firmware update for their devices to address security issues discovered with their devices (same ones that affected Hue bulbs). With the 24.11 this OTA was added to the hub firmware and customers with OTA enabled for these devices updated. It is customers with this updated Cree bulb firmware (0x020A) that appear to be seeing the behavior where the lights randomly turn on. Most likely this is due to the bulb firmware crashing or watchdog resetting resulting in a reboot with a default state of on.

At present, we do not have an OTA from Cree to go back to the old firmware. We are currently evaluating this device’s status as a WWST certified device and are also considering pulling the bulb firmware from the update database (which requires a hub deploy).


#78

But I have noticed CONFIG commands that match up to the flash times in the event logs for the bulbs. Reported in my post above above and to Support.


#79

And, at the risk of becoming a pain repeating myself, the Crees are causing zigbee devices to go offline. I reported elsewhere that if I power off all my Crees, any zigbee devices I have that had dropped offline come back on line. If I then power on the Crees eventually the zigbee sensors drop again, presumably as they map back through the Crees. While the Crees have always been declared weak repeaters, I never personally had this issue until the new Cree FW.


(Christopher Howard) #80

Thank you for this response. I have a case number with Samsung that has yet to receive a response. I put it in a week ago, so you can imagine why the frustration levels are high. It’s nice to hear something that actually sounds plausible.

I only hope that that a fixed firmware version can be released ASAP, with validated testing first. If OTA firmware updates have to come from the equipment manufacturer then they need to be thoroughly tested before rolling out when it takes this long to get another firmware version.