Hub Firmware Release Notes - 21.12


#101

Thanks @Zach_Varberg - specifically I’m looking to update Osram (outdoor) flex strips that aren’t mentioned in the release notes, however, US users can already update these using the IDE OTA updates so I was hoping that this might now be the case for the UK?

I’m worried it might not ever happen having been told by ST that “Osram OTA updates for UK/European users have not yet been made available. There’s no information on if/when this might be made available for UK users” on Feb 27th this year.

Any further info you might have on this would be great to hear :slight_smile:


#102

Its worth picking up a cheap Lightify hub to do firmware updates, they go for £15ish on ebay. The updates resolved my zigbee pass through issues and made sensors much more responsive.


(Kianoosh Karami) #103

Message me Directly and I can take a look.


(Joern) #104

@posborne
Any news on this when we can expect a fix for the Samsung appliance integration?


(Devesh Batra) #105

i lost an Osram RGB bulb from ST post upgrades. no other issues… Found out when we tried to turn the bulb on/off using the remote. did not work

OSRAM Remote is still in ST, bulb is missing

need to re-pair the device

Also, would it be possible to add local processing for Keen Vents and Aeotec devices as well ? Thanks


(Kebel87) #106

@Zach_Varberg

Thumbs up on last update, it solved the problem I had since 19.xx (November IIRC) with the DSC integration.

Httpget request were sometime delayed,


(Stephen) #107

Is there a reason why after every firmware update I lose 1 of my GE z-wave switches. It no longer responses. I have to remove it and re-add it. This happens EVERY time you do a firmware update.


(jay yankacy) #108

At least it was only one! I had several outdoor plugs do the same.


(John) #109

I’m going to guess that 'Virtual Switch\Dimmer" does not include momentary button tiles?


#110

It only includes the DTHs called Virtual Dimmer Switch and Virtual Switch.


(Jimmy) #111

There isn’t a local momentary button, but the new virtual device handlers will still process a command even if the device is already in that state. The simulated switches don’t do this. So for example, an on command will still occur even if the virtual switch is still in the on state. So a webcore piston with a trigger based on virtual switch turning on would still run.


(Paul Osborne) #112

We are currently performing additional testing on the fix to make sure it works across a variety of devices of this type as well as looking at a couple other issues that we might want to include in a hotfix release. Right now it is looking like the release will likely be late next week or the week after (depending on how testing and root cause investigation of the other issues progresses).


(John) #113

This is exactly what I am doing/talking about. I use a momentary tiile (virtual) that triggers webcore to run routines. However, even if I were to change the virtual device so it’s local, webcore is still cloud based. I’m not sure how much it will help me in that instance.


#114

Is it possible that these improvements could have inadvertently resulted in SmartThings not being able to read Sonos status properly? I have been able to reliably view status of my Sonos speakers for quite some time but am suddently seeing incorrect play/pause information. I feed this information to a few webcore pistons to trigger events (i.e. turning on an amplifier if the Sonos Connect is playing something). The Sonos still responds to commands sent through the ST app (play/pause/volume), however it no longer displays the correct status. Anybody else seeing this issue?

Apart from this, thanks for the continued improvement/updates!


(Joern) #115

@posborne: Thanks for the update!


(Zach Varberg) #116

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.