Hub Firmware Release Notes - 21.12


(JIm) #61

So if I have an existing simulated switch and just change it to a virtual switch it will then run locally? Or does it have to be a totally new one?


(Zach Varberg) #62

Changing will work fine, but you will have to make sure that the hub field is set as mentioned above.


(Sully) #63

Any plans to make momentary button tiles local? Just curious. :slightly_smiling_face:


(Devesh Batra) #64

Hub updated … all my 4 Virtual switches now show local execution :slight_smile:


(Alex) #65

@Zach_Varberg - Does the Virtual Dimmer Switch support LiFX and/or Hue? I’d love to be able to use SmartLighting to mirror multiple colored lights using a single virtual device to control them all.

I am aware of TrendSetter and I am currently doing it in Webcore however it is glitchy (quite likely due to my coding). I would imagine this to be a common thing for people to want to do when having multiple colored lights. Please consider adding native support if it isn’t already there so it can be done withing SmartLighting and all “local” for faster sync’d behavior.


(Zach Varberg) #66

The feature will work for any bulb. However, note that currently the mirror behavior will only follow on/off and dim status. Color and Color Temperature will not be mirrored, so it doesn’t help with moving a whole group of lights to a given color. Using scenes is probably the best first party option right now if you want a group of bulbs to all go to a single color. But, as you mentioned there are a few community solutions available for that behavior.


(Kevin) #67

Is the AEON Multisensor on the horizon for firmware updating?


#68

@Zach_Varberg Not sure what’s what’s up with my hub after the firmware but my hub has been restarting every minute since the upgrade. It’s hardwired into the lan and there wasn’t a power drop at the house during the upgrade. Any suggestions?


(Zach Varberg) #69

I’ll take a look.


#70

Thanks @Zach_Varberg! I can send you my hub information if you need it via a message.


(Jimmy) #71

The Aeon unit is z-wave and SmartThings doesn’t support over the air z-wave firmware updates


#72

My update seems successful. My ct101 thermostats are much more responsive now. If I make a change at the thermostat the app updates instantaneously now. Before it was hit or miss if it would update. Assuming this has to do with the updated zwave protocol.


(Steven) #73

Is mirroring color a feature that will be added down the road?


(Joern) #74

Really great job Smartthings Engineers.

  1. In the past I could connect my Samsung washer with Smartthings and it worked very reliable
  2. Then it stopped working from one of the other day.
  3. I opened a ticket and was told a lot about my WiFi network, which were the ptoblem. No chance to reconnect.
  4. Back in January 2018 Smartthings fixed this issue (w/o touching my WiFi) with firmware version 20.16 and the note"Fix for discovery of some Samsung Digital Appliances"
  5. It worked like a charme and very reliable.
  6. With the firmware upgrade today (version 21.12) you broke it again. Wonderful job, now I’m not able again to connect my lost connection.

What are you guys doing, is it not possible to work on the firmware w/o crashing something you fixed in the last release?

Now I will get more information about my WiFi if I open a ticket. And btw, why isn’t it possible to check a box when I want to have this update.


(Brad) #75

I am very sorry and recognize that the appliances have certainly had their difficulties. For this issue, I believe there is a TLS issue but one of the embedded engineers can speak more to it.


(Mike) #76

Using virtual switch in place of simulated has improved device reaction hugely, im detecting zero lag from app to device, thank you everyone


(Joern) #77

Hi @Brad_ST, thanks for your prompt response. Can you please get me in touch with one applicable engineer? I really would like to work this out. I also opened a ticket for that yesterday.

Thanks!


(Lee Florack) #78

In a lot of cases, instead of Simulated Switches, I’ve created “On/Off Button Tiles”. Can those be switched to the new 'Virtual Switch" for local control?

Also, I have many " 'Momentary Button Tiles". Any chance for them working too? (I doubt it as I don’t think there was a local replacement launched, but I’m asking anyway.)


(Jimmy) #79

Can’t say i’ve ever use the On/Off button tile handler. Switch it over to the new Virtual switch and see if it works. Can always switch back if it doesn’t.


(Lee Florack) #80

I converted one of my (10) “On/Off Button Tiles” and it seems to work OK. Looks a little different now, but functionally it’s the same - other than running local now.

BTW, the reason I have the “On/Off Button Tiles” is due to my use of the old SmartApp ‘Virtual Device Manager’ by “bkeifer” (I think he’s no longer a member) to create my simulated switches. That app creates either “On/Off Button Tiles” or “Momentary Button Tiles” as needed. I am now planning to start using “Switch Mania” by @infofiend

Update: I’ve now converted all (10)“On/Off Button Tiles” and (2) Simulated Switches to “Virtual Switches”. They all seem OK. Thanks!