SmartThings Community

Hub Firmware Release Notes - 20.17


#169

Anyone having issues with their favorites not doing anything when you click on them? ios - The “thing” work fine, but not within the favorites list on the main screen…


(PPO16) #170

Try to remove the battery of the faulty sensor and press the reset button and re-insert the same battery while the hub is in adding device mode. If you see the sensor led tuning green at a point, then all good, battery was not exhausted.
If you don’t see any light on the sensor,
try to change the batteries of the faulty sensors and press reset the reset button while inseeting the new battery with the hub in adding device mode.
For some reasons, sensors that worked before the hub update might go offline after the update if the battery level was too low.
As the battery level is totally inaccurate in the app/ide, even though you had 100% before the update doesn’t mean the battery was still ok.


(Brian) #171

I don’t know if this is related to the firmware upgrade or the app upgrade but since 2 days ago my Wemo plug doesn’t show up properly in the app and the SmartApp timer doesn’t turn on/off anymore. When I go to the “Thing” page (the Wemo plug controls the light in a display case) only shows a “?” instead of the icon that should show Off/On. I deleted the thing and reinstalled it, but it still shows “?” on the page. I can turn it on and off from the Things page, at least.

Any solutions? Thanks.

Brian


(Brad) #172

I see the issue with the “?” display and have flagged it for a dev to fix as I unfortunately can’t address it personally. I’ll let you know when it’s resolved.


(Brian) #173

Thanks for responding. I hope it won’t take long to fix.


(Dave) #174

I’m seeing the same with my motion sensors on the dashboard. I now have to press and hold their icons to see the detail screen. Before, a single touch would show the detail screen for the sensors.

My other icons for lamps etc are behaving ok. Single touch for on/off.

Colour has gone from icons which display Lux and temperature.

All this became apparent Saturday morning

.


#175

my wemo went offline about 2 weeks ago, haven’t had time to investigate, so don’t think it’s THIS firmware, but it was fine for almost 6 months and then dropped


(Bob) #176

Strange thing is my 2 WeMo devices are OK but I am seeing it with other devices.
I’ve reverted back to 2.13.


#177

Thank you. At least I can access them now. I’m getting the same behavior you describe. I’d like them to return it to a normal press…no need for a hard press…


(Martin) #178

I also had 5 zigbee bulbs non-operational after the update to 20.17 on my Hubv2 in the UK.

2x Osram lightify - these were OK after I reconnected them.
3x Hue bulbs (directly connected) are not working after 4 days. I don’t have a way to reset them, so don’t want to try deleting and rejoining.

Did you have any success in resolving this?


(Brad) #179

There was cached data causing this but it is fixed.


(Brian) #180

That’s great! Thanks!


(Chris) #181

I’m having this same issue. It’s extremely annoying. How do I get it back to the normal 1 press. Also noticed my sensor colors are gone from green to boring white on the favorites dashboard.


(Dave) #182

All back to normal again. ST obviously fixed something :wink:


#183

(Alex) #184

@Brad_ST - I changed a number of Aeon Door sensors over to using the local DTH but the battery is not reporting its status. This is an issue I had prior as well and had found that a configuration setting was set not to report battery status. While hacking a cloud based DTH I was able to get it to work but I would much rather use a local DTH. Is the battery reporting in the local DTH supposed to work regardless of sensor make and model?


#185

6 of my zigbee bulbs have stopped responding after this update. i did raise a ticket but the support guys are yet to get back on this.

I even tried resetting one of the bulbs (Osram Lightify) by cycling on/off 5 times but to my surprise even that didnt work.


(Zach Varberg) #186

Hey Alex I looked into this and everything is working as expected. With events in SmartThings they only get saved if they are a state change, otherwise we don’t propagate them. In your custom DTH it looks like you are manually setting isStateChange to true, so it will always show up in your event history. However, that isn’t normally the way things are done. I can see in your logs that several of the devices in question have reported battery since the update, but since the values reported were still 100%, they aren’t state changes and thus they don’t show up in the event history.


(Alex) #187

@Zach_Varberg - The issue with the default DTH and the one I was using prior to hacking it was that it always reported 100% regardless of the real value. I was then told to modify it so that it didn’t force the setting over and over and I am not sure I succeeded in doing so as a number of sensors are stuck at 100% for way longer than I have ever seen them do so. I would need to test things with a known partially drained battery to verify they all actually work. I will try that with the default DTH and report back.


(Zach Varberg) closed #188

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.