Hub Firmware Release Notes - 19.17


#204

What jkp said. Here’s that post:


(Warren) #205

Anyone having issues with Smart Lighting automations after the 19.17 update?

I’ve never had any issues with automations until the day of the 19.17 update but now I seem them consistently. I did submit a case on this but wanted to poll others (and those trolling the site while cooking a turkey) to see if I am missing something.

For example, I have lights that trigger to be turned on based on sunrise or sunset:
-Hue Lightstrip Plus: turns on at sunrise and sunset -1 hour and off at sunrise and sunset +1 hour
-Leviton switch: turns on at sunset and off at a fixed time (same as GE below)
-GE Plug-in Outdoor Switch: turns on at sunset and off at a fixed time (same as Leviton above)

These lights always work and have never had any issue being reachable AFAIK and work fine with Alexa controls. What’s weird is that the lights always turn on at the correct time but the automation that is set up to turn them off seems to inconsistently work. Here’s a pictoral:

In looking at the logs, it does actually appear that a command is issued (well, logged anyhow) to the light to turn off. Last night I waited and when then did not turn off I asked Alexa to manually turn them off and of course it worked.

So, I am convinced that something with the 19.17 update has reduced reliability or similar but I have no idea if it is related to the cloud/local changes or the supposed Z-Wave improvements. Anyone else having issues here?


(Dave) #206

I’m noticing issues too. Have reported to ST.

Lights turning off during a programmed-on period (ST Zigbee outlet). Another not turning off at the end of a programmed period (Aeotec Zwave outlet). This switched off instantly using the app, so no issue with communication.

Dave


(Bartek) #207

I am keep seeing this annoying error in theapp “there was an unexpected error” even though I don’t see any problems. Can not you disable this notification as in most cases it doesn’t show user any valuable information.


(Borristhecat) #208

I’m having the same issue but have a support ticket for it so there looking at it.


(Dave Gutheinz) #209

Are you using the custom TP-Link bulbs and plug Service Manager and Device Handler? One of the users there is reporting a similar issue. May be a common thread (even though the user is reporting the notice appears “much more infrequently” when the ap is not installed.


(Bartek) #210

No, I have no TP-Link bulbs.
And don’t see any problems with any of devices to work incorrectly. Just this error keeps showing very often.
It would be good if there were any logs, tellign what it refers to, or the error more descripting.
What is the reason to show it if you totally dont know what it refers to. Totally useless.


(Dave Gutheinz) #211

I agree. If the information is not useful to the user or does not identify the device or service manager, then why have it.

QUESTION FOR COMMUNITY: Are these errors (with more detail) logged anywhere?

The message say something needs fixing somewhere. Appearing in the Application helps - if there is a log event somewhere that states where the error is generating from (i.e., the event log for a Device Handler or Smart App). It should AT LEAST define the offending Device or Smart Application so something.


(Dave Gutheinz) #212

Sorry to bother you again. What Smart Apps are you running? The person I am talking to is running:

Amazon Alexa (UK)
Wake Up
Logitech Harmony
Notify Me When
Samsung Smart TV (connect)
Smart Lighting

Any commonality?


(Eric Anderson) #213

Will there be a DH for Switches/Dimmers with Scene Control?
Also will there be a Smart App Similar to Advanced Button Controller?


#214

Zwave going crazy… Constantly getting these for MOST of my zwave devices. What’s going? Tagging @tpmanley and @Kianoosh_Karami

I’m seeing these in the HUB events log but I don’t have device “B2 and A0” in my device list.

UPDATE: So I decided to cycle power to the entire house and I’m no longer getting those exception errors and everything is responding properly. And Z-wave repair is now completing without issue. It seems I might have a bad device on the network? Strange that the mesh can get so messed up with a bad device.


(Bartek) #215

I dont have any of those.

I use google home, webcore, arlo, ifttt, sharptools and grafana logger.


#216

I am also having issues with smart lighting since the update. Lights are being turned on by motion, but never switched off. Lights are also not turning on with motion despite being inside the enabled window.

The issues are occuring both with sunset/sunrise and lux level conditions, and across different types of bulbs and sensors…


(Warren) #217

So I did two things while waiting for ST Support to respond:

  1. Z-wave network repair
  2. Deleted the failing rules and recreated them

I think deleting the rule and recreating it somehow helped. The ST support team eventually responded and basically said that I had done what they would have asked me to do so my guess is that something with the update caused some issues with rules but they haven’t owned up to it yet as they also indicated that “firmware upgrades don’t cause these issues usually.” I’m monitoring now but it seems to have made the difference thusfar. What recreating the rule would do I have no idea. ST Support said something cryptic like “resends the commands” but I have not heard back just yet on what they mean by that.

-Warren


(Allan) #218

“Usually” you can just go into your routine, next through it, and click Done which does the same kinda thing. I believe whats happening, and it would be nice for a Dev to answer, is the SmartApp (SmartLighting) deletes and recreates the child SmartApp (your routine) when you do this. I know they are recommending this because of the new devices that run locally. I.e. if you had a device that ran from the could then your routine was also cloud based. If now after this firmware update the device you are controlling runs locally the routine doesn’t update from cloud to local until you “update” it by running through and clicking Done.


(PPO16) #219

Bad surprise coming back home tonight: :frowning_face:

  1. My ZigBee Osram bulb turned on since 11am after the HUB running 19.17 got a rejoin event without any cause (no power outage seen by my APC, no one home playing with switches).
    Ticket filed to ST support.
  2. “I’m back” routine setup the heating point to 19C but the physical Thermostat kept off. Tried again Goodbye/I’mback transition: same. Finally had to go to the Device and click on the Off->Cool-> Heat to get it On again and heat.
    I happened to click manually the “I’m back” widget before entering the house and after the geofence triggered it but as I didn’t receive the norification&SMS on time, I thought it didn’t work.
    Ticket filed to ST support for thermostat issue.

I don’t dare submitting the notification problem… 2 tickets a day keep the automation away…

[UPDATE 11/28: support reminded me that routine don’t turn On/Off the thermostat so if by chance the thermostat is put “off” then the routing won’t turn it “on” again. My bad on this one.


#220

I did this, but still had the same issues. None of my DTHs went from cloud to local, however I have now amended most of then to local DTH (zigbee rgbw bulb), removed the entire smart lighting app and recreated it from new (lot of effort!).

All working now, bulbs seem to be slightly more responsive… Fingers crossed this will sort it!


(Jeremy Kane) #221

This update has been a nightmare for me. All of my zwave devices have gone offline. The ones I was able to get working again after the update have stopped working. I can’t even exclude any devices to re-include them.


(terence peace) #222

When are ST going to fix these problems?


(Alwas) #223

@tpmanley are you joking?

Why mess with something that’s not broken? Why introduce a system bug? Before this firmware “upgrade” I’d never seen a device “not available” before, I’d never seen the red warning sign, now I have them next to 4/5 various Z-wave devices, some come back online for a few hours them go offline, 2 I can’t get back, tried power cycling the hub, Z-wave repair. Thanks very much @tpmanley!

The fact support haven’t replied says it all.