Hub Firmware Release Notes 08/15/16 (Hub V2) - 15.3

I am getting timeouts on anything that uses a simulated switch. Did anything change that should have caused an issue with the DTH for the stock simulated switch?

What does Hub V1 do?

This release is for the V2 firmware. The V1 behavior is unchanged; polling is done less frequently (every ~5 minutes) by the DTH in the cloud. This particular enhancement is unlikely to be implemented for V1.

Thanks, Paul.

This is very important information to share! The baseline assumption everyone makes is that Hub V1 & Hub V2 behave identically except where specifically noted.

Could someone please document all the differences? It would help clarify a lot of confusion (and a question that has come up many times!).


Yes and then if that is a substantial list of differences… When is the conversion tool coming. I would like to knock the dust off of the v2 sitting in the drawer.


Yeah, never. That’s when it’s coming.


Hey, hey…that’s a commitment, please, we don’t make those around here…


Agree it works great! This is a major enhancement for me! Before this update I had a bunch of hue light switches which I’ve never bothered using as the updates were slow and relied on a core piston refreshing states. Very happy this is finally fixed. I always found it strange that my logitech hub was able to detect Hue states within 2 seconds but ST took 5 minutes. Now it’s all working as it should.

Does this dramatic change in update frequency mean we’ve gone from cloud to cloud to local hub to bridge for Hue? Would this also mean possible local execution for Hue Lights now? :slight_smile:

1 Like

Despite it being mentioned several times by different people in different threads, there seems to be silence about the fact that people using andriod on the UK shard see ‘null’ in the app for the firmware version.
Everything seems to be working fine and it shows the firmware version via the ide.

So… is anybody going to actually acknowledge this and give an answer???

@posborne @slagle

EDIT: And before the question is asked, I have stopped the app in my phone and restarted it. Even done a complet power down/up of the phone.

Try this:

1 Like

I’m assuming that it will auto-reconnect?

Since the update a presence sensor is going bonkers … Present / away etc … Will need to investigate what is causing this was working perfectly fine until then …

And as if by majic… it appears. :slight_smile:

Not android isue.
Had the same on iPad also.
Fix mentioned solved on all.

I’m having the same issue… Hub has been rebooting all day.

May be its finally time to move on to Hub V2 :slight_smile:


While I don’t think that mine is rebooting, it just stops functioning all together. I guess I’ll try and leave it unplugged for 20 mins with the batteries out and see if that makes a difference. I’ve just been leaving it unplugged for like 30 seconds and it will function for a little bit but then go back into doing nothing mode. I send commands from my phone to it with no luck.

Still not convinced. There’s even mixed reviews today regarding the Hue “fixes”; rumors that it breaks GE Links in some cases…

I’ve been having problems with several of my zigbee motion sensor and contacts both an Iris one and a PEQ model. I reset, re-pair but that only works for a short while and the sensors go dead again. Very frustrating! My wife keeps saying that I like to wallow in my own misery with the constant fixes that I have to do to keep my house running smoothly on ST automations. I also had a couple of GE Link bulbs drop off but fortunately, a simple power cycle fixed that problem.

If I issue the disconnect command to the hub everything starts to work again for a few mins then it all stops responding again

Hey, you cannot break the already broken. ST did the right thing in this case. The bulbs are deemed ‘unreachable’ by Hue, it’s a Hue problem.