Hub Firmware Release Notes - 0.31.4

We’re excited to announce the release of Samsung SmartThings Hub firmware version 0.31.4. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)

Release Date: 25 June 2020 ~ 26 June 2020

Note that this release may be spread over a few days, so you may not see your Hub update the first day of the release period.

Release Notes:


  • Refresh Z-Wave network routes shortly (up to 30 seconds) after network repair is completed
  • Firmware update for latest generation of SmartThings Motion, Multipurpose, Moisture and Button devices


  • Fix an issue where manual changes to FE599 & BE369 Z-Wave Schlage locks were not reported instantly. Users experiencing issues with these specific locks must exclude and re-add the devices with this firmware.
  • Fix an issue where the color temperature on locally running Zigbee devices is slightly different than the value that was set, for example setting a color temperature of 2700 resulted in a value of 2703.
  • Fix issue where the Zigbee PAN ID was changing due to a perceived PAN ID conflict
  • Fix the removal of the hub from all Zigbee groups on factory reset

Thank you to @Kianoosh_Karami, @Brad_ST and all the ST staff members behind the scenes (including Tier-2) involved with the Z-Wave lock fix journey.


Is this going to entail a update to the RBoy DTH also?

We released the update a few weeks ago but will make a formal announcement once the firmware has been deployed.


So, I have been completely down since 10 pm ET last night. Is this related and if so, since when does a MW take 18 hours? (Legacy App, V2 hub, and network is fine)

Does this update bring back the child device support that was removed with a previous firmware update?

I see the version 0.31.4 for hub - what FW version will I see reflected on my SmartThings Wifi / Hub combo?

Current value is “WV530XXU2ATE1”

This is only for the V2 and V3 hubs

Was the firmware rollout really completed in six and a half hours as the status page claims? It isn’t usually anywhere near that quick, and one of my hubs certainly thinks otherwise.

1 Like

@orangebucket, just give it a little nudge and reboot it. :wink:

Thanks. I think I’m good then, since I already updated it what I saw some other post about it.

Any details on the SmartThings device firmware updates? I’ve been having some issues with a few of my ST buttons, and I’m curious if this will fix it. I can see the buttons have updated to the latest firmware (0x00000014), but can’t find any details on what that is supposed to fix.

1 Like

Since the update mostly noticed improvements but I seem to have lost communication between my Red Series dimmer and associated bulbs via app control, on/off works but level adjustments aren’t being transmitted. Prior to the update the setup worked as expected.

For the most part everything works with voice as we set “the dining room” to a level as they are included, I just noticed this bug by accident as I requested just the dimmer set to level, but the bulbs stayed at 100% and didn’t respond to dimmer app adjustments either, new or classic. There is nothing in the logs for the dimmer forwarding the level adjustment just the switch rec’d and completed. My network consists of 30 Z Wave devices (only Zwave+), no S2 active, 6 battery operated and quick reaction time.
Added Home Assistant and ST integration today and levels can be adjusted through HA but still not ST???

Sadly reboots, soft resets, and being patient just in case the status message was wrong, have not made it change its mind. It is determinedly stuck on 30.5.

@BarryA, @posborne, has the firmware roll out finished, as the email stated?

Maintenance complete

Firmware version 0.31.4 has been released to all Samsung SmartThings 2018 and 2015 model Hubs. Please contact us via if you have any questions.

Time posted

Jun 25, 17:43 EDT

Is anybody having dimmers, switches and fan controllers stop responding? They update int he app but the load is not controlled. I am trying to figure out whether it is a DTH related issue, or something related to the latest firmware updates or changes int eh cloud.

I believe most, if not all, of the devices that are locking up are Homeseer and I have been making changes to the DTHs. Either way, once it is locked up, even reverting to a default DTH (that does not support extended features) will not fix the issue. The only way to restore the device is to power cycle it (using air gap if one is present).

Edit: The issue frequency increased quite a bit in recent times, and I have not made changes to the DTHs in a while, which is why I am checking to see if others are having these issues.

Edit2: To clarify… the dimmer/switch/fan controller also stops responding if you press the paddles.

New to ST world. My hub shows 000.031.00004 as the firmware version. Is the 0.31.4 being referenced here just shorthand for the version I have, or is my hub not updating? Thanks !

That’s correct. You’re on the latest FW.


I also see my SmartThings branded devices have updated to 0x00000014 from 0x00000011. I’d like to see more information about what’s in the update.

@mjhendriks @DavidAg02 the new firmware has some battery life improvements although it will help some devices more than others so it is possible you won’t notice a change.