Hub Firmware Beta Group, get ready to migrate!

@alissa.dornbos @nayelyz ,

Here we go again with migrated Zigbee devices going offline for no reason but still reporting “something”. I’ll have to reset and rejoin these two switches and hopefully the sensor will come back too:

EDIT:

Add another vent to this list. The guest bath motion sensor DID have a recently new battery but it went offline because the battery DIED and it was only 6 months new.

@alissa.dornbos if ST is listening, there’s a problem. In the last few years since I moved to all zigbee devices, and I have a ton, I’ve not ever seen this level of instability with devices going offline and consuming batteries like this, ever. I ran great for the last few years until Edge showed up and automations/routines changed. Now I’m having to check my devices every day, my routines are slow, or don’t work at all at times, my hub is flooded with RAW events that never happened before, and I’m getting worried that this is not going to improve any time soon.

EDIT

Add my Master Bed Tray Lights zigbee switch to the list today.

What do you mean by they still report “something”?
In the app, do they appear offline too? To check the device’s health through the API instead of the IDE, please use this command in the CLI:

smartthings devices:health device-id

Have you done this already? When we delete a device and recreate it, its device ID changes, which means the team cannot trace the logs to see what could have caused the issue.

Does that happen only for Edge-based devices?

In the IDE, Last Activity, it usually says within a few minutes or even “a few seconds ago”. I didn’t think about checking the CLI because I’m usually on my Chromebook and I don’t easily have a way to launch the CLI.

Yes, I typically have the cloud strikethrough icon for those devices.

Yes, sorry @nayelyz . The next time this happens and it’s not causing any issues I’ll let you know.

Yup, just Edge-based devices that were migrated. My other Edge devices using non-ST provided drivers have not had this problem.

Ok, please help us by reporting this issue to build@smartthings.com

We need the following:

  • Routines names - This is to see their config
    • For this include the behavior expected and how they’re working instead.
  • Access to your device’s data:

1.Go to the SmartThings Web (my.smartthings.com)
2. Log in to your Samsung Account
3. Select Menu (⋮) and choose Settings
4. Toggle on Account Data Access
5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

1 Like

I’ll work on that tonight.

Hi @nayelyz ,

Done, and really good timing! Ticket number 1390620.

I have a device called “Garage Refrigerator Outlet” that just went offline and is flooding my hub with these RAW messages:

raw:2D7D000022A300001CA232, dni:2D7D, errorCode:00, ieee:0022A300001CA232

image

@nayelyz - this is a zigbee metering plug so every change in watts it is sending the raw message. I’d really like to reset this plug, so please advise on if support has when they need so I can fix this.

EDIT. Fixed that outlet, but now here’s another doing the same thing: Sunroom Outlet Right. It’s now offline and sending raw messages to the hub:

raw:A5AC0014B457FFFEB2DD97, dni:A5AC, errorCode:00, ieee:14B457FFFEB2DD97

This is also a GE/Jasco metering outlet (not plug), and nothing is plugged into it right now so those raw messages will not be as frequent.

1 Like

@nayelyz, why would routines get disabled when i didn’t do it and none of the devices in those routines weren’t deleted from my hub? I woke up to find 4 routines disabled this morning. I updated my ticket with the names of the routines.

Hi, @johnconstantelo

The team is looking into this. We will let you know as soon as we have an answer.

1 Like

Thanks @andresg. The one thing that sticks out to me is that for both my Zigbee thermostats, Fan Mode is no longer a capability I can select in a routine, and I know that was there because that’s what a couple of my routines were using but now it’s gone. The only place anything fan related is in State, and it’s only “fan only”, not on or auto like it used to be. I hope that helps.

@andresg please investigate battery drain as well. Just had to replace two more batteries that I had replaced less than a month ago. All zigbee devices and rapid drain on most. Leak Sensors are the worst offenders.

2 Likes

FYI @andresg , it just took me 5 times, yes 5 times, to initiate my Goodnight routine and devices still didn’t get turned off. In fact, one of my apps to alert me that doors are left open too long just told me my kitchen frig doors and garage entry door have been open too long. They’re not by the way because I’m looking at them right now and they’re closed.

There is something seriously not working right, I’ve not had this level of instability since the early days of SmartThings, and it all started when the migration to Edge started.

1 Like

I thought it was just me! This has been an issue for me several times per day for weeks now.

@andresg ,

And miraculously “Fan mode” now partially shows back up again this morning, along with any associated Routine being disabled that was enabled…

Why would Fan mode be allowed for the “Then” part of the Routine, but not the If part? Here’s what I mean with two different routine examples: (FYI, notice the duplication of the capabilities)

Routine where the device is in the Then section:

A different Routine where the same device is in the If section:

BTW, I’m not trying to be difficult, I’m just trying to share as much of the weirdness with ST as I can to help figure out what’s going on.

1 Like

Are they leak sensors ST or with temperature capability?
Multipurpose also use up batteries fast?

ST leak sensors
Multi is about the same using Edge.

Leak sensors are draining at a rate of 5-10% a week. The one device that was migrated last week has dropped 19%.

I have been using @Mariano_Colmenarejo ST-Zigbee Moisture Sensor MC Edge driver for months with no battery problems. In setting you can adjust the temperature reporting intervals to help extend battery life.

1 Like

done that! entered 240 which is the max. tried ST Edge Driver also

1 Like

Leak sensors with temperature information have a reporting setting of 300 sec and a reportable 1° shift.

In practice, this means that it sends reports every 5 minutes with a change of 0.1°.

If you use my driver you can set those reports to an interval of up to 4 hours and the reportable change up to 6°.

In practice, it saves many unnecessary transmissions in a water loss sensor.

For the multipurpose ones, which I think use my driver, you can also adjust the temperature reports.

But the penultimate version had a modification to the acceleration reporting settings that greatly reduced the 3-axis reports.
I’m not talking about sensitivity, use the accel cluster configuration

You can see with the CLI if every 5 minutes it sends the closed or open status only or also the 3-axis one.

If it reports the 2 capabilities every 5 minutes, I advise you to uninstall the sensor and reinstall it, so that the configuration of acceleration reports at 1 hour is carried out correctly. This saves a lot of battery.

I am using your Driver and have it set to 240 min which is the max interval that I can set

I am also using your Driver

1 Like

But is very important for battery Life check the 3 axis configuration reports with CLI or uninstall and reinstall for a good configuration