Hub Firmware Beta 25.26

Anyone seeing stuff like this?

Device E1 is not even listed in my device list. What is it? Why is it spamming the network (or whatever those commands are)?

If you can find it in your list of My Devices, it could be an orphaned device (something that’s not in ST’s database but is in the Z-Wave controller). It should not happen, so maybe worth investigating by ST as to when it was removed from the ST database and why the controller still has it in it’s database.

If you want to remove it, manually create a device in the IDE, select the Type as Z-Wave Switch and set the Device ID to E1. Save it and then delete the device from the IDE and it will also be removed from the Z-Wave Controller.

This appears to be a caching issue on the cloud side. I’ve pointed it out to one of our cloud engineers and he is looking into it. Thanks for bringing it to our attention.

5 Likes

Yeah, I’ve done that before but why do I keep ending up with ghost devices, and above all, if they are no longer actual devices why are they generating traffic?

If they’re generating traffic means they’re still paired with the controller.

That’s why I had suggested ST look into it because if it’s actively paired it should show up in your list of My Devices. They can probably dig deeper to see why there’s a discrepancy. Tagging @cbaumler

1 Like

Is this to mean that Device E0 and E1 (both not in my list of devices) share the same MAC and IP addresses? Would be nice to know what MAC/IP/PORT refer to in this context. I understand it in the context of Ethernet but not zwave.

E1 is monopolizing my network right now.

EDIT: I just realized it says “index” not “Device” before the Hex value. Are E0 and E1 in my case actually a device (ghost or real) or something else?

I have tons and tons of “index” errors as well. I never thought they were errors until now. Some explanation on what they are and how to potentially resolve them would be much appreciated. Or are they just debug messages?

This is what i’m wondering too. I just checked my logs and have some index logs where the two digit ID is a z-wave DNI, but others that aren’t.

1 Like

I got confused… the Event List is indeed full of “Device: E1” related log entries and the “Index: E1/E0” were just a few.

I have an August Lock that I can no longer control. It works fine from the August app and reports the status promptly in the ST app. I tried removing/adding it back, run z-wave repair but still no control. This issue started in one of the last two firmware updates.

The messages you are seeing are mostly notification reports the hub is receiving from a device on your Z-Wave network. I think they get printed raw like that to the hub event log if the device doesn’t exist in the cloud-based device list. Do you remember doing any force deletes with the Classic app in the past?

Are you still having issues?

I pulled logs and it looks responsive.

Can you DM me the details?

  1. Which specific device is having issues
  2. Timestamp action was taken
  3. Expected result and actual result

I have two August locks. One has been fine. The other (the one mentioned above) still not working. Device —> Door Lock Front

While there’s nothing specifically going to South Korea, SmartThings is based on Amazon Web Services and those things can move around a fair bit. It should all be roughly in the US or in the EU (depending on hub model).

Ping me if you start seeing frequent disconnects again. Even better, if it starts happening again and you have the time and inclination, a packet capture from a mirrored port on your Ubiquiti router would be amazingly helpful. So far we’ve found firmware bugs in Linksys and Cisco equipment, might be fun to try to find something in Ubiquiti equipment :smile:.

EDIT: I’ll extend the above statement to anyone - if you have hub network issues (i.e. Ethernet/WiFi, not mesh networks) and you can get me a packet capture while it’s happening I’d be soooo happy. Just hit me up in one of these threads or PM.

2 Likes

Time to figure out how to do that I guess… Wireshark and a computer connected to a port that mirrors the WAN port, right? I’ll hunt for the settings in the Unifi Controller as I do not recall seeing such option.

I was writing that no device is supposed to be powered but not included and it dawned on me that this entire time I was sitting at my desk there was an Zooz 4 in 1 sensor that refused to properly include (lots of zeros in raw description, and security errors in app)… and it had been sitting there for a few weeks waiting for me to get to it.

I tried including it with the classic app but once again it was added like this:

(This is getting old)

I then recalled how to reset the sensor (I wish they had a standard!) and did so, then I tried again with the new app and bingo!

Sorry for the E1 distraction, it was active because I was sitting right in front of it all this time… but I have to say this confusion was ultimately due to my previous difficulty in pairing this Zooz 4 in 1 sensor. To be fair I had not reset it in a while as I could not remember how, so maybe that was what was wrong… a sensor issue of some sort. For posterity, and myself next time I forget, all I did was open the back, remove the battery, press the zwave button and insert the battery. Once reset it paired right away in the new app even though I picked the incorrect brand for it.

(Unnecessary detail: I paired my Zwave Toolbox, and found device 225 (0xE1) and it said it was a “Notification Device” which tipped me it was a sensor… and then it dawned on me…)

1 Like

FWIW, I am pretty certain these are the exact same code. This only shows up in NA01 and both DTHs have the same checksum.

Also, @bamarayne you can see the code is the same for both if you create a DTH “From Code” under My Device Handlers - https://graph.api.smartthings.com/ide/device/create.

Yeah, it’s a little different for each router/switch/etc, but often you can find information for your particular hardware on the Wireshark community. This is the general page for setting up Ethernet capturing: Ethernet

The most useful option would be a capture of the port that the hub is connected to, since that will let me see all traffic going to the hub and coming from the hub without having to filter out other traffic on the WAN. A lot of it won’t be readable because of TLS encryption, but I can at least see the general flow of network messages and lower level things like DHCP. But I would take anything I could get and if WAN is the only option I will absolutely make it work.

1 Like

Another thought for anyone who has network problems and has network hardware that supports exporting a config backup (such as the Unifi controller) - if you’re willing to send us your config we might be able to recreate issues here by setting up our own hardware to match your config.

3 Likes