Hub Firmware Beta 0.34.11

Version: 0.34.11

Hub Target:

  • Samsung SmartThings Hub (Hub v2)
  • Samsung SmartThings Hub (Hub v3) (2018)

Release Date: 18 December 2020

Release Notes:


  • Zigbee and Z-Wave Child devices were not marked offline when the Parent device was marked offline. An example of one common Zigbee/Z-Wave Parent-Child device is a Powerstrip where each outlet/endpoint has its own Device card in the mobile app.

Deploy complete minus a few stragglers. Beta participants should now be running 0.34.11.

All good here so far. In fact, it’s never been so rock solid over the last several releases. Do you do work on mobile UI’s by chance? :wink:


Looking forward to test this. Have lots of device handlers using child devices.

@posborne and @Kianoosh_Karami Please take a look at my hub. It’s rebooted itself 4 or 5 times now. I’ve not initiated any reboots.

The parent child device health relationship is working well here with composite devices.

1 Like

Same thing is happening with me now.

Just saw this was resolved.

Hi @Kianoosh_Karami, sorry for resurrecting this thread, but had anyone reported devices being offline in the IDE but working fine in the new app during this beta or after its official release? The reason I ask is that my internet was out for 24 hours, and when it came back all my devices (99% at least) still show offline even after 2 hours.

We have not had any reports of Device Health mismatch between the IDE and the Mobile app, and there could certainly have been reports elsewhere that I may have missed.

However, When you say that all your devices appear offline even after 2 hours, is that in the IDE or mobile app or both?

Just in the IDE. The hub has been online since ~8pm EST last night, but device state in the IDE still show offline:

The mobile app works just fine.

did you try rebooting the hub in IDE? :wink:

not yet. we’re away for now and I don;t want to take a chance of hosing things up. everything is working great, so I have no problem waiting.

Just to add to that… It was painful enough having no Internet for 24 hours while I was away. Surprisingly SmartLighting stuff ran fine, but stuff like Blink and Ring were dead, and that was no fun being blind…

1 Like

I couldn’t wait… Didn’t make a difference.

EDIT: just checked and all devices show online in the IDE. I’m not sure if that was due to a reboot or something else, but now at least my OCD can take a break… :wink:

1 Like

@johnconstantelo So the best source of truth for Device Health status is the Mobile app. I am glad this cleared up, should it happen again, the IDE is most likely to refresh within a display the same state as shown in the mobile app.

1 Like

I would argue about that statement. I have a TRV which has been disconnected from the Zigbee network, but both the app and the IDE shows that it is online, due to Automations which are changing values on it (setPoint), but in reality not.
The same applies for another Thermostat which used as a Thermometer only. Online in both the app and the IDE, but it physically shows being disconnected from the Zigbee network.

I bought a Hub V3 On the 24th November 2020 and it running 0.34.11 … Is it still in BETA ?
I only ask because last week Wednesday ,I lost ALL my devices on the SMARTTHINGs APP on my Phone, Tablet & ACTIONTILES. All my devices were still present in the IDE , as devices and as devices on the HUB.
SAMSUNG Remote Support have taken 5 days to make contact with me… So long that I decided to delete all from the IDE and rebuild my network , which took me 1 day.
I suspect it was some sync issue in the SMARTTHINGS cloud , since it happened on multiple devices but the IDE was OK . Obvious all the evidence is lost, but have others experienced similar issues ?
I was deleting device items from the IDE when everything was lost.

It’s no longer in beta. It rolled out to v2 and v3 hubs on December 21st. Did the devices show as online in ide? Did you try rebooting the hub from ide and clearing the cache in the app before?

Yes they showed ONLINE in the IDE , looked Ok there. But nothing on SMARTTHINGS on phone & tablet & ACTIONTILES. Tried clearing cache on the APPS but no joy… didn’t reboot the hub, maybe I should have tried that. It looked more like the SAMSUNG cloud was out of step and needed syncing… unfortunately no diagnostics now since I couldn’t afford to wait the 5 days for SAMSUNG support.