Hub Firmware Beta 0.20.16


  • 0.20.16

Hub Target

  • Samsung SmartThings Hub (Hub V2)

Release Notes

  • Fix potential memory corruption for some Z-Wave networks

  • Fix local generation of Humidity events

  • Fix memory leak in local Hue integration

Release Date

  • Friday January 26

Hi @Zach_Varberg,

When will this be released to Beta users?

The plan is over the next couple hours. But that can shift some depending on how busy people are.

Can you push it back until tomorrow?

This version has regressed for me. Device health had to be turned off. Issues should up immediately after push of this version?

@Zach_Varberg What were the symptoms of this Z-Wave memory corruption? Was it a routing table corruption? I ask this because I have a small handful of GE switches that have been reliable for years throw “Not Responding” errors frequently in the logs. They still work but are sometimes slow to update status.

What issues did you experience?

I only see a single device as offline and it seems to have been toggling between online/offline prior to the firmware update.

Any chance I can be added to this BETA? I’ve already filled out an application and it looks like it was just released.

Someone else asked the same question 3 days ago and got this response

1 Like

Throughout this beta test, my system has been working just fine, as it did before the beta. Keep up the good work guys!

JHi Brad

Three devices went offline shortly after the firmware upgrade.

Before the beta I had one door lock that would not work with device health enabled.

In beta 014 I turned device health on, and everything worked fine. Even through the 015 firmware everything worked well.

Shortly after 016 three devices went unavailable. Front door, garage stair lights and stair lights. One I turned devicenhealth off all worked again once i toggled the device.

However. I have spent a little more time testing this tonight, and all is back to normal with device health on. Not sure what happened.

Glad things are back to normal, let us know if see other abnormalities.

The Firmware Beta actually began about 16 days ago at 20.11. This is just a newer release of that. :slight_smile:

And what @jkp posted

If you happen to have a device with device node id of 0xE8, depending on the device, a memory leak could have occurred which led to abnormal system functionality.

I don’t know if related to Beta or the outtages of late. I have had to reboot the hub at least once per day because " everything" stops working. Once rebooted all the commands that had not fired over the past xx minutes/hours that the system had been unresponsive all fire simultaneously. Makes for a pretty good light show.

That’s an obscure one for sure. Thanks for explaining it!