Hub Firmware 17.x Beta


(Joe) #161

They may have pushed a file that fixed the cloud problem I am awaiting the beta but as one said no one on the na02 server has it. The file the pushed got me connected back to the cloud after a restart or internet disconnect.


(Ed Meredith) #162

So I guess that the email from ST stating that my hub was offline and I needed to try and reboot it for the firmware update was not accurate since no one on na02 has the firmware. Now that leaves me with more questions as to what ST pushed to my hub that has caused all of these issues with ZigBee devices. I just rebooted again and in the IDE it states that ZigBee is functional but lists all ZigBee devices as offline and the last communication with any device on my hub ZigBee or zwave was 10 hours ago but that is not true as I have lights that I have turned on and off via the ST app in the last couple of minutes. Whatever was pushed it has wreaked havoc on my devices.


(Joe) #163

Did you submit a help ticket?


(Ed Meredith) #164

I have submitted a support ticket so I will update further once they reach out to me on it.


(Benji) #165

I think it prudent to mention this again. You volunteered for this beta. Even if your hub hasn’t successfully made it to the beta version, the flash itself to that version is also beta, if you weren’t prepared for these consequences you shouldn’t have volunteered for the beta.


(EinarS) #166

HUB disconnects when i use a z-wave lock. not all the time, but since it goes offline i have no way to fix without reseting og remove power.
The hub is answering ping, so it is online.
Removed all smart apps, now using stock Device handler for z-wave lock.
Did a rejoin for the lock.
But stil disconnects, and everything in the house is back to the 90´s
Help please!!! :slight_smile:


It registers the open, and then dies, the locked comes when the hub have been manualy rebooted.


(Ed Meredith) #167

I agree wholeheartedly. I know that I agreed to the beta and I fully expect problems. While it’s frustrating for me I am okay with it because I expected issues. Consumers will not be. Not having use of some devices makes the beta not very useful and testing is compromised if some devices don’t work. Beta rule 101 you have to be able to test or it’s not beta it’s an experiment.


(Joe) #168

Most regular consumers are not on here which is why the beta was asked for us to sign up. Also again they are having a cloud issue which is separate then the beta. If it loses connection to the cloud it doesn’t reconnect even it it shows green on your hub. I was told they had a fix and that’s what they pushed to mine last night. I signed up for the beta but no one that I know of on NA02 is on it due to the cloud issue.


#169

I wish i can try out the firmware… My hub is on its way back to ST for analysis after failing to boot (solid red led) after the firmware upgrade. My legs are getting tired having to walk around to turn off lights…


(Paul Osborne) #170

Hi @einars, please send an email to beta @ smartthings.com if you haven’t already. Symptoms here match a crash in the Z-Wave code, so definitely something that will be a high priority for us to address.

Since we are seeing a few issues, there will likely be an update to the beta that we will prepare and ship out to the beta list. We’ll try to provide more timing as we near that place (likely after our internal alpha/beta/rc depending on the scope of any changes).


(EinarS) #171

Done as an update to the case i already have posted.
But since it was weekend i used the community.
Have had the issue at least 7-10 times now.

Regards


(Benji) #172

All very valid points but general consumers shouldn’t be signing up for any beta tests. Even if you can’t test anything, your beta test was successful, it looks like from your issue they’ve found a possible problem with the firmware and that’s a good thing.

Even if a beta test lasts a fraction of a second, results in a total loss and no further testing… but they find out what caused that total loss, you can absolutely say that was a successful beta test. Might not be a very happy/satisfying result but you’ve helped people. :slight_smile:


(Joel W) #173

When I signed up, I didn’t expect everything to work. But I figured that this Beta would not have been released in the wild without some in house testing. For me it was a OK experience, And the problems I had before with WeMo haven’t changed. I found a Z-Wave problem, where a device would go off on its own. Well today so far it has stayed On. That’s a good thing. All in all the staff did a great job, for an Alpha.


(Joe) #174

It was not released into the wild. It was released to people that are used to testing and can provide feedback before releasing into the wild.


(Jason "The Enabler" as deemed so by @Smart) #175

I’ve not noticed a single difference in my system from before the beta update… still running strong here.


(Nick Stevens) #176

I want to take a moment and personally thank everyone that’s enrolled in the beta. It’s disappointing that there have been bugs, even more disappointing that some have been seriously impacting your usage. We put this release through testing on over 100 hubs internally including long periods of “dogfooding” on our own hubs, and we thought we got the kinks worked out. Clearly there’s still more to do, and I’m glad we have an awesome group of beta testers standing behind us to help get us there.


(John) #177

Just curious, but have you identified a pattern?


(Nick Stevens) #178

I’ve been specifically working to organize as much data as possible so that we can look at the bigger picture and look for commonalities. We have some ideas and may ask for some help testing theories over the next few days. No single smoking gun at this point though.

Which does remind me of a favor to ask. If anyone gets into a situation where their hub is connected but ZigBee or Z-wave devices are not responding, and can spare some time without hub functionality, please email beta@smartthings.com before trying a reboot. There are some additional logs that are lost when the hub reboots that could be really helpful. Thanks again!


(Joel W) #179

With enough beta testers reporting problems, it will be easier to track down the problems. Some of us aren’t having major problems, but others obviously are. I know my problem with the Dragon Tec Plug is Z=Wave related, but I am narrowing it down. I am almost sure it isn’t the firmware by itself, but a combo of the firmware and the DTH. I am testing now with the generic Z-Wave device type just to make sure.


(Jason "The Enabler" as deemed so by @Smart) #180

Well, the beta just bit me in the butt.
I had a zwave switch that was not reflecting the right status in the app, it was still responding. I tried to do a replace/repair on it… the hub went off line.

just a blinking blue light.

I waited a few minutes and rebooted the hub (unplugged it)

now, I just get a solid blue light.

edit…

false alarm… it’s back… just took almost forever to reboot… sorry :relieved: