Hub does not support edge drivers?

Welcome to the SmartThings Community, @Hwa_Hwa_Ong!

Can you share the Hub model and its firmware version, please? Edge drivers are supported since version 38.

I have a new Aeotec Smart Home hub:

When i click on ‘Driver’, i don’t see any drivers.
So far, i have only installed a few Fibaro devices, and i don’t see the driver option for any of them either.

Any ideas?

You won’t see any drivers until there is a driver already on your hub.

At the present time, we are still in the transition period, so most people don’t have edge drivers unless they either subscribed to the beta channel or they downloaded a custom edge driver.

The production edge drivers will start being downloaded to hubs in the next few weeks, and then roll out gradually over the next couple of months.

So it’s not surprising if you don’t see any now.


This transition sucks. I week ago I was able to load an edge driver on my ST WiFi hub. Today I had to reset and re-add the hub to my location. Now I can’t load any edge drivers on the hub. Get the same error as others. Hub does not support edge drivers. WTH Samsung!

Hi, @Its2loud, Can you check the current firmware version used by your Hub, please? The one on the screen above belongs to the Wi-Fi Router
There are some instructions about it on this post:

@nayelyz Thanks for your reply. This is a very confusing situation indeed.

When I open my app I show two hub devices. One is the apparently the “Router” and the other is the “ST Hub”. This is thoroughly confusing and I don’t remember this being the case prior to 10-10-22.

This is my “router” firmware

This is the “Hub” firmware.

The problem it seems is that I have devices connected to both of these, which shouldn’t be possible. The devices also show as online.

I can only control the devices associated with the “Router” but when I look in the IDE is see two active hubs

This makes absolutely no sense to me. I cannot add edge drivers to either one. But WHY on earth would the app be showing TWO hubs as being active in the same location. Thanks for the assist.

BTW, I’m not getting a prompt to update the firmware on any of the devices.

Just for grins. Here’s a screen capture of the “Hub” that shouldn’t be showing any active devices since I had reset ALL my hubs prior to re-adding them back into the app.

When I add in any new devices it adds them to the “Router”

Soooo, what’s should be the correct setup here? One Smartthings Wifi Hub with Smartthings turned ON?

and one more thing. If I tap on the “Router” and go into the MANAGE SMARTHINGS HUB on the app and the tap the three dots in top right for “information”. This is what I see. No firmware version at all

My app shows BOTH devices. As you can see here.

This is a very messed up situation that I hope can get resolved very soon. Thanks.

mmm this is strange, I’ll open a report for the team to check what’s going on in your case.
To do so, please provide the following info to

  1. The email you use for your ST account.
  2. Access to your account’s data:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. Replicate the issue but this time install the driver from the CLI, this is to get the complete error message.
smartthings edge:drivers:install

The CLI will prompt you to select the channel, driver and Hub, so, just type the corresponding number that belongs to it in the list and hit enter.
4. After replicating the issue, please send the Hub’s logs through the IDE:

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below "send hub logs

Thanks. Just sent the requested information. Posting the complete CLI error message on here as well.

FYI, The CLI did not give me option to choose a hub to instal the driver to. But I get the same error when trying to install the driver on either hub that shows in the app and in my IDE

In addition. I do have a case number and was supposed to get a call back from higher level tech support within 48 hours but that has not happened. So far, everyone I have spoken to in tech support has not been able to find a solution to this issue.

I still have not been contacted by any engineering support team member and it has been a week without the ability to add edge drivers to my hub

Hi! I already replied in the thread of In order to avoid duplicating information, please, let’s continue our conversation there.

Hello Nayelyz,
For a strange reason, our Smarthings WiFi Hub does not support edge drivers anymore…We’ve started getting the BadRequestError message lately, after we’ve reset the hub for a fresh installation.
Can you please help clarify the issue?
our firmware version is: 000.043.00005.


Looks like I’m not the only one. @nayelyz please do what you can to fix this ASAP. TY.

Another issue we have is the inability to add our IKEA motion sensors to the system anymore.
It seems that the hub does not go into the ‘discovery mode’ anymore…

Are you on iOS? Bug in the current version of the app. There are several workarounds posted on the forum here.

You are right. We are on iOS.

I think Ikea motion sensors are FUBAR’d on SmartThings until this pull request is moved in

Thank you for sharing your experience, does the “BadRequestError” you get also say “Edge drivers are not supported”?

I already shared your comment with the team.

The new iOS app release ( solves the issue.

Thanks for getting back to us Nayelyz,

Confirmed it also says that “Edge drivers are not supported”.

We have the latest release of the app installed ( and still experience this issue.

Mmm is it happening only for that specific device?
Have you verified if you see the Hub’s LED blinking or get any logs in the logcat?

It’s a series of devices we have issues with.
The LED on the hub does not blink to indicate that it goes into “discovery mode”. It stays solid green.