SmartThings Community

Hub action call in dth crashing hub since last firmware update


(Mike Maxwell) #1

I wrote a simple dth some time ago to mute my onkyo, this dth has worked fine up until the last firmware update.
Now I can crash my v2 hub every single time I execute one of its commands.

No idea where to go with this one.
Anyone else having simular issues with hub action calls?

Were there any changes to the hub action method?

At least I’ve figured out the cause of my hub reboots…


(Geko) #2

I have a couple of DTH’s that use hubAction and they seem to be working just fine. Are you sending HTTP requests?


(Mike Maxwell) #3

No these are Lan requests:
def ha = new physicalgraph.device.HubAction(msg,physicalgraph.device.Protocol.LAN,state.dni)
return ha


(Mike Maxwell) #4

@Jim what changes were made to physicalgraph.device.HubAction in the last month?, specifically the physicalgraph.device.Protocol.LAN option.

I can repeatedly crash my hub sending specific char sequences now, where prior to the firmware update this DTH worked just fine for more than a year.


(Mike Maxwell) #5

I’ve specifically isolated it to the following:

def sb = StringBuilder.newInstance()
sb.append(“ISCP”)
sb.append((char)Integer.parseInt(“00”, 16)) //boom…
return sb.toString()

send the above as the first param in the hub action call using physicalgraph.device.Protocol.LAN as the second…
It seems that “00” must follow the initial arbitrary text, since “00” won’t crash the hub on its own.


sendHubCommand taking a long time or getting congested after recent upgrades?
#6

We’re looking into it. Thanks for the report.


(Mike Maxwell) #7

So I pulled the dth causing reboots from all automations, reboots have stopped.
This resulted in a solid single day of operation, but now I have a motion detector stuck in a motion state.
The logs for this detector show it going bat shit crazy on and off at for several hours while we were sleeping, then nothing.
Battery reports 66%, if that can be beleived…

I guess I should just schedule reboots like so many others are now doing, except I can use this handy dth I have to implement it…
(Yes people, sarcasm mode on)

So replacing the battery “fixed” that one…
Is the battery level reporting that far off? 66% is dead?