HRT4-ZW or SRT321 progress?

I’m really trying to integrate my room thermostats to ST. I’m in the process of transitioning all my devices from a few Vera’s but I cannot get the pesky HRT4-ZW to work at all

So in each bedroom I had a HRT4-ZW paired to an electric relay or sorts.
I want the local control for visitors or fine tuning, but mostly they are controlled by the hub to set the routine work, up in the evening, off in the morning etc. Basic stuff.

I cannot for the life of me get the thermostat to wake and accept a SetPoint from the ST. What am I doing wrong?

I have tried a number of handlers, nothing.
The best one I have found is the meavydev one. With this one the thermostat reports back room temperature changes to ST on the degree resolution when it changes. Ok.
If I also change the 'stat locally/physically, that set point gets reported back to ST. Brill.
I cannot send a SetPoint to the 'stat where it updates. At all. The recent activity shows that a new SetPoint has been set. The physical device never recieves it though. It’s like it’s not waking to listen (even with a manual wake with the dip switches).
I’ve tried core sending a new “quickset heating point” (??), a “heating SetPoint”, a variable update … nothing.

At the moment, I have disassociated the thermostat and the switch. The set points all go through ST, if SetPoint greater than Room temp, turn on etc.
I’m not happy with this as there is no fail safe for ST failing, or the room temperature not updating. I’ve still got to build the trust…

Any help would be appreciated. Sorry for the rant.

@brumster May be able to say more, but based on the following thread, it looks like this integration is currently broken even for people who had it previously working. So I would start following that thread.

Tried the zwave tweaker handler and had the following:

warn zwaveEvent(): No handler for command: ThermostatModeSet(mode: 0, reserved01: 0)

It looks like there’s a new problem that was introduced on April 20 that is breaking the DTH is for this device. If you want to follow the coding discussions they’re in the following thread

Otherwise it might be best to just wait until the people using this device have a workaround in the DTH and then you should be able to use that.

Finally had the firmware come through, so on 17.13 now. Removed and readded the hrt4-Zoe and all good.
Thanks for the help.

Onto the C-stat 17-ZW now. :frowning: