How to turn ZigBee radio off?


(Shang) #1

Hi, I would like to turn Zigbee off, but can’t find in the IDE.


(Dan P Parker) #2

Well, that certainly explains the “How to turn Z-Waveoff?” title.

In any event, you can’t turn either of them off. Why do you want to?


(Pizzinini) #3

I have not tried it but I think this is it:

IDE -> My Hubs -> Utilities -> Disable Z-Wave Module


(Dan P Parker) #4

OK, my bad. I haven’t seen that option, and there’s no access to it via the mobile app (for either radio).


#5

I think all smartthings sensors. Contact, multi, motion, water etc are all zigbee. It would make no sense for them to allow people to turn the zigbee radio off, people would complain that all their devices aren’t working?


(Mark) #6

I’m also curious, why choose a multiprotocol home automation hub if you want to disable one or more of the radios in it?


(Shang) #7

I have the hub next to my router and the wifi connection is not stable.


(Ray) #8

Try changing the channel of your WiFi router and move the router or ST hub away from each other.


(Shang) #9

I tried and the wifi connection still not stable.


(Mark) #10

Do you mean your zigbee signal is interfering with your wifi signal?

Isn’t that unlikely?Usually the interference between zigbee and wifi results in zigbee problems. Not wifi problems.

Signals to/from most zigbee devices are probably much lower power than wifi devices.


(Dan P Parker) #11

What WiFi connection is not stable? Between your router and one other device? Multiple other devices? Have you tried using one of the many network analyzer apps available for Android and iOS to determine if you have neighboring WiFi signals causing interference? The Zigbee radio in your ST hub seems like the least likely potential cause of WiFi problems.


#12

I would get in touch with support. I don’t think there’s any way for a customer to disable the zigbee radio. And I’m all in favor of people being able to turn it off if they don’t want it for whatever reason. That would most typically be for diagnostic reasons, but they might also have some Bluetooth equipment nearby that they want to use.

All of that said, As @marktheknife said, it’s extremely unlikely that the SmartThings hub zigbee radio would be affecting your Wi-Fi stability in any way. Wi-Fi transmissions are typically 100 to 200 times stronger than zigbee home automation transmissions. And zigbee home automation messages are both very small and infrequent.

Problems with Wi-Fi are almost always caused by architectural features, such as concrete walls, or other nearby Wi-Fi networks. Or just by having the network trying to do too many things at once, which might mean other people logging into your network or malware, but might also just mean some heavy use apps like dropbox running too often.

You can certainly see if customer support can turn off the zigbee radio in your Smartthings hub, but I doubt if it’s going to have much impact on your Wi-Fi stability even if they can.

The following is a good article on how to improve Wi-Fi coverage that might be worth a read


(Mark) #13

That would suggest it’s even less likely the wifi issues you’re experiencing has much to do with the zigbee radio in your hub.


(Ray) #14

Easiest thing to test is turn off the ST hub and see the WiFi is stable.