How to set up negative value in "Extreme Temperature"

I am monerating my freezer with Aeon Labs Multi-Sensor.

Ok temp is minimum minus 18 celsius.(-18 °C )

I want to set alarm for when its to hot, and that is minus 15 celsius. (-15 °C )

But this it not possible, only 0 celsius is possible and this is really to hot for a freezer.

Hope some one can help me.



Bump… anyone have a solution for this?

Not sure if this is possible.

@Tyler any ideas?

Before i set up with a minus “-” in front of the number but not working anymore.

This is my old setup on 1 of my freezers:

But now i get this when trying to set up a new freezer:

Gosh… I can’t resist a tiny joke here and mention that positive temperature values are sufficient if you use Degrees Kelvin (i.e., relative to Absolute Zero) :wink:

Does the sensor return negatives? In which case it is just a datatype validation issue in the SmartApp or input method?

dont understand your joke, but before it was possible to put - in front to get -15 celcius now 0 is the lowest number possible to set up.


Looks like you are using an official SmartThings “Solution SmartApp”, so please email

Meanwhile, I can check around to see if there is an alternative SmartApp to use instead.

It is definitely a bug in the Solution SmartApp. I confirmed that the same preference setting limitation exists on iOS and Android, but is not a problem in the Simulator.

The “number” datatype on the “preferences{ input() }” method does not allow negative values. Perhaps it did prior to some change in the UI which did not previously limit number to unsigned values, or maybe the SmartApp previously used a different datatype like “text”.

With a custom SmartApp, there are lots of ways to workaround this. Best way I can think of is to have two input fields: “number” and “sign” (where sign is an enum of “+” or “-”).