How to determine what is causing ST Mode changes?


(Hendre) #1

I have an “On Holiday” Mode which I turn on with a Routine.

Something is changing the mode at random times away from “On Holiday” and I have been unable to determine what is causing the mode to change. It could be another Routine (although I’ve have removed automatic activation of all other routines), or a webCore Piston or who knows what.

My question is - how do I determine what is causing the mode to change away from the “On Holiday” mode?

I have set up a webCoRE piston which sends me a text when the mode changes to ensure that it immediately comes to my attention, but still I’ve been unable to determine what is causing the changes.


Changed from home to away
(Dan) #2

One common way to change mode is via Rotuines. Routines can change mode based on changes in “Presence” or even based on “Timed Events”. Take a look through all of your Routines to see if any of them are configured to change the mode.


(Hendre) #3

Thanks for the suggestion DAN. I’ve gone through them all to make sure that none of them has anything set in “Automatically perform…”.
I’ve even gone so far as to delete some of my routines.
I’m obviously missing something, but need a way to determine what is causing the change. (It could obviously also be a smart app, but I have very few installed, as I try to do everything with webCoRE.)


(John) #4

Have you tried going to Live Logging in the ST IDE and then once the mode changes see which routine or piston is changing the mode? I’m not sure exactly what gets logged for mode changes but for devices you can see the name of the piston or routine that interacts with your device.


(Hendre) #5

I’ve tried that, but the problem is that (apart from if I’m mistaken), one has to keep the Live Log open all the time (is there a way to go back to earlier logs?) and I’ve so far been unable to catch the change with the live log open.


(John) #6

You will need to keep live logging open


(Hendre) #7

It happens so seldom, it will be pure luck to catch it like that and that’s why I was hoping there is another way. (It happens maybe once a day. Yesterday it did not and I thought I’ve solved the mystery. Today it happened twice!)
The Hub Events log does not seem to record mode changes.