How to add Harmony Hubs?

So I’m struggling through with my Smartthings setup and I’ve managed to get the following working:

1 out of 2 outlet switches - I think the broken one’s reset switch is broken.
3 out of 3 motion sensors
15 Hue bulbs
2 wemo switches
1 Nest thermostat - had to change the code from F to C as my nest defaults to C via the API

But I can’t get my Harmony Hubs to work at all. I’ve tried adding the connect client app and when I launch it it says:
HTTP Status 500 - Cannot get property ‘authentication’ on null object

I can’t add the connection in the reverse (control SmartThings via Harmony) as when I go to approve the Hub it gives me a drop down to choose the SmartThings hub but nothing to choose from.

Anybody got this working?

It’s not working yet in UK :confused:

Support are aware of it as far as I know.

That explains that then :frowning:

Begining to wish I’d not bothered and stuck with adding z-wave switches to my openHAB server as even that beast seems easier to configure and setup.

I’m sure it’ll get there. Though I’d expected it to be less buggy than it is, I’ll stick with it. The community seems good and the SmartThings team do seem actually be listening to people.

It looks to be basic stuff that they haven’t thought through causing problems which is what makes it particularly frustrating. This seems to be caused by them using a new server farm for the EU and not adjusting the links in the apps properly.

I’ve tried to go through the oauth process for a couple of things now including Harmony and its breaking when it gets directed to the graph.api URI for the US as I do not have my hub registered there. However if I edit the URL and add in the EU address (currently using it’ll then allow me to pick my hub from the drop down, then on the next page choose what I want to authorize, and then I only get an error when it actually goes off to generate the authorization id/secret:

Oh No! Something Went Wrong!
500: Internal Server Error
Reference Id
Tue Sep 15 15:18:02 UTC 2015

I get the same problem with simple rules builder.

So it looks like oauth isn’t setup properly for the EU farm…

I have got smartthings working with the harmony hub…

Here are the steps…

  1. go to and create a new app based on the Harmony app template
  2. edit all links to graph.api to graph-eu01-euwest1.api
  3. enable OAuth in app settings
  4. copy the Oauth client and secret to the custom keys in settings dropdown (clientId and clientSecret)
  5. install for me
  6. install the app within the smartthings app (on authorisation you have to just hit next as it 404’s but don’t worry)
  7. open the harmony app on your computer with remote plugged in
  8. link with smartthings and wait until you get to graph.api.smartthings
  9. once you are there you need to change the url to point to your app (OAuth clientID)
  10. sign in and choose devices… you will then be returned to harmony and it will work.
  11. open smartthings and find the harmony app you installed earlier and you should now be authorised and can choose your activities.
  12. sit back and enjoy your newly linked activities so that you can trigger them on motion or prescence or whatever you want…

second this, harmony hub working perfectly fine. Added on December 27th. Most reliable part of my entire setup.


Later today, when i arrive home, will try to finish the steps.

But until step 6, every thing works.

If i try to enter Harmony Credentials, now i get

{“error”:invalid_client",error_description":“Client authentication failed.”}

Thank you.

you have to ignore that error just hit next and choose devices and then link from the harmony hub to smartthings which then saves the oAuth Token for Harmony


For the next steps, i need to be at home to connect the harmony app to the hub, hope that every thing will work :smile:

Update — no luck

In step 8,

Using the harmony app, (country uk) select SmartThings, then open the browser.

In there I have change the last pad of the url, copy the OAuth client ID, then enter (to go to the new pad)

Then select the location / devices

Save and then…

"internal server error "

Any idea? :confused:

Maybe because of this?

" 6) open the harmony app on your computer with remote plugged in"

Because I’m using the only the hub?

(2) Update >

After i change the (OAuth client ID) , select the devices, then “Authorize”,

The next page is a white page with this link >

and the page only says " Internal server error"

did you put the oauth client id and oauth secret in the app settings and enabled oauth?

You have to copy them from the oauth section to the app settings sections :smile:


Yes, i did all that >

Did i miss any thing?

And in the code, i have change 2 links >

def getServerUrl() { return “” }
def getCallbackUrl() { “” }

when authorising using the harmony did you change the URL to graph_eu01 ? I think i missed that step…

Yeap you missed that step, but there is no need for that now. One more importanted step to had the “Device Handlers”,

Using this topic, its working now.

Thank you for your help. :slight_smile: