Honeywell Smart Wi-Fi Thermostat Compatibility

You create a new device, under Devices, and then set this as the Device Type. Your custom Device Types usually show at the end of the list. Then when you first use the Thing on your IOS device, you’ll have to set the values for your Total Comfort login and Thermostat number (assigned by Honeywell, at the end of your URL when logged into Total Comfort website). Alternately, you can set these in the IDE after you create your device and re-look at it, after clicking it in the Devices list of the IDE.

[Also, you apparently set the Device Network ID, when defining the new device to the hex conversion of its IP address. You can find online IP-to-hex converters. I don’t know if this really matters, since the code never seems to talk to the device itself. Instead, it talks to the Honeywell TC website, which in turn talks to your thermostat.]

1 Like

I should have followed this closer… just finally took the time to debug my devicetype… seems very little changed, they were just a little bit more strict about what cookies they were accepting as well as no longer sending weather data.

Are you updating your device type? My hack works, but I was just fumbling in the dark.

I have some obligations tonight but should be able to get to it late tonight or tomorrow. I have it working fine on my phone. Will post an update when I update my git repository.

New to forum, brought in the device type and it works, it impresses me how quickly this community implemented this functionality.

Question: My device in the interface only seems to update when I hit refresh. Otherwise, it doesn’t update on it’s own. Any ideas?

1 Like

Thanks Jody! That’s a great tip.

To return the favor, I would point you to StatusThing. It puts the status of selected ST things onto your Mac’s status bar. It also allows you to control simple things there as well (on/off things). I find it super useful because when I get home, I put my iPhone on my dresser to be charged and lose my ability to directly control my smart things. I’ve pretty much covered this with a few of the GE remotes (often on sale for around $12) and StatusThing. [Unfortunately, I can’t show the Honeywell Thermostat on StatusThing without crashing, so I just leave it off the list.)

1 Like

Trying to get this to work currently, tried the device type Bruce posted, still not connecting. Any updates?

What’s the main difference between your two device types?
Can you post some new screen shots?

I just installed the Honeywell RTH8580WF. With the cool mode ON, I want ST to set my AWAY temp to 84deg, and my HOME temp to 79deg. I’m using my Android phone as the proximity sensor.

Also is there a way to automatically turn the fan from ON to AUTO after X minutes? :slight_smile:

Great work you guys, I look forward to it.
@Ben Any talk of ST making one of these official?

My device type is a blend of the one by @ethomasii and another I found on github. The difference is that I made some tweaks to conform to the new cookie handling by Honeywell and I added some formatting tweaks for the heat and cool setpoints. You can use ST to set the away cool set point and heat setpoint. I don’t know of any way to set the fan mode via a smart app, as I have never done anything like that.

I get this when I past your code into the web IDT on ST:
“java.lang.RuntimeException: Metadata Error: input() can only be invoked inside a section definition @ line 15:”

Can you help me out?

You have to save it and publish it, then create the device using your new device type. At which step are you getting the error?

When I past the code and hit save.

Make sure you have all of the code copied. I was able to paste it into a new device just now.

still. I saved the code as RAW data into notepad and selected all. And then pasted it into the new app which I created in the developer tools on the ST site.

java.lang.RuntimeException: Metadata Error: input() can only be invoked inside a section definition @ line 17

Not sure what is causing your issue. Did you remove the code that was automatically generated?

you got teamviewer? or a way to im directly? I can show you

I still get this. What settings do you enter when you create this new app in the ST IDE? Maybe I’m doing something wrong.

Try this code

1 Like