Honeywell Evohome 2020 device handler update

Hi! I’m doing well thanks, how about you?

I get the same error, I was wondering…Wouldn’t you need only the control of heating setpoint since this sets the temperature you want?
The event of setHeatingSetpoint changes the thermostatOperatingStatein the Detail View (eg. from “idle” to “heating”) and shows the same value in Set Temperature, which comes from the ThermostatSetpoint capability (its presentation, doesn’t include an Automations section).
It could be appearing because it was included in that part of the device configuration.
I left it off my device’s automation (see my last gist) and now it appears like this:

What is your position on this?

I am very good. Getting ready for my Christmas vacations. I need to pray to my servers before that though :stuck_out_tongue: (I work in IT).

I totally did not catch that change on the configuration file you send me last time. I removed the lines and created a new presentation VID. Now all seems good :slight_smile: Thank you.

I hope they listen so you can enjoy your vacations. :tada:

Awesome! Good job. :ok_hand: So, Could you now mark this post as solved, please? I’ll still be here in case more doubts come up.

1 Like

Sure thing! Thank you for all your help!

1 Like

@nayelyz hello again :slight_smile:

I am having a few issues with the Evohome integration and i was hoping you can help me out.

  1. At the device’s settings i have changed the Setpoint Duration setting “Until” to permanent but it still uses the next switchpoint. I get no error doing this, it just doesn’t seem to do anything.

  1. I cannot see the evohome thermostat as a device in either the keep me cosy or the thermostat mode director smartapps. I assume the smartapps need to be updated to support the new thermostat capabilities in order for evohome to appear there?

  1. Changing the temperature using the Alexa app, gives me a Device doesn’t support requested value error. In the alexa app you can only change the temperature using .5 increments. Do i need to change the Evohome Smartapp to accept increments, or is this something Smartthings app doesn’t currently support.

Thank you.