SmartThings Community

Home Automation Dashboard (HAD)

dashboard
project_dashboard

#1047

No go one the slider still, but the toggle + and - work fine so I’m sticking with those! Thank you!


(Brandon) #1048

It really should work. I tried it on multiple devices. I can’t stress the importance of the location of the touch currently. Please see the screenshot.


#1049

Im using a Fire 7 with fully kiosk, I tried touching all over to see if I could get it too function but it didn’t, possible do to the device since you have it working on multiple, its not a big deal as I like the the static + - buttons!

Any luck with the traffic widget?

Cheers!


(Brandon) #1050

I haven’t had a chance to look yet. Already spent my allowed time away from the kids for the day. The post looks promising though.


#1051

@bmmiller
Just wondering if you are having any issues with your dashboard at the moment? Mine stopped updating so went to re-authorize the dashboard with Smarthings. After I select all the devices and hit authorize it leads me to a page that says internal server error. "herokuappname"herokuapp.com/smartthings/oauth/callback?code=ItHVBH

Any ideas on how to fix this? Thanks!


(Brandon) #1052

I am out of town at the moment but I loaded things up on my phone, same as ever.

I went and did a reauthorize anyway, just to test that and everything seems fine. Loaded the dashboard up just fine.

I can’t really sit and watch on my phone and watch for updates but sounds like whatever issue is isolated to you, or at least isn’t everyone. Can you try rolling back to a previous version from within the heroku website?


#1053

No worries!
I ended up re-deploying the dashboard and that allowed me to re-authorize with smartthings. Everything is now working as it should except for one presence sensor. When I get sometime to trouble should Ill try removing the device and adding it back to see if it gets up and running again. Thanks again for all your help and Happy New Years!


#1054

Just an FYI, it seems that google must have updated there API or something has changed, but the map widget is now working perfectly. It loads right up and with the correct Lat and Long… Enjoy your weekend!

Cheers!


(Brandon) #1055

Nice! That’s great


#1056

Having the same issue. Where did you change the site setting you are referencing?


#1057

Are you asking about the google maps?


#1058

Nah, when you had the issue with the authorization portion in smartthings. You stated you were able select the respective devices to control, however when hitting authorize you ran into an internal server error. I am having the same issue.

I tried to modify the stabb.rb file with the US URL https://graph-na04-useast2.api.smartthings.com/ but still no luck. Is that what resolved your issue?


#1059

Yeah so I have uninstalled, re-installed, ran out of app name ideas and so forth. Any who the last step of authorizing the app to ST (OAUTH) is not working. I am steadily getting “Internal Server Error.” I have modified the stapp.rb file however when I utilize my smartthings auth link (https://your-app-name.herokuapp.com/smartthings/authorize) I still get redirected to the graph.api link rather than the US link on graph-na04.

In addition, I have done a git pull and push to publish the update and nothing. Any help would be extremely appreciated. PRETTY SURE IM MISSING SOMETHING STUPID but who knows.


#1060

Fixed I didnt commit the change when I modified the URL in stapp.rb file


#1061

So are the tiles supposed to auto update once I authorize or do I need to change them myself?


#1062

Disregard again im in there. No one responding as this conversation is old/dead but able to resolve my issues slowly but surely because of this thread. So Thanks ALL!


(Devesh Batra) #1063

try searching for open-dash or ActionTiles. these are newer and currently worked on…


#1064

Sorry man, been busy with work! Yes open-dash and ActionTiles are much better and are currently worked on. This dashboard has been working perfectly for me over the last year (minus a few little issues).


#1065

No worries. Yeah I made the switch already. Didn’t know about it but now I’m good. Thanks


(Raffaele) #1066

I would like to works out my SmartWeather Tile in HaDashoabors by FlorianZ. What I’m requesting is if I need a PWS or some hub to get the API KEY to put in smartthings.rb.
Any help is greatly welcome.
Thanks