SmartThings Community

Home Automation Dashboard (HAD)

dashboard
project_dashboard

(Brandon) #984

Just to get a better idea of things, are you using the repository linked in the first few posts of this thread or my fork?

I should probably make my own thread for the fork. @florianz did contact me a bit ago and said he doesn’t have any time for this anymore and has essentially handed it off, giving me write access to his main repo.

I have looked at merging my code into his so this thread can be current but it seems like a cruel joke to stomp over something he might have working, as the original author.

Anyway, I will be better help if you use my fork, but his should be working too as of now as I pushed some necessary fixes to it. Did you ensure you enabled Oath in the SmartApp?


(Brandon) #985

@Lucas_Mesquita I went ahead and blew out my all in Heroku and started from scratch since it had been a while since I rebuilt. I’ve confirmed that things still work as intended but some of the steps in the Readme are no longer necessary as they get done automatically. Namely the plugin install of heroku-auth. The command is now this:

Instead of:

but it no longer matters since this comes installed by default. It will fail, but can be ignored. If it isn’t too much trouble, can you login to your heroku app and view your config values to verify all 8 are set correctly? (instead of the CLI)

  1. Replace ‘your-app-name’ with your actual app-name
    https://dashboard.heroku.com/apps/your-app-name
  2. Go to Settings
  3. Click on the purple/white button in the middle that says ‘Reveal Config Vars’

Also, to everyone else, I’ve reconfigured the SmartApp code to be compatible with SmartThings Github integration so you can take updates in a more controlled/simple manner. Please convert over to this at your leisure. Repo for this should be the following in your IDE:

Today I pushed fixes for modes which was showing some erratic behavior which oddly didn’t materialize until I rebuilt the app during the steps above.

Also, as a friendly reminder, if things aren’t updating for you, before reporting a bug, please make sure you Reauthorize the SmartApp to eliminate any version issues.


(Matthew Valeri) #986

I just got a Fire HD 8 and am thinking of implementing this. One thing I’d like to have is Google Calendar displayed. Looking around the web this looks like it could be done with an iframe widget. I was wondering if anyone has done that before and how it effects performance?

Also, adding a weather radar which from more searching I found a brief discussion about it being able to be done with the Big Image widget.

Are all these widgets able to be added by just simply putting in the appropriate files in the folders or do they need to be somehow added to the SmartApp? Not sure if that’s the right way to put it, basically, can I just use any widget that I can find for Dashing by adding the files or is there something more that needs to be done?

I’m certainly no programmer, but am relatively good at figuring out format to adjust DTH’s, and from working with OpenHab in the past creating sitemaps which seem minerly similar. I’m sure I’ll have plenty of questions, but this looks pretty exciting.


(Brandon) #987

It’s a bit more complicated than populating folders and would require programming knowledge to get the base widgets set up.

I’ve thought about adding this in the past but just haven’t had the time.


(R Lisembee) #988

I would love to have a copy of your code. I am planning to speak with our robotics instructor about using your base code for a project for our students.


(HousePanel Author) #990

Hey folks… I love seeing that there are multiple panel options for SmartThings - including this dashboard, Terry’s ActionTiles (which is now a commercial product and very polished), and my HousePanel (which is not very polished, but has some interesting unique features).

I am thinking that it would be great to do a side by side comparison of all three to help the community pick which one suits their needs best. I have to admit that I like the look of some of the tiles and icons here… more inspiration!!


(Brandon) #991

It is on GitHub for all to see.


(Brandon) #992

More often than not, it seems like the vast majority of people are looking for simplicity above all else. Unfortunately, this dashboard isn’t very simple for a novice to install but that is why most people gravitate to SmartTiles/ActionTiles. Alas, I don’t see this changing anytime soon.


(HousePanel Author) #993

I agree completely. I would add that people also want an ability to customize to their visual liking. A killer install script to make it easy is my next action but any app running on your own server will never be as easy as a cloud hosted app to get going. I think Terry and the ActionTiles team have done a marvelous job on this front.


(2exclusive) #994

is there anyway to change the icons? instead of using fontawesome.io icons? Also any way to incorporate the smartthings smart home monitor to the dash? would be nice also if you can add a pin to disarm/arm it.

last but not least anyone get a software to activate the motion sensor with a windows 10 tablet? im using a dell venue 8 pro i had laying around which has windows 10 installed natively and it would be nice if i can activate the motion sensor for the screen to turn on.

thanks in advance, this has been awesome insight so far


#995

@bmmiller I am not able to authorize the app .I get a internal server error .


#996

I have followed the instructions completely but all I get is the “Welcome to Heroku” splash screen. Anyone have any ideas?


(Brandon) #997

Fontawesome is the icons of choice right now and there are currently no plans to add more. It shouldn’t be too difficult really, but I can’t commit any time to add more at this time.

Likewise, there is no SHM integration. I agree, it’d be a nice feature to add, but I or @florianz don’t have the time to add it.

Where are you located geographically?


(2exclusive) #998

ok no worries, thanks for everything very appreciated. I probably will go with Action Tiles and see if they will integrate certain features in the near future


#999

I am located in USA


(Brandon) #1000

I’ve updated the authorization link to what others have said works but since mine has already authorized, I cannot test this change. Please ‘git pull’ the updates, verify, and report back if you can.


#1001

@bmmiller .Thanks for the update .After the git pull . I no longer get the Internal server error and It worked .Thank you for your time and effort to keep this project up and running .


(Iris Panabaker) #1002

This tool may help to format and validate JSON data.

https://jsonformatter.org


#1003

little help guys, I get to the last step to authorize smartthings, I click the devices I want to authorize and than hit authorize… I than get internal server error code… with the following error code “smartthings/oauth/callback?code=b7pVAO” Any idea on how to proceed? Thanks


#1004

Nevermind, changed the site to site: ‘https://graph-na04-useast2.api.smartthings.com’ and everything worked fine…