SmartThings Community

Home Automation Dashboard (HAD)

dashboard
project_dashboard

(Brandon) #964

@JCulver Thoughts? It isn’t pushed yet.


#965

Looks nice


(Brandon) #966

Changes have been pushed to my repo in Git. There is a SmartApp update which means you’ll need to reauthenticate to SmartThings, etc.


(Krystian Szastok) #967

this looks amazing! So jealous!


#968

@bmmiller - Looks very nice, having some problems picking up the meter readings now, both power and energy; however, it picks up the device just fine for the switch portion. Redid the dashboard from step one as well, did not alleviate it. Will try again tomorrow.

Thanks for churning it out!


(Brandon) #969

The stmeter widget is very different than the stswitch widget. Likewise, because not all meters are switches, it doesn’t really make sense to combine them into a single widget unless I were to create a new stmeterswitch widget of sorts.

Basically, to get the meter readings, you have to use ‘stmeter’

To get switch functionality, you have to use ‘stswitch’

I hope this makes sense but it sounds like you are using ‘stswitch’ and expecting energy and/or power to show up. That isn’t going to happen in the current config. You need to use ‘stmeter’ and you won’t be able to turn it on/off. That means you’ll need to dedicate two widgets for now and tie it to the same device, which will work fine, if I am inferring what you are saying correctly.

On a side note, can you help describe your use case so I can better understand the motivation to needing on/off functionality on a metered device?


#970

Sorry, should have been clearer; I have a GE Z-Wave large load switch controlling my Pool Motor, which I use as a timer. As well, I have it displayed on the HADashboard for times when I, or my wife, want to turn on the pool motor manually. This controller also shows Power and Energy which I am trying to display on the Dashboard. e.g.

  div data-id="poolpumpswitch" data-view="Stswitch" data-icon="tint" data-title="Pool Pump" data-device="Pool Pump"

  div data-id="poolpower" data-view="Stmeter" data-title="Pool" data-device="Pool Pump" data-min="0" data-max="1500" data-suffix="W"

Device in the Hub:
Z-Wave Metering Switch

Current States

  • switch: off
  • energy: 12.872 kWh
  • power: 55 W
  • checkInterval: 1920

(Brandon) #971

Potentially silly question. In the SmartApp config on your phone, did you include “Pool Pump” as a meter under “Which meters?”


#972

No such thing as a silly question…but, yes it is listed as a meter. As well, the phone app lists all the data for Power and Energy.


(Brandon) #973

Well, yes, I would expect the app to list the data under its associated device but that really has nothing to do with the dashboard.

I’m specifically speaking about the SmartApp ‘Dashing Access’ and your Pool Pump device being set up to communicate meter data.

I’m not questioning that the device is reporting to SmartThings as it should. I’m questioning that this SmartApp knows to check the device for power/energy.


#974

Yup …


(Brandon) #975

Last thing for tonight then. When you go to authorize the dashboard, you have to select the devices again:

Tomorrow I’ll ask for logs from the SmartApp. The period on the Pool Pump says 1920, is that in seconds? So 32 minutes? Can you do more frequently than that? Is there a Refresh on your device to force a power/energy refresh?


(Brandon) #976

@JCulver Also make sure that you have updated the SmartApp to the latest version.


(Brandon) #977

I have just released some new functionality to my fork. There is now the ability to explicitly navigate to multiple dashboards instead of cycling through each. Check out my main.erb for how to accomplish it, but basically, each dashboard gets an ‘id’ now, and on the changepage widget, specify the data-page as the id for the dashboard page you’d like it to navigate to.

Of course, if you don’t care for this added functionality, if you only have 1 or 2 pages and no need for more. You don’t need to change a thing, the existing configurations will continue to work. Screenshots below:

Page 1 “Main”

Page 2 “Basement”

Page 3 “Outside”


(Ryan Gallagher) #978

Holy crap. I need to read through this thread. This is what I have been looking for. I have a lot of weird devices that I early adopted on which probably won’t work but AWESOME! Is this a product coming out or available somewhere? I’m assuming its similar to the SmartTiles. Tried action tiles but didn’t have time to really test anything with my schedule before it expired.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #979

Hi Ryan,
Send a quick email to Support@ActionTiles.com, and I’ll be happy to extend your Trial. Include your “Location ID”, please, from the Licensed Expired page (at at least your ActionTiles login email).


(Brandon) #980

It is already released but takes a bit of install know-how. It is completely open source and free. It isn’t quite as simple as ActionTiles to set up. Instructions here:

And throughout the thread.


(Lucas Mesquita) #981

Hi,

I got the same error and I`ve checked ST_CLIENT_ID and ST_CLIENT_SECRET on the config.
Did you solve your problem? Any tips for what could be wrong?


(Brandon) #982

@Lucas_Mesquita You quoted someone that posted in 2014. I’m not expecting he’ll respond :wink:

There isn’t any problem with the code in this regard so can you explain a little more about how you have arrived at this point?

Everyone else, there was some code missing for Garage Doors in the SmartApp. If you were having any issues with that widget specifically, please update your SmartApp with the latest in my fork. It does not require a push to heroku.


(Lucas Mesquita) #983

I,ve followed the steps without error till step 6. It’s the first attempt, dind’nt made any changes untill now. You think would be better to rebuild all the steps till 6?