SmartThings Community

Home Automation Dashboard (HAD)

dashboard
project_dashboard

(Brandon) #881

Thanks for the idea. In the first few posts there is a method mentioned that utilizes the camera on the tablet, Secure Settings, and another 3rd party app (too lazy to go check), and it worked pretty well for me. Uses battery pretty heavily on the tablet, but you’d hopefully have it plugged in anyway.


(Jeff Davis) #882

You might want to add a water heater timer to your controller. Either gas or electric timers will save yo energy and extend the life of your water heater. There are many electric water heater timers available. There is only 1 gas water heater timer found only on the internet. The do work!


#883

@JTT This works for me on the new 7" Fire tablet:


#884

First let me say, AWESOME work to all who have contributed to this application.

Everything is going good so far except for one issue I have ran into that I am totally stumped on. I have created a small SmartApp so that I can group and ] control several Cree smart bulbs and switches with a Simulated/Virtual switch following these instructions:FAQ: Creating a virtual Device

From the mobile app it all works as expected but when I tag the virtual switch in the main.erb file and publish, it shows up on my dashboard but it will no execute. It acts just like one of the default place holders.Here is the lone from my main.erb file:

Anyone have any ideas how to get this working? I read others have similar things like this working, so I am unsure why it is not for me.

UPDATE 01/30/216

Issue SOLVED. Discovered some sort of disconnect within ST that did not properly register the virtual switch to the light group app I created. Once I corrected this by recreating the association between the two, it began working in the dashboard.


(Tom Harding) #885

Nice! Mine is a bit more simple. Just an android 21" touchscreen monitor using smartiles. I downloaded a kiosk app so it is basically locked on this screen, but the monitor arm used is articulated so it can pull out around the corner to use the web in the kitchen (see recipies etc).


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #886

What kiosk app are you using?
I tried a couple, but didn’t like them.


(Av8rdude) #887

@Gadgetman Make a shortcut from the chrome menu and save it to your home screen. Then when you open the page it will hide the browser and be full screen.
Looks nice…


(Tom Harding) #888

The kiosk program will not allow me to save shortcuts to the homescreen (or I just have not found out how yet). But thanks for the tip!


(Tom Harding) #889

Mobilock seems to work OK. The android version on this unit is older, but seems to work OK with it.


(Brandon) #890

So, if anyone else got the email from heroku about the current ruby version becoming outdated, I’ve updated the app with some key package upgrades to fix this. I will package it up into a pull request for @florianz but for those that have trouble with that, the associated files that need changing are here:


There are two files that needed updating, just copy paste each into your own and push to the heroku master again. I’m sure there are other packages that could be updated, but this was the least amount of changes that got things working again.

For those that just want the changes:

Here’s the PR:


(Glen King) #891

Awesome! This is roughly the same thing I’m doing. Glad to see someone else has done it already. I love maximizing the usefulness of things.

So far I have the tablet functioning as

  • a control center. Not nearly as elegantly though; I’ll take a lesson from you on this :slightly_smiling:
  • a security camera. I started by having its motion sensor send alerts, but I’m going to abandon that and have it just record brief snippets of motion. Let the door and window sensors handle the alerts. I love you using motion to wake the screen! Again, a lesson. Of course, all footage goes immediately to the cloud.
  • in conjunction with a Bluetooth speaker, an alarm. Between controllable lights and speakers, there is no need for a separate alarm.
  • an alert center. It emails alerts to my work email. Useful since I don’t really have a cellphone.
  • a voice control (using OK GOOGLE). I use it to toggle lights, lock/unlock my front door, etc
  • a detector of bluetooth presence. Not as reliable as I hoped, but it occasionally unlocks the door as I walk up the walkway. Might need a Bluetooth LE capable tablet to make that work better.

Here are a few of the assumptions I’m working from:

  1. Cost. Folks spend as much or more for just a camera. The tablet gives a cam… and so much more.
  2. While I won’t have infrared capability, that can be offset by having lights turn on in alarm scenarios so you get clear images. ST does that perfectly.
  3. I don’t need cams for outside; I only need them is someone actually intrudes.
  4. Even if someone breaks in via a window, he’s almost certainly leaving via a door. So I only need to capture images of intruders on their way out the door (same as the OP’s concept). Conveniently, a mount by the door perfectly serves both the camera function AND the control panel function.

I’m gonna get a second tablet for the back door. I like the OP’s frame. It hides (and secures) the power cable. I’m gonna have in-wall outlets for these tablets.


(Shaun) #892

Anyone having trouble pushing today? I’m getting the corrupt Gemfile.lock message

remote:        Using uuidtools 2.1.5
remote:        Your Gemfile.lock is corrupt. The following gem is missing from the DEPENDENCIES
remote:        section: 'bcrypt-ruby'
remote:  !
remote:  !     Failed to install gems via Bundler.
remote:  !
remote:
remote:  !     Push rejected, failed to compile Ruby app
remote:
remote: Verifying deploy...
remote:
remote: !       Push rejected to secure-beach-72955.
remote:
To https://git.heroku.com/secure-beach-72955.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://git.heroku.com/secure-beach-72955.git'

my gemfile.lock matches the master branch.


(Adam Meadows) #893

@sonicxtacy02

If you look here: https://github.com/FlorianZ/hadashboard/issues/44

You can find the issue and fix for the gemfile.lock.

Thank you “bmmiller”!

However, I have now ran into another problem. I have the server deployed and running on heroku. However when trying to authorize I run into a “Internal Server Error”.

I have scanned through the thread and have seen a few people with the same error. Each time the solution appears to be entering the ST oauth keys. I have done this multiple times, however each time I get the error. I have also tried hardcoding them in the “smartthings.rb” however again to no avail.

Does anyone have any ideas?

Thanks


(Brandon) #894

@Adam1901 If you run ‘heroku config’ within your local repo location on your computer, it should spit back to you all of your config options. I would make sure you didn’t flip flop things.

Also, did you mean stapp.rb ?

My guess is you have the keys mixed up.


(Adam Meadows) #895

@bmmiller

I have worked out what it is after 3 days of trial and error.

It appears to be a problem on Samsungs end. Not anything to do with the keys.

I have the application set up and working fine, however when I come to authorise it with smart things I notice the URL it is using “graph.api.smartthings.com

If I then go on to press “My Locations” it redirects me to “graph-eu01-euwest1.api.smartthings.com”.

They appear to be different entities and are not compatible with one and other.

If anyone has any ideas that would be great. I have one more left.


(Brandon) #896

Oh, wow. I hadn’t even considered that. You’re in Europe?

Can you try just hardcoding that in stapp.rb instead of graph.api.smartthings.com?

Just to test with.


(Adam Meadows) #897

Yep, the UK :slight_smile:

Hardcoding the “graph-eu01-euwest1.api.smartthings.com” in the stapp.rb got it.

I have it up and running.

Now for the tinkering :stuck_out_tongue:

Thank you for all the help!


(Glen King) #898

Old thread I know, but i have a question. When Motion Detector Is enabled, screen sleep and timeout on my tablet take almost a half hour to occur… even though hey are set to 30 seconds and 10 seconds. Anyone have any idea why??


(Shaun) #899

Two potentially easy questions:

  1. Does the changepage widget not accept background colors? I placed background-color: #FF0000 !important; into the scss file but it doesn’t appear to work

  2. Does “stmotion” not accept icons? No matter what icon I enter into the .erb it uses the “3 horizontal lines” icon

Thanks!


(Andrew Cockburn) #900

Thanks for this @bmmiller! I finally got around to doing the upgrade and hit the error - this fixed it a treat :slight_smile: