Home Automation Dashboard (HAD)

Honestly, I’m not sure of a great way of doing this as the pull request is for the master branch instead of your own personal fork. Perhaps if the PR’s were issued to your f0rk, it’d be relatively simple.

Since your stuff was so contained I just manually added it.

Cool, just wanted to check there wasn’t an easier way - I am liking git a lot more than any of the previous bloated source control systems I have used in the past, but I am still feeling my way a little. This project has been a great excuse to start learning it :slight_smile:

There very well might be a better way. I use it every day at work but am still far from an expert :blush:

I finally got the switching pages working. Was having an issue where the second page wasnt inheriting the CSS styles. This app is great. Out of curiosity has anyone been able to get “scenes” working with this? I know @aimc made mention he had some virtual switches controlling scenes. Not sure if anyone has any code/methodologies they would like to share :smile:

Yes, I have a take on scenes that I am reasonably happy with, at least for lights.

There are 2 pieces to it -

First, use the IDE to create a virtual Switch and name it something appropriate like “Movie” or “Downstairs Off” or whatever:

  • In the IDE go to “My Devices”
  • Click the “+ New Device” button On the “Create Device” screen
  • give it a name (e.g. “Movie”), a device network ID (e.g. “Movie”), set the Type to “On/Off Button Tile” and
    set the Location to the appropriate location from the drop down list,
  • then click the “Create” button.

This will give you a dummy button that does nothing yet, but you can make a tile for it in the dashboard like any other switch

The second part is a smart App to make the scenes:

I use a modified version of the excellent SceneMachine by @wackware. The original version didn’t support Virtual Buttons and I also added support for Hue Bulbs.

This app, when you first install it or whenever you change the options, will record the state (on/off, level, hue and color) of the bulbs or switches you tell it to. The virtual button support listens for the button being activated, sets the bulbs and switches to the recorded levels and then switches the button off for you , so it acts like a momentary switch. The idea is that you create a version of this app for each scene you want then tie it to a unique virtual button. It is a good idea to name the app something like “Scene: Movie”

When you have this all in place you can create an “stswitch” widget for the virtual button and pressing it on the dashboard will activate your scene.

The only caveat I have found, and the reason I haven’t contributed this code earlier, is that for Hue and some of the other device types you need to let the scene stay in place for a while before you record it. I believe this is related to latency in the bulbs reporting back their levels and settings, and/or polling issues in the various device types. For Hue bulbs in particular I found this to be necessary, and would welcome any insight into how to fix this. The original code sent a poll() command to each device before recording this but I had to remove it as it wasn’t supported by GE Link bulbs. Even with the poll() in place working against non-GE bulbs it still wasn’t working well unless I let the scene settle for a while. So the reliable steps to create a scene would be:

  1. Use the phone app to set all the lights and switches to the levels/colors you want
  2. Wait 5-10 minutes
  3. Create or edit the Scene App.

The Code is here:

https://github.com/acockburn/SceneMachine2/blob/master/scene-machine.app.groovy

2 Likes

Just a heads up to check out the device type in the below thread for the GE Link bulbs. Added poll() support and improved status updating. Might improve integration with Scene Machine.

Excellent - thanks, I’ll check it out later today.

That setup didn’t work for me. I edited the files listed and the dimmer shows up, but it’s not responsive to input on the dimmer slider. On/Off still works

Awesome! I will play around with this tonight. Thanks for the help, and keep up the great work!

@DinnerYeti - glad to help :smile:

@retlas - I also took a quick look at the dimmer code and saw something similar to @Jsalicru

I tried it on 3 different browsers with the following results:

  • Safari on iPad - completely unresponsive slider
  • Chrome on Android - slider worked once or twice then became unresponsive
  • Chrome on Windows emulating iPad - worked as expected

In all cases on/off worked, and also even the unresponsive sliders would update to match the current dimming level even though I couldn’t move them manually. What browser did you test on?

BTW, it looks awesome so I am looking forward to seeing it working!

I ran into a similar issue as @aimc and @Jsalicru.

In my case, this was resolved by adjusting the height of the toggle-area class from 110px to 90px in stdimmer.scss.

Toggle-area and slider were overlapping. I presume this is an issue I created for myself as I’ve modified the original size of the tiles.

Ahh that would make sense, I adjusted the tiles too, to fit the iPad aspect ratio. I’ll take another look tomorrow and report back.

@Jsalicru @aimc, let me know if @pm4_1613’s fix works for you. I could try using percentage instead of pixels on that so to avoid the problem all together, maybe. I’ve been testing with Chrome on Mac and Android and haven’t run into any issues yet with the original size specs.

That’s the same issue I had. It’s because your device names have whitespace characters. Rename them to single word names; “Tree” instead of “Christmas Tree” perhaps. It’s a bug somewhere that I haven’t had a chance to make a test case for.

Well partial success here - changing the height from 110 to 90 worked on my Android pad. A bit fiddly since it has a small screen but everything worked when I zoomed it.

No luck on the iPad though - I experimented with several heights and the slider is just dead, completely immobile. Just for kicks I tried with Chrome as well, same result, and I also tried a totally vanilla build consisting of the current master branch with the stdimmer changes added, but none of my other modifications to sizes, heights and css page switching in place.

Happy to do more testing if you can figure out what might be wrong here.

Okay, so after a 12 hour waiting period after getting things all set up I still don’t have the weather tile displaying anything but 0s… I know I’ve missed something, and have scoured the 600+ posts, but still coming up empty, anyone care to help me out on how to get the weather to start populating to the dashboard?

Also: Everything else seems to be working okay so far, looking forward to some full HVAC, HUE, and Sonos integration coming down the road.

My thanks in advance for helping put this all together!

-Rob

Did you setup a weather tile on Smartthings?

Yes, SmartWeather Station Tile has been setup for months, works fine with ActOn dashboard, just not this one. In use by applications lists Dashing Access too!

Any other thoughts? Does it need to be SmartWeather Station V2?

Hi Guys,

I’m getting this error:

"An error occurred in the application and your page could not be served. Please try again in a few moments.

If you are the application owner, check your logs for details."

Any ideas on how to fix it?

@florianz …has the master branch been updated lately?