Hide and go seek


(Ben) #1

Have you ever been working on something in the garage and set a tool down only to not be able to find it nanoseconds later?

Well, I have an issue like this, except it’s with an iSP5 pocket socket. The ST App shows the plug as being connected and functioning, and that it’s called “Light”. Apparently nothing is connected to this socket because when I turn it on, nothing in the house or garage lights up.

I’ve searched the house high and low, but can’t find the socket. Anyone have any magical mystical ways of locating my lost “tool”?


(Chris) #2

Have you tried turning it on or off using the native iHome Control App?


(Chris) #3

Sorry! I misinterpreted the question. If nothing’s plugged in, then of course you won’t find it. However, if something is plugged in and turns on when you toggle it from the iHome Control App, then it’s a SmartThings problem. And if that’s the case, then I wanna know about it.

The device makes a small click when it turns on or off, but let me think up a better way to try and find it.


(Ben) #4

I am at a total loss here…I’m pretty sure I’ve checked every single outlet in the house, and can’t find the silly thing. Anyone have a bloodhound specifically trained to sniff out iSP5’s? :grin:


#5

It’s a Wi-Fi device so it’s harder to search for. Presumably if it’s plugged in there are a limited number of receptacles so you ought to be able to find it with a careful room by room search. If it’s not plugged in there’s no way to locate it. If it was unplugged while it was in the “on” state, I think smart things will continue to show it as on while the native app should show it as off-line.


(Chris) #6

Okay, check the easy things first:

Open up the native iHome Control App and go to the “devices” tab.

Tap the info “i” button to the right of the lost device and take a look at the status. If it says “Not Connected”, then its probably unplugged and lying around somewhere.

Are you on an iPhone? Is it connected to HomeKit? Is it possible that it lives in some other location?


(Ben) #7

Huh? That’s funky! I searched the native app and it’s not there, but ST shows it as being connected, what firmware, and I can turn it on and off?

I’m using an iPhone, and connected to HomeKit (but not using).


(Chris) #8

Interesting. The ST integration is presumptive and sends than on and off command to the iHome cloud which then relays it to the device itself. It appears that the device isn’t on your account anymore for some reason, so for sure the ST side of the integration cannot be relied on. That solves the mystery of why nothing happens when you turn it on and off in ST.

Now locating the device is still gonna be difficult. If you’ve looked at every outlet (really you probably only need to look at the ones you’d likely install it on), it might be possible that it’s not plugged in at all!


(Ben) #9

It’ll be like Easter in Otober for me if I find it. :slight_smile: Hope it exists because I could really use another socket…

Here plug-in, plug-in, plug-in…where are you little Mr. plug-in!


(Ben) #10

The iHome app says that I have 4 sockets, and all are accounted for.
Those 4 sockets are also accounted for in the ST app.
I have 4 iHome boxes that the sockets came in when purchased.

But ST thinks I have 5 sockets?


#11

It’s possible that you integrated the four plugs, then for some reason removed one from the iHome app but not from SmartThings and then added it again to the iHome app and rediscovered it from SmartThings. That would give you four plugs in iHome and five in SmartThings.


(Ben) #12

@JDRoberts Exactly what I was thinking, but I can’t say that I did/did not do that at some point. I wouldn’t put it past me to do something like that.

I turned off all of the accounted for sockets, and then turned on the unaccounted one. Nothing happened, and the ST app didn’t show any of the accounted for sockets were turned on?


#13

It wouldn’t, that’s now a ghost device. Since iHome doesn’t know about it, no instruction is ever sent to the actual device. SmartThings is sending instructions into the cloud, but iHome ignored them because it doesn’t have an associated device anymore.

if each of the four can be worked from SmartThings, I’d just remove the fifth from SmartThings and not worry about it.


(Ben) #14

@JDRoberts

Another odd thing: There’s a colossal electrical generating wind turbine located about 1k from my house, and I noticed that whenever I turn the “Light” switch off in ST, the wind turbine comes to a stop. When I turn the switch back on, the turbine starts back up. The turbine is made by GE, but I didn’t find it on the officially supported ST list.

I don’t think I have written a CoRE piston for the turbine? :slight_smile: