Heltun HE-HLS01 only recognised as a switch and not as a thermostat anymore please help

Hello last year when i set up 3 Heltun HE-HLS01 as my underfloor heating thermostat’s and all was working fine, switched off for the summer and now unable to communicate with them.
Thought it was just the edge driver switch over and just relearning them would sort it.
But it seems it can only now be connect as a z wave metering switch, evan if put in thermostat mode and told its a thermostat it pairs as a metering device with no switching function.
Iam new to the edge drivers and just changing the driver to a thermostat in advance settings show incorrect fingerprint.
So is it possible for a devise finger print to be added to a driver?
any other suggestion?

Thanks

Try @Mariano_Colmenarejo 's “Z-wave Thermostat Mc” Driver.

If that doesn’t work. Post the fingerprints (Mfg. Code & Model) hear. You can get them using the Advanved Web App Samsung account and maybe Mariano can add it to his driver.

1 Like

Thanks very much, ive tried the “Z-wave Thermostat Mc” and still get the valid fingerprint issue.
I think my mfg code is :0344-0004-000A
and model :0004-000A
is there any other information need?

thanks
pete