Help with WeMo switch and Lifx bulb

I have looked everywhere but cannot find a way to connect to these two devices, they are not listed in the corresponding categories in the “marketplace”, equally running a “connect new device” search gives no results. Looks like the hub is simply not seeing these devices. I’m stuck, help please!

Have you tried using ifttt?

Not yet! I thought WeMo and Lifx were both supposed to be compatible with ST and could be controlled within the ST app…

Wemo intergration is kinda crappy. I gave up on it a long time ago. I just use the scheduling inside the wemo app. It works for what I need it to do.

When you come to the forum, look at the top right of the page and you will see a link to “support and knowledge base.” This is where most of the official articles are. As long as the device is on the official “works with smart things” List, you will find instructions in the knowledgebase for how to connect it.

When you get to the support page, go to the section “meet the things.”

The devices are listed alphabetically, and WeMo devices are listed under “B” for “Belkin WeMo.”

If you get stuck, write to and they will help you. :sunglasses:

To get my Wemo in-wall switch to pair I had to do a complete reset on it… then it worked ok. Was it paired to something else? Mine was connected to my Amazon Echo only… It wouldn’t pair with ST until I reset and removed the Echo. But once paired Echo was able to reconnect and it works fine…

WeMo bulbs are zigbee. They can be paired directly to the hub.

WeMo switches connect via Wi-Fi, and they do this weird refresh thing which means if they’re not on exactly the same part of the WiFi network as the controller they’re talking to, things don’t go well. So if you have a booster extender or even just Apple airport, you may have Pairing problems.

well that explains a lot… that thing did take me forever to finally get connected.

Google is also your friend :wink:


I call my 12 year old soon Google… He thinks he knows everything but is always popping up with useless information… I call my 15 y/o sons Jeeves and WebCrawler… both pipe in constantly with totally irrelevant information that is usually wrong…

Kind of like this post.

Thanks. I think I will have to contact support. WeMo doesn’t become discoverable even after resetting the switch…Lifx is the same!!!