Help with Vodafone SmartThings Camera

Hi all
As part of the Vodafone VHome package I have a SmartThings camera. When I first set it up, it was all fine however in the last few days when I’ve gone to check the camera it showed there was a problem with the feed.
I’ve removed the camera from my hub and attempted to add it again but now I get:
“Something went wrong. Try adding your camera again. If the problem persists, reset your camera”

Tried resetting multiple times but still no luck.

Any advice on what I can do?

That device is only available as part of the Vodafone package, so I think you probably need to get in touch with their support.

Any idea what re branded camera Vodaphone used JD ? That’s the first post i have ever seen on an ST camera and after Vodaphones push to hock there ADT version of St, no doubt not the last

May be of interest to those wanting an ST camera as the device is listed as a Smartthings camera

I believe they are using different cameras in different markets, certainly I’ve seen some pictures that look very different. But I I don’t know for sure.

https://eshop.v.vodafone.com/uk/vhome

We were looking at the same time lol
(Image of Smartthings branded camera )

The IDE also lists Smartthings camera, wander if thats its Device handler

No my bad Samsung smartcam… is that the DH ?

Oooo nasty…

Thanks all

I’ll see if I can reach out to Vodafone if they have any idea…

Hi Adao,

Did you win?