HELP - IDE Login Troubles?

I got a new Samsung webpage for SmartThings IDE Login? When I created a new account, since I could not logon with the same credentials that I have used since V1 hub, all my devices and smartAPPs are missing. Did I miss an announcement?

I was able to login but I had to click on SmartThings logo instead of Samsung logo. That was a change that I never received notice!

1 Like

I did not get a notice either but login with my prior credentials worked without a problem.

1 Like

If you had a SmartThings account prior to the 2.3.5 app release, you almost certainly have a SmartThings account. If you created an account after the release of 2.3.5, you likely have a Samsung Account. Lastly, there is the possibility of having a SmartThings account and a Samsung Account with the same email address. This is the most confusing scenario which should be addressed soon.

Here are the steps for each of the three scenarios in order of likelihood.

SmartThings Account Sign In
a. Click Login
b. Enter your SmartThings email address:

c. If you only have a SmartThings account, the login will detect that and prompt you for your SmartThings password:

d. Enter your password and sign in

Samsung Account Sign In
a. Click Login
b. Enter your Samsung Account email address:

c. If you only have a Samsung Account, the login will detect that and prompt you for your Samsung Account password:

d. Enter your password and sign in

SmartThings or Samsung Account Sign In
a. Click Login
b. Enter your email address:

c. The login will detect that you have a Samsung Account and SmartThings account and will prompt you to select which one you would like to sign into:

d. If you have both accounts, your Hub is likely claimed on your SmartThings account and you will want to choose that. If you choose SmartThings, you will be prompted for your SmartThings password:

e. Enter your SmartThings account password and sign in.

f. If you choose Samsung Account, you will be prompted for your Samsung Account password:

g. Enter your Samsung Account password and sign in


Thanks @Brad_ST for the detailed explanation. I now have a Samsung account since I thought that SmartThings had switched to Samsung for their authentication/authorization. I quickly found out, that this allows login, but then one is presented with a blank list of SmartApps and DHT’s, which can be quite alarming since I have been using SmartThings since V1 hub days.

So I followed your steps right after I found myself looking at a blank IDE and decided to see if the logon for Smartthings took me somewhere else, and it did. I now have the same access and list of SmartApps and DTH’s that I have always had for years, but the IDE login now takes more steps since I created a Samsung account. I am wondering if I can delete it, but I have always believed if it isn’t broken don’t fix it.

Thanks again!

To add…the new IDE login page isn’t LastPass friendly in iOS.

1 Like

Or Android

The login also doesn’t work with older Android “Browsers” (aka Android v3.x). Therefore I am unable to get SmartTiles to operate which destroys nearly half of my Home Automation displays.

Thanks for the notification of this change Samsung!!!

Looks like SmartThings and Samsung really threw a monkey wrench into this UI and authentication change!

Surely the beta testers found this? :grinning:
Oh, you are the beta testers.

1 Like

I feel more like an pre-alpha tester!

For LastPass, doesn’t seem to auto fill on Chrome/Windows 10 either, although if you use the extension and tell it to fill it will. Haven’t tried Android yet.

Update-Found that it also doesn’t work with older Chrome Browser on Android. I purposely loaded Chrome on certain devices as the default browsers on some devices didn’t support JS and therefore didn’t work with the IDE login screen. Now I’m left trying to figure out what browser if any will work with the new login screen.

I have an email into Samsung SmartThings support and will update with whatever info I get.

Just chatted with SmartThings support and you now have to have a browser that supports HTML 5 (like everything else these days). Any suggestions on an HTML 5 compatible browser that works on older android versions?

If you use SmartTiles (ST Support still refers them to ActionTiles if you can believe that) ST Support says that SmartTiles is going to work to work with the new login integrations.

Anybody know if it broke other OAuthentications (ie: Quirky, Thermostat, etc.)?

scratch that about ST support and ActionTiles it appears that no one is notifying me of anything. I hadn’t even got notice that SmartTiles was being renamed “ActionTiles”. I wish companies would be more proactive in their notifications but I guess I’m living in a fantasy land!

Did you ever get this resolved? If not, DM me. I think I know what’s going on.

1 Like

I am thoroughly confused. Apparently I have 2 separate IDE Logins using the same email address and the same password?

The web address is different and the contents are different. Both websites show my correct account information however 1 of them has my SmartApps and the other one has my equipment.

I only purchased a Smartthings device within the past few months, so this is not related to old accounts or anything of the sort.

If I login to my app, it has my equipment, but not the SmartApps I created. Rather confused about how to get this resolved or if I just have to wait until Monday?