Hello, Home Phrase Director - Control modes (through hello home phrases) based on occupancy and "sun state"

Well it looks like the problem has reared it’s ugly head again. Frustrating part of the whole thing is that I just tried chatting support and got a bounce back that Support has an increase incident volume and that I would need to send an email. My confidence level with ST is quickly dropping. I have a completely useless hub because ST cannot get the sunrise/sunset right. Come on ST what gives!!! If ST plans on moving to subscription based plan for V2 they had better get their stuff together. I want ST to success but I am not sure that is going happen given the recent couple of weeks of problems.

Not sure if this belongs here or not but since it affects this app I figured I would try :smile:

I want to be able to manually select a Hello Home Phrase, just say “I’m Back” for example, and have it select a certain mode based off of Sunrise/Sunset. Is this possible?
I have this app setup to automatically do this based off of presence and Sunrise/Sunset but what I want to to be able to manually select a Phase and have it set Home Day Or Home Night based off of Sunrise/Sunset.


it would probably be easiest to just make 2 different hello home phrases, one for day and one for night


what he said…

I am trying to setup an alarm panel using a android tablet. It will have a button for disarm which will run a Hello Home phrase which triggers a mode.
The alarm disarms on either Home Day or Home Night. So I wanted one button to trigger the hello home phrase which would set either the mode to Home Day or Home Night. Either will disarm it but I also wanted to keep the correct mode (home or night).
It may not be possible but I figured I would ask.

Check out actiON dashboard, it doesn’t have a button but it has the hello home phrases easily accessible so you could disarm that way. I have a couple cheapo android tablets around the house just running the dashboard

Thanks, I am running Action and it’s awesome!
I did just find in Tasker that I can set a variable at a certain time so for now I am using that to determine day and night and it “seems” to work, I will find out more tomorrow :slight_smile:

I’m struggling with the sunrise/sunset bug as well. Support had me relocate the hub ( SmartThings Icon>Gear Icon>Select the map and move your Hub to a new location. Select save and then repeat, moving your location back to the area around your home. ) which sounds like a creative way of rebooting the location. I moved to Russia, then back to Canada just to be sure. I haven’t figured out whether it will work, I guess I’ll find out at sunset tonight.

As an alternative, I’ve thought about linking/modifying the app to luminance from my Aeon Motion/Light/Temp sensor, but I don’t have the programming prowess to modify Tim’s code. @tslagle13 would this be an extremely difficult task?

After spending a lot of time trying to debug the last sunset fail in February, when it happened this time (late March) I decided to just leave it alone and see what happened.

Failed day one
Failed day two
Failed day three
Worked day four

With no intervention on my part at all.

Wouldn’t be that difficult.

I’ll think about this one and get back to you all.

I haven’t see problems in the long time though…

I would contact support. If your app isn’t catching sunset it’s not my code it’s something on the backend. Things happen.

My problem with using something like a lux value is that can fluctuate and had the potential for a ton of false positives

@tslagle13, sunset events started firing correctly after adding this app: Is it me or schedules not firing this evening?

Must have been a coincidence. The setting of sunrise and sunset states is unrestricted. You cannot prevent my app from see and acting upon sunrise and sunset events no matter what you do.

This is how it works.

If the app sees a sunrise/sunset event and your home is in an allowed mode it will set the correct sun state and run the necessary hello home phrase.

If the app sees a sunrise/sunset event and your home is outside of the allowed modes it will set the sun state and skip running the phrase until the next time your home enters a mode it is allowed to run in

The sunrise/sunset issue cannot be fixed by an app. There is a theory that when you subscribe another app to sunrise/sunset it moves your hub up in the queue. This is probably what happened here.

According to the CTO of SmartThings the only fix for the sunset issue is a new scheduler they are rolling out this weekend and Hub V2. Again another likely possibility you saw your sunset phrase get triggered today. The new scheduler might be in place:)

If you have further issues with sunset triggers, including my app, please contact Smartthings support. They are they only avenue for a solution for this.

The app that is being referred to is using the old way of scheduling sunrise/sunset by checking the times at 1 am for the current days sunrise/sunset. It doesn’t use the sunrise/sunset event that is supposed to be triggered.

That version of my app was denied by smartthing for official supoort.

Can’t update OP so i’m posting it here. New link on GitHub


GitHub says that this was updated yesterday… is that just because you moved things around a little bit, or did you make any changes?

moved stuff

I cannot figure out how to uninstall this app. I go to Convenience->Hello, Home Phrase Director->Uninstall and I get an error that says “An unexpected error occurred.”

I use “Smart Alarm Security”, which I set to arm itself at 11:00 pm (by having it automatically switch to Night Mode at 11:00 pm. “Hello, Home” switches the mode upon sunset, which is way too early to arm it for “Stay”. I wish there was a way to have the app let you select a time to switch mode, rather than forcing you to select between Sunset and Sunrise.

Any help on uninstalling this app?

There is an uninstall issue right now…support is looking into it. That was March 25th and I still can’t uninstall.


No errors in the log. Not sure whats going on.

Might be on the STs side? I don’t know…

P.S. I also cannot uninstall