SmartThings Community

Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server
(Anthony S.) #743

They know and I don’t think they think it’s worth the effort to repair it :expressionless:
It really doesn’t add much value to the homebridge integration anyways

(Kris) #744

Just thought I’d share my experience. I had installed @pdlove 's HomeKit SmartApps. It worked well, but there were some limitations (for example I have both zigbee light bulbs and Z-wave switches controlling dumb lights. Using Siri I had to say Turn Off All Lights, and also Turn Off All Switches because @pdlove’s implementation didn’t allow me to specify that the switches were also lights.

(I also used @ajvwhite’s Homebridge Routine Triggers)

So I thought I’d try @tonesto7’s implementation.

I deleted the old SmartApps from my phone, and tried to add the new json text. I also installed the code on my raspberry pi for the new devices.

npm i -g homebridge-smartthings-tonesto7

However I was unable to get homebridge to run.

After some troubleshooting I realized that I had to remove the old code from my raspberry Pi:

npm remove -g homebridge-smartthings-routine-triggers

and

npm remove -g homebridge-smartthings

I also had to remove the Accessories that routine-triggers had me put into the json file.

My json file now looks like this (XXXX are obviously my specific code):

It seems to be running great. I hope this helps someone get theirs setup.

{
“bridge”: {
“name”: “Homebridge”,
“username”: “XX:XX:XX:XX:XX:XX”,
“port”: XXXXX,
“pin”: “XXX-XX-XXX”
},
“description”: “JSON API”
,
“accessories”: “”
,
“platforms”: [
{
“platform”: “SmartThings”,
“name”: “SmartThings”,
“app_url”: “https://graph.api.smartthings.com:443/api/smartapps/installations/”,
“access_token”: “XXXXXXXXXXX”,
“app_id”: “XXXXXXXXXXXX”
}
]
}

1 Like
(Kris) #745

Did you remember to remove the @pdlove smartthings plugins?

npm remove -g homebridge-smartthings

I wrote up how I migrated from @pdlove’s implementation in the post below:

1 Like
(Anuj79) #746

yes i did remove the pdlove version… thats how i got it to work . but it was erroring out on certain Devices. when i removed these devices it worked.

#747

Hi I just installed homebridge, I’m having some issues runnin it. I’m getting the error below I’m not sure what I’m doing wrong, can anyone help pin point the issue?

[2019-4-25 00:17:19] Error: Cannot add a bridged Accessory with the same UUID as another bridged Accessory: 800a1d7f-0d6d-46d4-b1c9-bff45b57f275

at Bridge.Accessory.addBridgedAccessory (/usr/local/lib/node_modules/hap-nodejs/lib/Accessory.js:268:13)

at Server. (/usr/local/lib/node_modules/homebridge/lib/server.js:416:24)

at /usr/local/lib/node_modules/hap-nodejs/lib/util/once.js:16:19

at /usr/local/lib/node_modules/homebridge-smartthings-tonesto7/index.js:197:13

at /usr/local/lib/node_modules/homebridge-smartthings-tonesto7/index.js:121:27

at /usr/local/lib/node_modules/homebridge-smartthings-tonesto7/lib/he_st_api.js:130:17

at IncomingMessage. (/usr/local/lib/node_modules/homebridge-smartthings-tonesto7/lib/he_st_api.js:45:17)

at emitNone (events.js:110:20)

at IncomingMessage.emit (events.js:207:7)

at endReadableNT (_stream_readable.js:1045:12)

at _combinedTickCallback (internal/process/next_tick.js:138:11)

at process._tickCallback (internal/process/next_tick.js:180:9)

[2019-4-25 00:17:19] Got SIGTERM, shutting down Homebridge…

(sidjohn1) #748


1 Like
#749

Thank you I will take a look at the first post see if it hels. I already tried the second one about cache file did not help

(Giltechy) #750

Any help here appreciated, moving from pdlove to tonesto7 homebridge , configured all the procedures but homebridge loading all accessories and failing with error. There is no issue with config.json or accessory.

[5/11/2019, 1:57:53 PM] SyntaxError: Unexpected end of JSON input
at JSON.parse ()
at IncomingMessage.request.on.on (/usr/local/lib/node_modules/homebridge-smartthings-tonesto7/index.js:330:29)
at IncomingMessage.emit (events.js:182:13)
at endReadableNT (_stream_readable.js:1081:12)
at process._tickCallback (internal/process/next_tick.js:63:19)
[5/11/2019, 1:57:53 PM] Got SIGTERM, shutting down Homebridge…

(Simon) #751

@tonesto7 Running version 1.5.3 of the app and 1.5.6 of the plugin and an issue has cropped up with the latest version.

Some of my lights now appear as buttons and cannot be controlled. These all on Switch 1 of Fibaro Double Switch 2 (FGS-223) modules. The use the embedded Fibaro Double Switch 2 ZW5 DTH. The lights on Switch 2 are OK as they use the child handler Fibaro Double Switch 2 - USB. I had a look at the DTH and noticed that the parent (S1) handler has the following capabilities

capability "Switch"
capability "Energy Meter"
capability "Power Meter"
capability "Button"
capability "Configuration"
capability "Health Check"
capability "Refresh"

The child (S2) handler has these.

capability "Switch"
capability "Actuator"
capability "Sensor"
capability "Energy Meter"
capability "Power Meter"
capability "Refresh"
capability "Configuration"
capability "Health Check"

I think the app is picking up the “Button” capability and not the “Switch” capability as it should. Perhaps this is as a result of @shnhrrsn button mode fixes?

Could you take a look?

Thanks

(Anthony S.) #752

I think you are right about the latest button fixes I merged. I will take a look once I get into the office