SmartThings Community

Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server

(Anthony S.) #683

I continue to actively develop the plugin. Im currently working on a complete rewrite of the plugin code to make it more resilient and easier to manage


(Kaan Ozturk) #684

I know that you will since I saw your work on Nest! One thing, I have noticed is that I can trigger the routine once but I cannot trigger it again through Siri. It might be related what you mentioned above but I am not sure. I can click inside home app again but not through Siri. Let me know if I can help somehow.


(Daniel Falci) #685

That’s nice tonesto7! I’m gonna try the fix that knozturk has talked! Let me ask you something: it’s possible to see a camera installed on Smartthings (Like the Arlo Q) on the Homekit app? Thanks and regards!


(Kaan Ozturk) #686

Tonesto pushed another update today but does anybody know how we should update everything? I have never done update on homebridge.


(Sean) #687

I’m using version 1.5.2, I’m also getting this same error when trying to view the configuration data.

{“error”:true,“type”:“java.lang.IllegalArgumentException”,“message”:“An unexpected error occurred.”}

I don’t see extra square brackets in the referenced lines or in the jsonMap section mentioned on the github thread. Anyone know how to fix this?


(Kaan Ozturk) #688

Please remove the square brackets in row 401 and 406 since code has moved because of updates tonesto made:


(Anthony S.) #689

Sorry about that bug… I’ve pushed out a fix…


(Peke) #690

The shm function doesnt work anymore for me.
Ive looked at the homebridge server and the command comes tru but in smartthings nothing happens.
Log in smartthings look correct except for the error and it has to do with shm.


(Anthony S.) #691

Sorry I forgot to share that the latest code updates require you to reactivate the SHM in the SmartApp and it will create a new device under HomeKit.

I had to do this so users with multiple locations could use multiple instances of SHM.


(HousePanel Author) #692

Just got homebridge and this plugin installed and it works great. Thanks for providing this to the community.

I now have Homekit access to my lights and the native devices including my crazy iComfort S30 thermostat.

Now what I would really like to do is to access the thermostat from ST using this setup as a reverse pathway. Has anyone done that?


(HousePanel Author) #693

I no longer need to do this because I finally figured out how to replace my Lennox thermostat with my original Ecobee. But I still love having Homebridge set up and working. I now have easy access to my home from my phone and car via CarPlay. The Alexa link in my car works too but it isn’t as reliable as the Siri method.


(R Scott) #694

Just got homebridge installed. Works great on the iPhone and iWatch. Thanks so much for contributing the plugin.


(John) #695

I just installed this and everything seems fine, however, when I add the homebridge accessory it says “additional setup required, add related accessories with homebridge-CAD8 in the manufacturer’s app” I go to the smart app, select my devices, restart the service (even reboot my RPi) and still no devices. I’m mainly just trying to run GE light and fan switches.

Edit: it was an issue having moved files to create a systemd service.


(Daniel Falci) #696

Hello tonesto7, installed the plugin and its working perfectly! Nice work!

Is it possible to make my camera work with HomeKit using the plugin?

Thanks and regards


(Anthony S.) #697

nice to here. It’s working… There was a change in the Latest iOS release that prevents locks from working. So i need to push out a plugin for those.

As far as the cameras unfortunately no. They are a whole other animal, but there are a lot of camera plugins available.
Tell me which cameras you have and I can point you in the right direction :slight_smile:


(Daniel Falci) #698

Hello tonesto7, thank you! I followed your idea and found this plugin https://github.com/devbobo/homebridge-arlo (I have an Arlo Q).


(Anthony S.) #699

Awesome does it allow you to view the video?


(Daniel Falci) #700

I’m traveling at the moment and will get back by the end of the month and gonna test it. Ill post the results! Thanks again!


(Jg506) #701

Link or message#? I’m still on that original implementation. Works well except for locks. And is there docker image somewhere to make my life simpler.


(Barry) #702