Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server

(Anthony S.) #663

Thanks.
I’ve been testing and so far it’s been working


(MacTechGenius) #664

Doesn’t work for me…I can PM my live logs.


(Pizzinini) #665

I suggest you also check in the Eve or the iDevice app if the issue exists there.

All my devices became unresponsive in the Home app after iOS 12 upgrade but still worked in Eve and iDevice (yeah…strange!). My issue was probably related to my home setup in icloud and a re-install fixed it.

[Edit:] To clarify… I removed and re-setup my home in iCloud, not the Smartthings app.


(MacTechGenius) #666

I did the setup after iOS 12…3 days ago


(Peke) #667

I got the same issue, says that is doesnt respond after 1min or so.
Updated you smartapp and restarted twice the homebridge but no luck.


(Anthony S.) #668

I’ve pushed up some updates to the app and NPM package. I have noticed a minor issue in the home app where once the routine switch is tapped it go into the on state. Once st fires the routine it sends an off state to HomeKit for the routine device. However the Home App UI doesn’t seem to update the device until you leave the page and come back.
With that said I’ve pushed out some fixes for a few bugs and added support for virtual routine devices which I like to use in my HomeKit scenes.


(MacTechGenius) #669

Was the SmartApp updated (didn’t see any updates there today). But I updated homebridge and the plugin…still have the same issue. The routines doesn’t run.


(Anthony S.) #670

Make sure the smartapp version shows 1.1.8


(MacTechGenius) #671

Just tried today and it works! Thanks (:smile:


(Kaan Ozturk) #672

Where did you guys setup the virtual machines? I am planning to setup mine since I want to use siri.


(Pizzinini) #673

I used a dedicated raspberry pi. This way its always running and I don’t have to worry interference with other processes.


(Kaan Ozturk) #674

I have spare macbook. Can I use that for now to test the stuff out and then transfer to rasberry pi later once I like to setup or do I need to setup again?


(Pizzinini) #675

If you transfer from the macbook to pi your apple home structure setup (rooms, zones etc) and your smartthings/smartapp setup remains unchanged. You will need to need to re-set up the homebridge on the pi and the old homebridge/devices in the apple home app will be deleted. and need to be re-setup.

FYI: I recommend the “Eve - You. Home. Connected.” app (new name! hard to find in app store!) to set up the apple home. I find it much quicker and more intuitive.


(Daniel Falci) #676

Hello guys, I’ve suscefully installed Homebridge on my Windows 10 PC. Then installed the Homebridege Smartthings App on my iOS phone and when I click to View the Configuration Data for Homebridge I get a java.lang.IllegalArgumentException with message unexpected error occurred.
As I don’t have the right app id and secret I’m unable to get It running. On the live console I get this error: java.lang.IllegalArgumentException: argument type mismatch @line 380 (renderConfig).

Anyone know how to fix this? Regards


(Kaan Ozturk) #677

Anthony,
I am using your version 1.4.1 and getting the same error as the other guy which is {“error”:true,“type”:“java.lang.IllegalArgumentException”,“message”:“An unexpected error occurred.”} Do you have any idea why are we getting this error when we try to get the config data?


(Kaan Ozturk) #678

Did you find any solution to your problem?


(Kaan Ozturk) #679

Actually, somebody already found the issue on the github. There are 2 extra square brackets on row 372 and 377 that needs to be removed. Once I remove it, I can see the config detail.


(Daniel Falci) #680

That’s nice knozturk, gonna try it! Do you know the difference beetwen Tonesto version and pdlove version? Also, a Smartthings camera will work on any of them? Regards


(Kaan Ozturk) #681

Tonesto’s version is more up-to-date with the changes that you can see over here! He took over PDLove’s version and modified it to make more usable. I am not sure about camera thing since I have not tested it yet.


iOS app that can control both Zwave (through SmartThings) and HomeKit devices?
(Daniel Falci) #682

Hello, not yet for this plugin. But I installed the old one by pdlove and worked perfectly:
https://www.npmjs.com/package/homebridge-smartthings

Regards,

Daniel Falci