SmartThings Community

Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server

(Phong) #581

It’s been awhile since i played with the homebridge, can you tell me how to add the username and password. It was working for the past year and now i’m digging myself back into it.


(Jg506) #582

Edit config.json. You just need to modify the already configured user name. There is no password.


#583

Username and pin.


(Jason) #584

Hi all-

I am wondering if someone can help me out. I have been missing with this for about 2 weeks now with no success. All of a sudden about 2 months ago my home bridge setup stopped working. I didn’t do anything or change anything. It run on my mac mini media server so it isn’t even a machine we touch ever. I tried removing home bridge and reinstalling along with everything else i read online and in the forums. I was having the issue where i couldn’t get the last message that says “communication established…” After the last attempt to reinstall (following the instructions on the GitHub page for pdlove it no longer drop the config file after the install. How do I get the sample config file so i can drop in the code from the smart app? I remember it was a fairly simple file, but I don’t know if the example i am finding online are unique to the install when it comes to usernames etc or if I need to create the file with a certain tool (like Xcode) if I was to try to copy and make it myself. I think I remember reading you can’t edit the config file with a standard text editor. Any help that can be offered on these 2 issue would be much appreciated!

Thanks!
-Jason


(MacTechGenius) #585

Make sure you have Xcode installed on your computer and make sure you launch it. You don’t need to do anything…just need to have the developer tools inorder for homebridge to work. You can edit the text on anything.


(Jason) #586

I do have xcode installed, but it wasn’t launched. I don’t remember ever having it launched before. Does it need to be opened while I install or open while its running and I am trying to establish a connection?

Any idea how i can get a config.json file? Can I just paste a copy I see in the thread in the text editor and save it as .json

Thanks for the quick reply.


(MacTechGenius) #587

You merely have to launch it to complete install…just once

Yup thats about it with the .json


(Jason) #588

I just opened it and re ran the npm install commands but still no config file. The persist and accessories directories install, but the config file is not there. I’ve done a system wide search and still nothing. I don’t get it. It was there before when I had it running before…

any other ideas?


(Jason) #589

I think I got it working. I found the config file on GitHub and then edited it with my info and checked the validation. I put it in the homebridge directory and launched home bridge and it looks like i have a successful connection! Thanks for your help. I’m going to see if it is recognized in the Home app now.

Thanks again!


#590

Just wanted to bump the timeout issues with saving config in the JSON Complete API SmartApp. I added a few more devices this past week and am still getting the nonsense timeout when saving the API config. Can’t find any rhyme or reason to it.


(Pizzinini) #591

Strange… mine has been working without hick ups for 2 months now and I have ~75 devices set up in Homebridge.

Maybe it is dependent on the type of device you are trying to connect? Maybe some attributes take longer to read and cause the timeout?


(Neil Oakley) #592

Just looking to set this up on my home system now. One question before I start, are the instructions here still valid?

I only ask becuase that was a few versions of iOS ago and there is a dedicated Home app now to add devices.


(JBrown) #593

I used these instructions https://github.com/nfarina/homebridge


(Neil Oakley) #594

Failed when installing from NPM - Cant Find Python. Any ideas? I’m running all my js servers on a windows 7 PC.

I managed to clone the git, but then the install fails.


(JBrown) #595

I’m using a Raspberry but this might help you.


(Neil Oakley) #596

Giving it a go now, but VS community is over 8gb :open_mouth:


(Neil Oakley) #597

BOOM

Just need to figure out config.json and plugins now.


(Neil Oakley) #598

OK had the server running, installed plugins, but not when i try and create the JSON i’m getting errors.

The JSON is the one compiled by the Hello Homebridge smart app on here.

Am I just missing the plugin to go with the particular accessory type in the JSON?


(JBrown) #599

What is SmartthingsHelloHome?
This what I used for the plugin for Smartthings.


(Neil Oakley) #600

I’ve tried several.

If i use the pdlove as you suggest then the smart app gives me a config AND a separate accessories JSON.

But neither of this have any “accessories” in them.

I really don’t know how i need to compile my config.json file :frowning: