Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server

#561

Also having similar issues.


(Pizzinini) #562

Strange… it looks like there was an issue with the Smartthings server… it works again now. The Smartapp saved the devices just now. It took a couple of reboots of homebridge. Not sure if this had also something to do with the iOS 11 upgrade and changes to Homekit. Well… it’s working again!


(MacTechGenius) #563

I can confirm hombridge works with iOS 11 without an issue


#564

Homebridge on docker is working well for me…well kinda. I get notifications of things happening but I am unable to control anything. All devices just say updating. Any ideas?


(Jg506) #565

Some do have issues with iOS 11 especially if you have apple TV.
See: https://github.com/nfarina/homebridge/issues/1414 for how to rectify.

That said the problem described by @pizzinini seems independent. (I do not experience it but I my bridge got dropped as some other homebridge users have been experiencing.


(Pizzinini) #566

Thank you for the post. This was very helpful. This issue actually happened for me, too. I just did not realize at first because of the previous issue with Smartthings. I do have an apple TV updated to TVOS11.

After a couple of hours all devices started to show unavailable. Each time I was able to restart Homebridge. Devices would still show unavailable in he Home app but when I refreshed them in the iDevice app and then turn a switch on and off, they were available in the Home app again.

6 hrs ago I updated Homebridge to the latest version 0.4.28 (sudo npm install -g --unsafe-perm homebridge) and I have not had an issue since.


#567

Hey all. Was referred here by another user and wanted to ask if anyone has seen anything like what I’m seeing before - basically, SmartApp API time-outs when trying to save the JSON Complete API configuration in the SmartThings app. Plenty of detail in my other thread here: SmartThings and Homebridge - API Timeouts? (and it links to my issue filed on the Homebridge github as well)

Thanks in advance!


#568

Oh snap, I just noticed the above couple of posts were about this exact issue. But for me, it hasn’t gone away - I’m definitely still seeing it.


(Pizzinini) #569

I suggest you wait a couple of hours or days and keep trying…this fixed it for me.

I dont want to test it right now, just in case it is a server issue and this would then mess up my configuration again…:rage:


#570

Arghhh… it just keeps happening. Agree with several others who said it seems to be related to the number of devices, but it changes slightly from attempt to attempt. I’ve tried eliminating certain device types in case there’s a communication delay with external systems, but that was no help either. Surely I can’t be the only one still having this problem! If it was a server load condition I’d expect to have snuck in somewhere during the couple dozen attempts I’ve made.


#571

Count me as someone having major problems with homebridge and the homebridge-smartthings plugin.

I hope pdlove or nfarina can help somehow.


#572

Just an update, this is still happening. Same as before - you can’t save more than a VERY small handful of devices in the JSON Complete API app without it erring out. Can someone please please look at this??


(Justin) #573

There is a deeper problem. I think when the problem described by @jawn101 occurs, this (in conjunction with a restart of homebridge) causes the ST devices to reset in HomeKit to the default room and default name.


(Olivier) #574

Finally played with homebridge. Had a raspberry Pi Zero W in a drawer so bit the bullet and installed Homebridge.
No major hickups, and all seem to be working. If anything I have too many tiles in the home app :slight_smile:

Is it normal to have 2 tiles per thermostat, one of which is greyed?

I also have a greyed homebridge tile.

Ideas?


#575

The Homebridge Tile is your controller, that’s normal. As is the other, as you’re seeing one sensor and one “thermostat control”. You can group them together into one device in HomeKit if you hard press on one and go to Details.


(MacTechGenius) #576

I got remote access to work when I use my iPad as homehub. Strange my Apple TV 4 worked perfectly till I updated to iOS 11


(Jonathan Rivera) #577

I’m curious if anyone knows if the node.js server can be run in the cloud?


(Jg506) #578

No, it must run on the Lan


(Phong) #579

i updated to iOS 11 and it seems not to be working. anyone had any issues?


#580

Working fine here. I did have to change the username and PIN… essentially re-adding the home bridge.