Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server

(MacTechGenius) #521

You have to say turn on Nest on cooling or something similar to specific cooling.


#522

I’ll give some syntax a try. I didn’t have to do this 1-2 weeks ago. Previously I could just say “Set Nest to X degrees” and it would just do that… not change the mode.


(Gregory) #523

Has anyone tried a new installation or update lately?

I am trying a new installation and the repo is not showing any api’s to pull down. Everything is just blank. All my other repos are working just fine.


(Pizzinini) #524

Can you be more precise what your error is? I do not remember having to select an API during installation.

Did you follow the installation guide here?


(Gregory) #525

It’s working now - But to answer your question, when you clicked on “Update from Repo” in the IDE, it was blank and not showing anything to update.


(Pizzinini) #526

Glad you got it working! Sounds like time out issue.

If something like this happens in the future, you could go to github directly and copy/paste the code into the IDE.


#527

I’m confused. I finally got my iphone to recognize my homebridge but I can’t get any devices to show up other than the homebridge itself. I have the JSON Complete API app installed and devices selected in the ST app and I made sure it is OAuthenticated too.

What do I do with the Device Results section of the JSON SmartApp where it says “View Accessories JSON”? Does that go into my config.json file?

I’m on a mac if that matters and I can paste info from the terminal if needed, just let me know what you need to see.


(Pizzinini) #528

Sounds like you are on the right path… The “View Accessories JSON” is for your information only to see if what devices are connected. I assume you have installed the config.json per installation with the OAUTH keys from Smartthings.

Do you see the devices recognized when you launch homebridge where you installed it (e.g. Mac or raspberry pi?). This gives you a good indication that the devices are actually connected or what the error is.


#529

I see it attempt to register a bunch of accessories I don’t have (they’re the ones included with homebridge by default). and then I see this:

 Loaded config.json with 0 accessories and 1 platforms.
[8/14/2017, 8:47:44 PM] ---
[8/14/2017, 8:47:44 PM] Loading 1 platforms...
[8/14/2017, 8:47:44 PM] [SmartThings] Initializing SmartThings platform... 
Loading legacy platform SmartThings
[8/14/2017, 8:47:45 PM] [SmartThings] Fetching SmartThings devices...
Scan this code with your HomeKit App on your iOS device to pair with Homebridge:

And then it gives me the code for the app and tells me the port its on

edit: so no i dont see the devices.


#530

this is my config.json file, is it complete? I don’t have any accessories listed, am I supposed to? I can’t find a good answer to this.

{
"bridge": {
	"name": "Homebridge",
	"username": "CC:XX:3X:X3:XX:22",
	"port": XXXXX,
	"pin": "xxxxPINxxxx"
},

"description": "SmartThings.",

"platforms": [{
	"platform": "SmartThings",
	"name": "SmartThings",
	"app_url": "https://graph.api.smartthings.com:443/api/smartapps/installations/",
	"app_id": "xxxxxxx token xxxxxxxx",
	"access_token": "xxxxxxx token xxxxxxxx",
	"update_method": "direct",
	"direct_ip": "default"
}]
}

(I’m not sure what’s sensitive so I redacted some stuff)


(Pizzinini) #531

This looks right… just that after “Fetching SmartThings devices…” it should list the actual devices you are connecting.

Are you using these instructions… there is an older version of Homebridge referenced above and I dont know if it still works after some changes Smartthings made a while ago…My config,json looks different…

{
"bridge": {
"name": "Homebridge",
"username": "D0:00:00:00:00:00",
"port": 51826,
"pin": "031-45-154"
},
"description": "JSON API",
"platforms": [
    {
        "platform": "SmartThings",
        "name": "SmartThings",
        "app_url": "https://graph.api.smartthings.com:443/api/smartapps/installations/",
        "app_id": "xxxxxxx token xxxxxxxx",
        "access_token": "xxxxxxx token xxxxxxxx"
    }
]
}

#532

I was using these: https://www.npmjs.com/package/homebridge-smartthings

they look similar if not the same

I have to admit this section about detecting the devices is confusing me. Whats the simplest and most reliable method?


(Pizzinini) #533

can you just delete the

	"update_method": "direct",
	"direct_ip": "default"

from you json.config? will this help?

Another thought: You should only select every device once in the JSON Complete API smartapp. (it will still have multiple capabilities), not in multiple categories. e.g. dont select a switch in “Most Devices” and in “All Switches”


#534

I actually added those two lines when I couldn’t get it working originally. SO I can take them away but I won’t fix it. I’ll also double check the app but I do believe each device is only checked once.


(Dan) #535

Just throwing out an idea…

Does anyone know if you have to change the URL in the config.json file if you are not on the original NA shard? My Homebridge integration is still working, but my hub is on the original shard.

Just a guess! Hope it helps.


(Pizzinini) #536

Are you sure “default” is a valid value for direct_ip? From the description I understand this should be an IP address… I may be wrong though.


#537

I honestly can’t figure out what it should be. I tried using my Mac’s internal IP and it didn’t work so I changed it back to “default”.


(Pizzinini) #538

(Pizzinini) #539

From the description I understand that this should be a free IP address for Homebridge to communicate, not one that is in use already. This may be different dependent on what router you are using.


#540

Ok. Is this the method you’re using though? Is it even necessary?