Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server

(Greg) #499

Double checking… responsiveness will stay the same after this update?


(MacTechGenius) #500

I did the update on the IDE

I upgraded my node.js
typed in sudo npm install -g homebridge
and typed in sudo npm install -g homebridge-smartthings

And then when I decided to update my config.json file with the one smartthings linked, I got an error when I tried to run homebridge stating that my config.json is incorrect so I simply used the same one I had before and and everything continues to work as it did before. I didn’t have to redo any setup even though I did npm install -g homebridge-smartthings instead of npm update -g homebridge-smartthings


(fireheadman) #501

I also performed the update for node.js, homebridge, homebridge-smartthings, and json api smartapp code.
Coincidently, I also swapped out my Android Galaxy S5 for an iPhone 7. Unrelated to the swap I was having some issues with homebridge, so I wiped my “Devices App” in iOS and attempted to re-pair Homebridge to Devices App.

My iPhone 7 would not pair, it would sit at “Waiting for Homebridge”. I had to open the Devices App on my iPad, then it paired up. Afterwards, my iPhone saw everything as is able to modify the Devices and Home app.

Perhaps I did too much at once?.. Good thing is I am online once again.


#502

I’m getting this error:

**Error: The requested platform ‘SmartThings’ has been registered multiple times. Please be more specific by writing one of: homebridge-legacy-plugins.SmartThings, homebridge-smartthings.SmartThings
**

Do I have to clear out my install and reinstall?


(Anuj79) #504

i keep getting this error running docker on QNAP anybody know whats going on … and then the docker crashes.
this is the command i am using to start the docker
docker run -d --name HomeBridge --restart=always --net=host -p 51826:51826 -v /share/docker/homebridge:/root/.homebridge marcoraddatz/homebridge:latest

Scan this code with your HomeKit App on your iOS device to pair with Homebridge:

┌────────────┐                                                                                                                                                                                                              
│ 031-45-154 │                                                                                                                                                                                                              
└────────────┘                                                                                                                                                                                                              

/usr/lib/node_modules/homebridge/node_modules/mdns/lib/advertisement.js:56
dns_sd.DNSServiceRegister(self.serviceRef, flags, ifaceIdx, name,
^

Error: dns service error: unknown
at Error (native)
at new Advertisement (/usr/lib/node_modules/homebridge/node_modules/mdns/lib/advertisement.js:56:10)
at Object.create [as createAdvertisement] (/usr/lib/node_modules/homebridge/node_modules/mdns/lib/advertisement.js:64:10)
at Advertiser.startAdvertising (/usr/lib/node_modules/homebridge/node_modules/hap-nodejs/lib/Advertiser.js:43:30)
at Bridge.Accessory._onListening (/usr/lib/node_modules/homebridge/node_modules/hap-nodejs/lib/Accessory.js:539:20)
at emitOne (events.js:96:13)
at HAPServer.emit (events.js:188:7)
at HAPServer._onListening (/usr/lib/node_modules/homebridge/node_modules/hap-nodejs/lib/HAPServer.js:190:8)
at emitOne (events.js:96:13)
at EventedHTTPServer.emit (events.js:188:7)
at EventedHTTPServer. (/usr/lib/node_modules/homebridge/node_modules/hap-nodejs/lib/util/eventedhttp.js:65:10)
at emitNone (events.js:86:13)
at Server.emit (events.js:185:7)
at emitListeningNT (net.js:1278:10)
at _combinedTickCallback (internal/process/next_tick.js:71:11)
at process._tickCallback (internal/process/next_tick.js:98:9)


(Jg506) #505

I use nickartman/homebridge-smartthings:latest . I run it on QNAP using container station.


(Anuj79) #506

still get the same error … theres an additional information but not sure why its failing…
on another website it mentioned to check your port and avahi-daemon was running local on my NAS to which i stopped manually but still didnt fix the problem… i am at it for weeks and no end in sight :cry:

> [ ok ] Starting system message bus: dbus.
> [FAIL] Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon failed!

(Anuj79) #507

i had to log into the container to run the avahi manually by giving following command… in case its helpful to anyone else

/etc/init.d/dbus start
avahi-daemon --debug --no-drop-root


(Kris) #508

I was able to get everything running up to the point of adding devices. I’m able to add the home bridge device, but it doesn’t see my switches/lights etc in the home app or the ‘devices’ app I downloaded.

In terminal there is an error that shows up, is ‘access denied’ an issue?:
Error received type AccessDenied - This request is not authorized by the specified access token

[3/20/2017, 2:06:58 AM] Loaded plugin: homebridge-smartthings
[3/20/2017, 2:06:58 AM] Registering platform ‘homebridge-smartthings.SmartThings’
[3/20/2017, 2:06:58 AM] —
[3/20/2017, 2:06:58 AM] Loaded config.json with 0 accessories and 1 platforms.
[3/20/2017, 2:06:58 AM] —
[3/20/2017, 2:06:59 AM] Loading 1 platforms…
[3/20/2017, 2:06:59 AM] [SmartThings] Initializing SmartThings platform…
[3/20/2017, 2:06:59 AM] [SmartThings] Fetching Smart Things devices.
[3/20/2017, 2:06:59 AM] [SmartThings] Error received type AccessDenied - This request is not authorized by the specified access token
[3/20/2017, 2:06:59 AM] [SmartThings] Unknown Capabilities: []
Scan this code with your HomeKit App on your iOS device to pair with Homebridge:

┌────────────┐     
│ 031-45-154 │     
└────────────┘     

[3/20/2017, 2:06:59 AM] Homebridge is running on port 51826.
[3/20/2017, 2:06:59 AM] [SmartThings] Direct Connect Is Listening On 192.168.1.68:8000


(Huy Nguyen) #509

Looks like you don’t have Oauth setup correctly. When you installed the JSON Complete API smart app you need to enable Oauth in the smart apps settings. And then when you open the SmartApp on your phone take a look at the config and copy/paste those values in to the config.json file on the homebridge server. This is so that the homebridge server can authenticate the endpoints exposed by the SmartApp.


(Kris) #510

I’m so embarrassed. I typed the key in wrong. I used an l instead of a 1…

Lesson learned Copy-paste… Don’t type those big keys in by hand…


(Jg506) #511

With iOS 10.3 update (released today) it is finally possible to trigger home app routines with accessories (switches, buttons, motion sensors, etc…)


#512

We had motion sensor and light coming on triggers before. What’s new is triggers from “programmable switches.”


(Jg506) #513

Got it. Thanks. Is it meaningful to homebridge-ST users?


(JF) #514

Hello I cant figure for the life of me how to set up the launchd on my Mac. Can you share your plist?


(Scott) #516

All I see in the JSON app within the Smartthings App is my lights. How do I go about getting my motion sensors to show up?


(Justin) #517

When controlling via homebridge, is it possible to use the homebridge plug-in for home assistant to enable ST integration?


#518

It’s been a while since I’ve installed this. Does Homebridge expose Nest? I’ve forgotten how I allowed Nest to show up in Homekit. I do have NST Manager installed but I believe I had Nest support before NST.

That said, I’m now having an issue where I issue a temperature and it changes Nest from cool to heat/cool mode. It used to just set the temp regardless of the current mode.


(MacTechGenius) #519

Yup, I can ask Siri to turn on/off upstairs nest, set temp, etc…


#520

Is the temp change an issue for you as well? I have Nest set to cool. If I ask Siri to set a temp, the Nest flips to heat/cool mode and sets my temp to the lower heat number – effectively doing nothing.