Hello, Home HomeKit (and Siri!) control via homebridge

can you just delete the

	"update_method": "direct",
	"direct_ip": "default"

from you json.config? will this help?

Another thought: You should only select every device once in the JSON Complete API smartapp. (it will still have multiple capabilities), not in multiple categories. e.g. dont select a switch in “Most Devices” and in “All Switches”

I actually added those two lines when I couldn’t get it working originally. SO I can take them away but I won’t fix it. I’ll also double check the app but I do believe each device is only checked once.

Just throwing out an idea…

Does anyone know if you have to change the URL in the config.json file if you are not on the original NA shard? My Homebridge integration is still working, but my hub is on the original shard.

Just a guess! Hope it helps.

Are you sure “default” is a valid value for direct_ip? From the description I understand this should be an IP address… I may be wrong though.

I honestly can’t figure out what it should be. I tried using my Mac’s internal IP and it didn’t work so I changed it back to “default”.

1 Like

From the description I understand that this should be a free IP address for Homebridge to communicate, not one that is in use already. This may be different dependent on what router you are using.

Ok. Is this the method you’re using though? Is it even necessary?

I did not include it… this way if I make a change to my network and I ever need to reboot Homebridge it can select a new IP address automatically.

so does your config file look the same but without those two lines?

Yes, the post above is my configure.json file.

ok I think i’ve got it working!

I uninstalled homebridge and the legacy plugins and reinstalled homebridge and the ST addon(?). I think my issue was the the ST addon didn’t install properly probably because I didn’t use -g but I did use -g for global install for homebridge - thats my best guess. I did get “no root access, try again as admin” when trying to install the ST addon but when I tried running Homebridge anyway it said it was contacting ST so I thought maybe it had worked anyway? IDK this whole thing was not as easy as it just was now but I’ll take it!

Thanks for the help! I’m going to try out some devices and play with it now that my devices showed up.

1 Like

I’m on the original shard too (if I’m understanding it correctly. I use graph.api.smarththings).

I got it working! I ditched the two lines about direct update method and direct IP and uninstalled and reinstalled. I think the problem was that I didn’t properly install the ST addon of homebridge.

1 Like

I’ve installed the app and everything works perfectly but I have 1 question:

**Is the app capable of recognizing a camera? ****** My own answer seems to be no because when I try to add my cameras, Home sees them as motion sensors (which they are as well) and there is no ability to set the device as a camera.

You may be able to integrate the camera into Homebridge through a separate plugin instead of through Smartthings.

You can find package for your camera here:
https://www.npmjs.com/

I have done this for my Nest Thermostats (see post 298 above).

Got it. Followed the directions to install the nest-homebridge plugin, when I get to the last step which reads as follows:

Run HomeBridge once (do not include the token in the config at this time) and you should find a log that says something like “CODE IS ONLY VALID ONCE! Update config to use {‘token’:‘c.5ABsTpo88k5yfNIxZlh…’} instead.” Copy the c.5ABsTpo88k5yfNIxZlh… portion to your HomeBridge config as the token in the Nest config
You should be able to restart HomeBridge and it should succeed with the new token.

Where is this log where I can find the token

When I load homebridge, this is the message I see:

*** WARNING *** The program 'node' uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=node>
*** WARNING *** The program 'node' called 'DNSServiceRegister()' which is not supported (or only supported partially) in the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=node&f=DNSServiceRegister>
[8/16/2017, 2:38:51 PM] Loaded plugin: homebridge-nest
[8/16/2017, 2:38:52 PM] Registering platform 'homebridge-nest.Nest'
[8/16/2017, 2:38:52 PM] ---
[8/16/2017, 2:38:54 PM] Loaded plugin: homebridge-smartthings
[8/16/2017, 2:38:54 PM] Registering platform 'homebridge-smartthings.SmartThings'
[8/16/2017, 2:38:54 PM] ---
[8/16/2017, 2:38:54 PM] config.json (/root/.homebridge/config.json) not found.

The token should be available in your Nest developer account: https://developers.nest.com/

Actually everything BUT the token is in the developer account.

The instructions (from GitHub) led me to believe the token would be generated by running homebridge.

OK, I understand now,

From your log above it looks like the config.json is not found. With out this Homebrigde will not have the Nest credentials to create the code.

Yes, I see that too… I don’t understand that as homebridge with HomeKit works flawlessly so the HomeKit plugin seems to locate the config.json file.