Hello, Home HomeKit (and Siri!) control via homebridge

smartapp_voice
requires_server

(Andrew M) #436

I’m not sure myself. I need to look into this as well. I have seen YouTube videos of people doing things like this but haven’t found the documentation yet. I had to use a mix of instructions to get this all working. I should probabaly write it al down in case I have to do it again. Or at least clone my pi just to avoid headaches in the future.


(Pizzinini) #437

Congrats to getting this up and running.

One way to initiate a routine is to create a virtual switch (momentary contact) that you control via homebridge. Then you use one of the rule apps (e.g. Smartrules, CoRE) to launch the the routine (or whatever else you want smartthings to do) if the switch is turned on.

To make it more intuitive you can create a scene (e.g. “I am home” or “good night” ) in Homekit that turns on the virtual switch.

For advanced users: You can set up your rules in a way that the same phrase does different things based on time of day e.g. “hello home” may only turn on certain lights if it is after sunset etc…


(Andrew M) #438

Hey thanks @pizzinini ! Can you point me to any documentation on how to do this? Total noob with home bridge still.


(Brian J Lambert) #439

(Todd Whitehead) #440

Well, for some reason the aggressive moderators closed my thread in the other thread that linked to the morass of 18 months of posts here. Since I cannot post my solution there, I’m posting it here. (Good luck to anyone who actually wants to find it here…)

Anyway, I followed these instructions and this smart app worked fine for me:
https://www.npmjs.com/package/homebridge-smartthings

Interestingly, when I pasted this link into this comment, the board is telling me it was posted on June 8th (338 posts into a thread of 425 posts). I’m sure it is my fault that I missed that post. Anyway, perhaps the moderators can delete this as a duplicate for me.

Sigh.


(Pizzinini) #441

here is some help (Sorry, very little time tonight, will post more tomorrow if needed)

Virtual switch:
http://thingsthataresmart.wiki/index.php?title=How_to_Create_a_Virtual_Device

CoRE:
http://thingsthataresmart.wiki/index.php?title=CoRE
or

Smartrules
http://smartrulesapp.com/


(Jg506) #443

Just wanted to thank whoever made the gateway. It’s great to have ease of access from iOS 10 control center.

Anyway my 2 cents is to use docker container over npm install, especially if you have QNAP NAS like I do and the npm won’t compile without a lot of dependencies resolved. Simply use container station which is pre integrated with docker hub. It finds it by searching homebridge-smartthings. It takes 10-15 minutes to get up and running.
Directions are here:
https://hub.docker.com/r/nickartman/homebridge-smartthings/
Note that config.json should be placed in the root of the host mapped directory (one that is mapped to /root/.homebridge) and not inside config directory as noted in the instructions.

Also the original post should be corrected. No Apple developer program is required. I think it just scare people off. Just follow docker instructions above if using continer or the ones in homebridge-smartthings npm page: https://www.npmjs.com/package/homebridge-smartthings


(MacTechGenius) #444

I made a video tutorial of the integration:


(Michael Boggs) #445

Thanks for creating that video! The thing stopping me from doing this is the complexity. I’d love to see a version of this installing on a Win 10 machine.


#446

Anyone know how to make a device that shows up as one a light bulb with dimming capability instead be classified as a window shade?


#447

has anyone successfully gotten this to run on raspberry pi? If so, any instructions?


(Megan) #448

YEa I am, and loving it!!


#449

I’ve had it working for months (Raspberry PI 2). After IOS10 upgrade, there was some instability, but I think we are through that now.


(Brian J Lambert) #450

#451

does this solution work when you are not home? Like do you guys do some kind of VPN?


(Brian J Lambert) #452

HomeKit devices work outside of the home only if you have an Apple TV or iPad set up to work as a HomeKit hub.

(Apple TV 3 prompts you to sign into your Apple ID to work as a HomeKit hub upon setup, so no extra steps are needed other than making sure you are signed in under the same Apple ID as the phone used during setup.)

https://support.apple.com/en-us/HT207057


(Pizzinini) #453

I thought I’d share because I found this very useful:

About once per week I had problems with the “Home” mode not set and Smart Home Monitor not disarming on time when I reached my house. I use my iPhone as a presence sensor. Opening the garage door would usually cause an alarm. I tried increasing the radius for the presence but more than 1/2 mile does not seam reasonable to me.

Solution: I have created a virtual switch (momentary contact) that sets “Home” mode and turns off the Smart Home Monitor and send me a notification. I also created a Automation in the Apple Home App to turn on the virtual switch when I arrive (with a much narrower radius!).

I have tested this for ~2 weeks now and had no false alarm anymore. I have received the notification a couple of times from that the virtual switch turned off the alarm. The Home App seams to be much better at presence sensing than the SmartThings App. (WAF also increased significantly! :slight_smile: )


Integration with AT&T digital life
Presence Sensors and Alarm
#454

does anyone know whether the automation in home kit is done locally or whether its cloud based?

Also, im not sure why, but i had everything working and setup and even invited my wife to my home in apple. However, after coming back from a work trip, my phone said all devices are unreliable and it would not re-connect, my wife phone which never left functioned as normal. I had to completely erase my setup to get it working again. is there a trick for this? Will getting an apple Tv fix all these nuances?


(Bill Tanner) #455

The ATV3/4 gives you remote access while the ATV4 can run automations. Automations are local if the device running them is local. I was using a iPad in the house but it was unreliability so I switched to an ATV4 and, so far, it seems more reliable.

That said, it doesn’t sound like that’s your issue. Try getting your wife’s access sorted out first. Is she using her own iCloud account? Try revoking her access and doing another invite/accept cycle.

Home occasionally wigs out on me but it always clears up with a force-close of the app.

Worst case, you should delete everything (arrow icon in the upper right) and rebuild HK from scratch.


(Joe) #456

I had docker training a while ago and never used it. Would you be able to help a newb out?

How do I actually get the docker-compose.yml updated inside of the my-docker-directory folder? I can’t seem to get the container into interactive mode to update it. I am running container station on my QNAP NAS.