Heatit Z-TRM3 with Aeotec hub

I am having issues connecting my Heatit Z-TRM3 with SmartThings through the Aeotec hub. Basically follow the instruction and succeed connecting the thermostat, but it shows up in the app as «Z-wave device Multichannel» and only able to turn it on or off as if it was a light switch. This of course does not work for me, as there are no way of controlling temperature settings.

When I go to the device on the app is says it has not updated all status information yet, but have waited and waited and nothing changes.

Any tips from antone out there?? Have also tried resetting and adding it agein about ten or twenty times, but same thing happens every darn time… So frustrating…


Have you installed the official drivers?

Great, thanks!! Did not know a driver was required (strange that this is not communicated…) Have now used of the link you provided and the driver seems to be installed on the hub. Then did a new reset of the thermostat, and tried connecting it again - and VOILA!! It now shows up as a thermostat.