Heatit Z-TRM3 goes offline

Hi, I have several Z-TRM2fx, and they all work like a charm. Just recently bought a Z-TRM3 and updated the DH from RBoy. But from time to time, this Thermostat goes offline.

When this happens, I am not able to get it online again. Have tried several things, like repair Z-Wave network, restart the thermostat and so on. The only way has been to do a factory reset and include the device again. Did anyone else experience this? Could it be something with the DH or the HW itself?

When it goes offline if means that the hub hasn’t received any packets from the device in couple of hours. It could also be a bug in the hub’s device health feature (ST recently changed how device health works in the hub firmware).
Since you’re saying that the only way to bring it back online is by pairing it again then it’s one of 2 issues:

  1. A bug with the hub firmware device health, the best to confirm this would be to try to operate the device. If you can change setpoints on the thermostat and they show up on the ST app, then this is the issue.
  2. If the above doesn’t work (i.e. changes made on the thermostat aren’t show up in the ST mobile app) , then it means your thermostat has lock communication with the hub. This could indicate a potential z-wave module failure or a possible issue with the mesh. Try bringing the device closer to the hub, I’ve seen devices lose their pairing if they’re having a lot of trouble with the mesh signals (very rare but it does happen).

Thanks a lot, will try.

Regarding point 2; This Z-TRM2 is the closesest device to the hub. It is only 2 meters from the hub. All other devices are further away. But, when looking into the device on the ST web-overview, it is actually routing through one of the Z-TRM2fx, which is further away (maybe 5-6 meters from the hub). So this is quite strange…

That may be the issue actually, try this. Exclude and power down your TRM2fx and see if the problem goes away. The TRm2fx stops routing messages when overloaded and that may explain why your TRM3 goes offline.

Ok, so I just did. And now it is routing through a power plug in the living room, that is 10 meters away. Any way to force direct contact?

1 Like

The only way to do it would be to power down the other main powered devices and then pair your thermostat which should force it to connect directly.

1 Like

Hi Tor

I have the same problem the TRM-3 (have 11 TRM-3) is going offline after a couple off days, have 70-80 z wave devices the thermostats is the only one going offline.

I am also having this issue. I have two TRM-3’s, they are both within 5-6 meters of the hub. I have no other main powered devices. They keep disconnecting and the only way to bring them back is reset and new setup.

So, as RBoy wrote, you should check if they are both connected directly to the hub:

My Z-TRM3 was routing through another Z-TRM2fx…

The one with issues right now is routing through unknown devices, and then through the other (working) TRM3.

I only have these two TRM3’s and a few Xiaomi temperature sensors in the network.

So, I did a reset of the Heat, with the Smartthings Hub right next to it (By pressing buttons Right and Center (down and confirm) for 20 seconds). And I made sure everything else is powered off. Then it automatically got connected and the routing is directly to the Hub.

I think the number you see in parenthesis “Unknown Device (98)” is the Network ID. So if you look in the table of My Devices, you can find out what they are. (and turn them off, while re-setting your Heat)

So my problem seems to be ghost devices in the route. I have tried several times deleting these devices by following the process of adding them by id and then force delete them in the app. Then I have tried to repair z-wave, but get “failed to update route” — and new unknown devices (new id’s) appear in the route to my TRM3.

Only way to fix this is by factory reset?

Check out this post FAQ: How to remove ghost devices from your z-wave and zigbee networks