Heat-it z-push button 2 & smartthings

Og, hvordan går det med batteriforbruket? Min har brukt 45% på12 dager. 11 av dem uten bruk (fysisk eller via app)?

Tja, om rapporteringen fungerer eller ikke vites ikke men har ikke hatt problemer og de viser 100% enda, og har hatt de aktive siden rundt den tiden du var i kontakt med meg…

@Rboy is the official partner to Heatit. They have made DH for Heatit devices like Z-Dim, Z-TRM2fx and Z-Water.

I have asked Heatit for them to also make a DH for the Z-Push devices, but they said that they dont see any demand for this yet. Please send them a mail post@heatit.com and request a DH for the Z-push devices, and they might actually do it :slight_smile: @S.F.B @Kristian_Skauge @Modrica @ivarsand @JohanW


I made a request today. Let’s hope they Will listen

1 Like

Answer from Heatit :frowning:


Vi har dessverre ikke en device handler for push button 8 i smartThings.

Vi beklager dette.

Vennlig hilsen/Best regards,

Hei Ivar,

Fikk du 8-knapps varianten av Z-Push-bryteren til å fungere?
Om du evnt har en Device-handler som fungere setter jeg stor pris på om du har mulighet til å sende link/dele kode :slight_smile:

Mvh. Sebastian

Hei Sebastian

Jeg har en som jeg benytter. Ikke fått noen rapporter om at noe ikke fungerer lenger.

Tar gjerne tilbakemelding om du finner noe som ikke fungerer som du forventer at det skal.


(Attachment heatit-z-push-button-8.groovy is missing)

Hei igjen,

Takk for det. Jeg skal legge den inn med en gang, og kan holde deg oppdatert dersom jeg opplever noen utfordringer med den.
Men, det ser ikke ut som at vedlegget kom med. Jeg sender deg en e-post til adressen du oppga lenger oppe i tråden, så om du har mulighet til å sende over koden på e-post er det supert.

Mvh. Sebastian

Hi guys
Would it be possible to use push-and-hold on this device in order to dim (increase/decrease brightness)? I currently have a Fibaro Dimmer that is controlled by a Fibaro Keyfob, but I have to do repeated clicks to increase/decrease x% and there needs to be a delay of 1s between click, so quite cumbersome.

Hi there, I’m using your driver, Ivar. A few weeks ago the reset battery function stopped working. At the same time (approx) the reporting at1h08min intervals of the battery status ceased as well.

Hi. Not sure what you mean. Reset battery function is only used when you change the battery. Have you done a battery change multiple times? You know you have to click the reset button twice?

No more reporting normally means the battery is empty.

This switch would be perfect apart from the battery usage. I have one in a holliday home and it is not much used. It only managed 5 months on the first battery.

When you change battery, make sure you never touch the new battery with your fingers.
Fat and dirt from your fingers will easily reduce battery life time drastically.

My first battery lasted a few weeks only. The next 95 days. And, the unit is seldom used as it sits in a vacation home. Other than that the unit and the DTH have been working like a charm.

When changing the battery last week (after 95 days) double-clicking the battery-last-change-app-tile led to nothing. Several more attempts neither.

And, the battery-status-messages vanished from the ‘Recent’ tab in the app. The reporting might actually have disappeared at an earlier stage, without me noticing.

I refreshed the DTH/device-assoc by means of the IDE to no avail (‘touch’, save, publish for me) in an attempt to rectify. No luck.

I’m running the 2015 - hub and it just recently received new firmware. I’m not aware of any changes in the ST-platform.

So - what happened?

Sounds like a problem with the device. Check that it blinks when pushing buttons.
I have the 2015 hub and just tried resetting battery since. Press once, then press again.

Refreshing the dth will not help, but pressing configure might help. Note that if you press configure, you have to wake battery devices. Otherwise nothing will happen.

Hi, did anyone have success with this PushButton? Which DH to use?

I added it as a generic device, and it seems to send signals to ST. In the old app, I see this in the logs. In the new app, nothing seems to happen. When trying to setup an automation, so that it can turn on/off lights, it is not listed as a possible device to trigger automations.

Hi, I am quite new to Smartthings. Have bought a Heatit-Z-Push-Button-2
so I can switch off the alarm at night moving from 1st floor to ground floor were the alarm is turned on.

I have installed the device handler from Ivar (thanks!)

I have added an automation with 1 press - to deactivate STHM and 3 press - to re-activate, but nothing happen. I can see that the button status changes from Standby to Pressed in the new ST app.

Do I need to add node - in settings? Any suggestions what to do?

Hi again, I changed the automation to Held (for activate) instead of press 3 times. Worked !!

Hey – does this mean you only have pressed and held as the state the hub recognizes? That’s my situation exactly with the Heatit Z-Push button. Got the DH from Ivar, but the Smartthings hub only recognizes ‘pressed’ and ‘held’. And makes no difference between the buttons (0 and 1). They’re all recognized as the same press. So I need to have one thing happening when either of the buttons are pressed, and another for when any of the buttons are held. Any way to solve this?


Kunne du sendt meg denne DH.
Har ikke funnet noen annen DH for HeatIt Z-push 8 buttons enda…


DH vedlagt.

Mvh Ivar

(Attachment heatit-z-push-button-8.groovy is missing)

Hvor finner jeg egentlig vedlegget?