Having An Issue With networkSecurityLevel: ZWAVE_S0_FAILED


New to SmartThings and Z-Wave, not new to home integration. SO, here’s the problem: I have a SmartThings hub V3, all set up. I have three Fibaro Smoke Sensors, that used to be connected to a Z-Stick. I excluded them all from the Z-Stick, and added them to the SmartThings Hub. One of them works perfectly, the other two will not show the battery level, although will show temperature (and that there is no smoke…). When I have explored this further, the two that won’t display the battery, have the ZWAVE_S0_FAILED message in the Data section of the SmartThings webio.

I have excluded all of the devices and just added a single device. The same two devices show up as ZWAVE_S0_FAILED, every time, and the third device always shows up as ZWAVE_S0_LEGACY.

I am at a complete loss. I have scoured the internet, and cannot find a solution for this issue. I have no other devices attached. I have tried resetting the router, as well as factory resetting the smoke detectors. Anyone have any ideas? I really need to be able to know the battery levels of my smoke detectors, so that I can have alerts reminding me to change them - seems like that’s not such a tall order…

Thank you

1 Like

Did you get a secure inclusion for these. i.e. zw:Ls at the beginning of the raw description for the device in the IDE?

Another thing on battery level is to remove the battery, wait one minute, replace the battery, count to 10 and then press the button to wake up the device.

It means the the device is unable to complete the pairing process successfully. Try to reboot the hub, reset the device and pair it while it’s close to the hub (within 5ft or so).


1 Like

That worked!! I obviously wasn’t close enough the first time I attached two of the three sensors, and somehow this was retained. I went right up to the hub, removed one and reattached it and it worked. Did the same for the other, and now I have full connectivity – thank you

1 Like

So the problem was a failed pairing, and it was fixed by re-pairing … great. But … what concerns me about this whole story is … why did it work ‘partially’ - from what I’m reading, you were getting ‘some’ data from the device, just not battery. So is this a ‘normal behavior’ of the smartthings system (or of any z-wave network?) … that you can have things fail but still work? I would prefer that … if the pairing doesn’t work properly, that you would get an appropriate failure message and you’d have to try again, rather than having a ‘half-assed’ success! So is this a design feature of the system - it will ‘try to work’ with something even if it doesn’t succeed fully? I guess it’s nice to see that it ‘tries’ but again, I’d prefer a hard failure that tells you to go figure out the problem!

1 Like

There are a number of devices that only work partially unless they are included securely. Perhaps this was the issue.

Hello guys this sound interesting why not open a ticket for Dev support so this issue can be checked on and if needed be escalated to SmartThings Developer team? link for Dev support

Rebooting the hub (disconnecting it for 30 seconds), resetting the device (then disconnecting it) and putting it closer to the hub did it. Turned from ZWAVE_S0_FAILED to ZWAVE_S0_LEGACY. Thank you for the help!