Harmony Hub UK Integration

Not quiet sure what’s going on with harmony and smarthings but the smart app on smarthings with not save the credentials. I’ve deleted app and started from scratch but still the same. I think there is a problem with the integration now as it was working fine. Anyone else suffering the same problem. And if so does anyone have any idea when this may be fixed ?
Paul

Been researching add-ons to my ST set-up now that it seems to have stabilised somewhat over the past few months and just noticed the Harmony Hub on Amazon (inc. Prime) has dropped to £62 (15th March 2016) which seems a decent enough price to give this a whirl!

Now all I want is the Amazon Echo stuff working (& Hozelock Cloud Controller) and I think it’ll be a pretty impressive set-up!

Note: Amazon link includes my affiliate code

1 Like

Cheers, just ordered one.

Hi
I’m failing badly on adding in Harmony to my UK Smartthings setup.
I’ve successfully added in Smartthing into my Harmony Remote (not that the Harmony site helped there. For any UK Users, Add Smartthings as a Device for manufacture and model :slight_smile: ) - may save someone a lot of forum clicks.

I’ve followed xAppos instructions (I think correctly)
Using the IDE

  • I added in the Logitech Harmony Connect SmartApp via the template. I updated the app and clicked the authorise option. I saved my changes and published for me. For some reason this entry on my list is now brown and under OAuth the option is true (at no point have I entered any credentials)

  • I added in Logitech Harmony Hub C2C device handler again from the template code and published it for me. Again this entry is brown and under OAuth the title is true.

However when I enter my ST App on my Android device, under Marketplace and Smartapps I click on MyApps , but there is no Harmony/Logitech SmartApp.

Can someone offer assistance?

Thanks

Bloody hell, maybe its just me, but they haven’t made this easy. I’ve been reviewing this issue for ages and only by pure chance when i was clicking around the App, do I now actually see the application installed.

Under Marketplace My Apps doesnt fully relate to the apps you have installed (by the look of things). On the top of the screen, click the 3 bars at the top right, this provides you with a subscreen indicating the Hub is Online etc.

Click on the option “SmartApps” and low and behold there is the Logitech Harmony Connect App.

Hope this helps others.

1 Like

Oh boy, maybe I spoke too soon, attempting to add devices and I keep getting

“You appear to be having issues with your network. Please check your network connection and try again.”

I think the Harmony now have an automatic smart app thereby making the above steps obsolete.

Can someone else confirm?

Open up ST app. Click on Marketplace, under the heading of “Things” there is a new option (at least for me) called “New Things” within there, there is an option called “Logitech Harmony (UK)”

Thanks

1 Like

It’s in there along with a couple other newbies

1 Like

I like the inclusion of the £1200 washing machine ahahaha :smiley:

Has anyone done this through the new things option. I have a Windows phone and the option does appear, when I follow the wizard it takes me to the harmony login to authenticate, once done a page appears saying click done to continue. However, there is no done button, when you go back to smartthings there is nothing filled in and you start all over again.

I have but on an Android ST app. It crashes a bit, but if you persist it eventually goes through.

Hi
I’m experiencing an issue with this integration but not sure if its me or perhaps someone had offer assistance.

I have an ST Switch which is pluged into my lamp, thus turn lamp on or off.

I’ve integrated ST into my harmony remote and can turn lamp/switch on/off perfectly. I turn the Lamp/Switch On/Off via an Activity. I’ve integrated Harmony into ST and added in my Lamp/Switch activity.

When I turn on the activity via the app and the lamp/switch turns on. The ST lamp switch turns on and the Activity on the Remote turns on…but then the ST Harmony Activity turns itself off!!! The lamp stays on and so does the activity on the Remote.

Re-setting everything and I turn on the Activity via the remote everything turns on Lamp/Switch, the Harmony Activity and the Lamp and Harmony Activity on the app, but a few seconds later the Harmony Activity on the App turns off.

Any one know why the Harmony Activity on the Android App turns itself off after a few second?

1 Like

Can you pop on some screen shots please of the activity within the harmony app?

In the scenario below the Lamp is on. The Harmony App showing the activity active is correct.
The Device in the ST App called LR - Lamp [HA] represents the LR - Lamp Harmony Activity.

This one is from the Harmony App - showing the activity on

This one is from the ST App - Showing the Harmony Activity Off

This one is from the ST App - showing that the lamp/switch is on

I’m honestly not sure. I have my logitech setup to be controlled by ST. I added one of my lamps to the harmony app to test and the activity worked fine.

I’m guessing your adding smartthings into harmony so you don’t have to keep your phone with you at all times?

Pretty much. I want my remote to control the room, but if I use my ST app on my phone I need to have whatever is powered on/off accurately reflected too.

The weird thing is it does turn on, but after a few seconds it switches itself off. I’m on the latest Android ST app too.

As it currently stands it means I can not trust what the ST app tells me in terms of whats turned on or off.

I’ve just being reading the Rule Machine thread and there seems to be an issue in relation to ST keeping track of devices states. I saw someone mention Simulated Switches are also not working.

I wonder if this relates to the issue I’m having!!!

Unfortunately the update didnt fix this issue.
Anyone has any suggestions on possible options to resolve?

plus @teohwk… (stupid aaron doesnt know how markup works)

the Logitech Harmony Trigger SmartApp is now live in the UK. You can find it by going to Marketplace>More>Logitech Harmony Trigger. Thanks for the patience!

Thanks @Aaron

Now let’s get github integration going… :beers: