Harmony Hub UK Integration

Need some help with this…

What i did was >

1 - Harmony App , add ST every thing was ok, no errors (using UK country)

2 - Using the site ( graph-eu01-euwest1.api.smartthings ) , i have add the template to my SmartApps, and put the OAuth to true.

3 - Using the app ST , Marktplace > Smartapps > My Apps > Logitech Harmony (Connect) , try to enter Harmony Credentials >
{ “error” : True, “type”:AccessDenied", " message" :" This request is not authorized by the specified access token"}

Is there any idea why i’m getting that error?

Update > I have create a USA location, and everything works. I can see my activities, the only down side is that i don’t have any sensors, that i can add to that location.

@TomM and @deano12 is still working for you?

Thank you.

Still no update for this?

You should not need to take step 2. Might be n idea to start again… It should work in the documented way on the Harmony site now

The documented way on the Harmony site (at least the one i have found), its all correct, but the problem is that when you add the ST in the Harmony app, you are redirect to the “graph.api.smartthings.com” and not to the " graph-eu01-euwest1.api.smartthings ".

I have already try to change the country (to uk) on the Harmony app, but it stays the same.

There is a current UK issue reported on the ST status page. I don’t know if it’s related though as it doesn’t provide enough detail re. the affected apps.

Investigating - We have identified an issue authenticating some new devices and integrations that use OAuth. We are currently investigating the cause of the issue and will continue to provide updates accordingly. *
*Jan 25, 16:00 EST

The above ‘issue’ for UK users is now showing as resolved on the status page so if you still have problems unfortunately it looks like it’s something else…

I’m going to try, again…

But Logitech Harmony (Connect) is still missing from the UK.

Yes, you’re right it’s still not there officially - the UK is tediously slow at adding these things , but there were no changes I had to make to the US published versions. I just tried it start to finish and it has worked OK for me…

I added SmartThings to the Harmony iOS app first - selected my ST hub location and then enabled the devices I wanted. That worked OK (although it’s easy to overlook the spinner select for location at the bottom of the screen).

I then added the Logitech Harmony (Connect) SmartApp in the ST IDE ‘My SmartApps’ - enabled oAuth in the ‘App Settings’ and then ‘Publish’ (For me) … and then I did the same for the Logitech Harmony Hub C2C device in the Device Handlers and ‘Publish’ (For me). I did not have to edit either code in any way (for example to change the EU server address).

Then using the ST app via ‘My Apps’ in ‘SmartApps’ I entered my Harmony account details - it authorised (a bit slowly) and then found my hub and my activities (again a bit slowly) which I could then add to ST. My hub then appears as a device using my new device handler in the ST IDE and I have control from ST.

So control in both directions…

K

I do worry about this maintenance/approval for the devices and apps that appear in the listings on UK hubs. The US ST staff often seem surprised that we can’t see some things that they have available in the US. I’m not convinced it’s well maintained and synched. I’m concerned that lots of things available to US users are just missing over here … for example are there really only two ‘SmartThings Recommends’ apps - SmartLights and Notify Me When ?

Thank you @xAPPO for the info, when i get home will try to do all that.

One thing, when you "I added SmartThings to the Harmony iOS app first ", it did send you to the US site and not the UK, right?

Is it the ST integration within Harmony that isn’t working or the reverse ?

Yes - If I remember correctly it did but it did still authorise OK. But I think it did for you based on comment (1) in your earlier post #29 ? I think that aspect is a red herring. You selected a location OK did you and got the ensuing list of devices back from ST to select from ?

Also later in that post I see you’ve added the SmartApp with oAuth but no mention of adding the accompanying device handler - although you seem to have half succeeded even then which seems contradictory.

Let me know how you get on.

@xAPPO

BIG THANK YOU!! :smiley: It WORKS YEAHHHH

What was missing, “device handler”, didn’t change the urls, just make the steps you say, and no errors.

Do you know how long takes the sincronize, the names of activities in Harmony to be show in ST ? (if change the names or add new activities)

Really Thank YOU!!!

Maybe with some luck (there is a topic talking about that), about the " oAuth " in the Uk server will show more stuff.

My next step is going to be Fibaro FGRGBWM-441 RGBW.

I have this working but since the last update of the hub I get a lot of entries in the live logging continuously
Support said to see if anyone else was reporting this, and also suggested removing Harmony and re-adding, however, its take a long time to get this working I don’t want to stop it now.

Anyone getting these?

843c08c5-4a8b-4508-8c00-346010b5b0bd ‎15‎:‎36‎:‎34: debug Adding subscription

843c08c5-4a8b-4508-8c00-346010b5b0bd ‎15‎:‎36‎:‎34: debug Adding callbackUrl: http://192.168.1.12:8222/api/harmony.automation?smartthingscb
843c08c5-4a8b-4508-8c00-346010b5b0bd ‎15‎:‎36‎:‎34: debug addSubscription, params: [appId:843c08c5-4a8b-4508-8c00-346010b5b0bd, param1:subscriptions, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi], request: [attributeName:switch, callbackUrl:http://192.168.1.12:8222/api/harmony.automation?smartthingscb, deviceId:cd2fa39b-0051-430e-8825-76682f109e88]

Not quiet sure what’s going on with harmony and smarthings but the smart app on smarthings with not save the credentials. I’ve deleted app and started from scratch but still the same. I think there is a problem with the integration now as it was working fine. Anyone else suffering the same problem. And if so does anyone have any idea when this may be fixed ?
Paul

Been researching add-ons to my ST set-up now that it seems to have stabilised somewhat over the past few months and just noticed the Harmony Hub on Amazon (inc. Prime) has dropped to £62 (15th March 2016) which seems a decent enough price to give this a whirl!

Now all I want is the Amazon Echo stuff working (& Hozelock Cloud Controller) and I think it’ll be a pretty impressive set-up!

Note: Amazon link includes my affiliate code

1 Like

Cheers, just ordered one.

Hi
I’m failing badly on adding in Harmony to my UK Smartthings setup.
I’ve successfully added in Smartthing into my Harmony Remote (not that the Harmony site helped there. For any UK Users, Add Smartthings as a Device for manufacture and model :slight_smile: ) - may save someone a lot of forum clicks.

I’ve followed xAppos instructions (I think correctly)
Using the IDE

  • I added in the Logitech Harmony Connect SmartApp via the template. I updated the app and clicked the authorise option. I saved my changes and published for me. For some reason this entry on my list is now brown and under OAuth the option is true (at no point have I entered any credentials)

  • I added in Logitech Harmony Hub C2C device handler again from the template code and published it for me. Again this entry is brown and under OAuth the title is true.

However when I enter my ST App on my Android device, under Marketplace and Smartapps I click on MyApps , but there is no Harmony/Logitech SmartApp.

Can someone offer assistance?

Thanks

Bloody hell, maybe its just me, but they haven’t made this easy. I’ve been reviewing this issue for ages and only by pure chance when i was clicking around the App, do I now actually see the application installed.

Under Marketplace My Apps doesnt fully relate to the apps you have installed (by the look of things). On the top of the screen, click the 3 bars at the top right, this provides you with a subscreen indicating the Hub is Online etc.

Click on the option “SmartApps” and low and behold there is the Logitech Harmony Connect App.

Hope this helps others.

1 Like

Oh boy, maybe I spoke too soon, attempting to add devices and I keep getting

“You appear to be having issues with your network. Please check your network connection and try again.”

I think the Harmony now have an automatic smart app thereby making the above steps obsolete.

Can someone else confirm?

Open up ST app. Click on Marketplace, under the heading of “Things” there is a new option (at least for me) called “New Things” within there, there is an option called “Logitech Harmony (UK)”

Thanks

1 Like

It’s in there along with a couple other newbies

1 Like