SmartThings Community

Harmony Home Control

It depends how you set it up.

If you assign the fireplace activity to a virtual switch on the SmartThings side, you can then assign that virtual switch to a home automation button on the Harmony remote so that toggling it will go to SmartThings, then come back and run the activity.

But doesn’t sound like that’s what you wanted, as it does turn the activity on.

1 Like

That does help as I can turn on the fireplace from one of the home automation buttons on the remote but yeah that’s not exactly what I was after. Thanks for chiming in and trying to help me figure it out.

1 Like

Note that you can run multiple activities simultaneously on the Harmony, but only one of them can be an “entertainment” activity. You can run multiple “home control” activities.

The post below explains this in a little more depth:

But there would be no way to specify my fireplace as a home control device though, right?

I bought a Harmony Elite tonight and I’ve authorized it with SmartThings but, I can’t see anything Harmony-related in ST. My remote can control SmartThings devices but, my group of GE bulbs behaves weird. It usually only turns one of the three bulbs on and, not always at full brightness. After this happens, I have to power cycle the bulbs for SmartThings to be able to control them again.

This might help if you’re interested in controlling Harmony activities:

As far as the bulb behaviour, haven’t heard that one before, but my Zigbee network was weird all day, no Harmony involvements just devices not responding. I would report that to support.

Unfortunately, no, this is not something you can change yourself,

The best you can do is petition Logitech to change the device definition within their database, but even this may not be possible - there may be an underlying constraint in their software which is why they currently define every IR controlled device as an “entertainment” device when it is obviously not the case. (If your fireplace is controlled via IP rather IR, then go ahead and petition away :smile: ).

4 Likes

Hi Scott, here’s an option depending on what types of activities you use on that TV. Create duplicate TV activities. One with the fireplace in it and one without. If you just want to watch tv, you can press the one without. If you later decide you want it on, you can press the one with it and since everything else is the same no change in buttons or anything. If you have a lot of activity types (cable, Apple TV, bluray, etc) it could be tough.

The home companion remote has 3 dedicated activity buttons, but each can store a short press and long press; so you could map the fireplace ones to long and without to short. If you have more than 3 TV activities, you’d be in a pickle or need the Elite.

Then you could use JD’s virtual switch suggestion to put the fireplace only activity to one of the 4 home control buttons for when you just want the fireplace and not tv.

Lastly because you’d be switching activities but with the same devices, you’ll want to play with the advanced settings for not changing inputs, so you don’t get the input selection flicker when making a change.

Good luck!

1 Like

Thanks, I did not think of doing it that way, that may help if what I am testing now does not work out.

I have been messing around with HarmonyHubControl:
http://www.openremote.org/display/forums/Howto+-+Control+a+Harmony+Hub

which allows we to send commands to the hub to trigger activities and individual commands. I had it installed on a Raspberry Pi but didn’t know how to get from ST to the PI. Right now I found a windows version of it and have it running on an always on PC with EventGhost. Everything is run in a roundabout way so it is not very elegant but does work. I am using the “Send Events to Evenghost” smartapp to send to EventGhost which then triggers the command line for HarmonyHubControl. I have also added it to my Echo so saying “Alexa, turn in the fireplace” will be a big hit as it starts getting colder.
My only issue I am going to run into is if someone manually turns the fireplace on or off as the IR command is just a toggle so I have no discrete on and off commands, things can get out of sync pretty quick.
This is a hack at best (but works for now) and would be great if ST was able to send directly to the Harmony Hub with individual commands :smile:

2 Likes

Couldn’t find my remote this morning so I brought up the app. Unfortunately, all my activities were missing. After stumbling through different menus, I got a dialog indicating the hub firmware needed updating. I’m now at hub version 4.8.24.

Thought I would give you a heads up because the problem isn’t immediately obvious.

In fact I picked up the remote couple of days back and there was a prompt on the remote itself for firmware update. This was a first for me.

The Android app just updated to 4.7 build 11 which may avoid the issue. They changed the color theme for activities.

Just wanted to mention that sometime in the last few days a brand-new official smart app, “harmony control” (not “harmony connect”) showed up in my account all on its own and broke my harmony/SmartThings integration. It appears to be a replacement for “Logitech Harmony triggers”

It did assign itself to my trigger switches, but I wasn’t signed into harmony from its credentials page and so nothing worked.

It may have been somebody in support pushed it out to me as I have a couple of open tickets. But I did just want to mention it because it was a hard problem to track down but easy one to fix. Details here:

1 Like

Now I need to go looking. I might even be to blame since I have open ticket regarding not being able to remove a ghost switch from ST, " in use by harmony". Even though that switch was never used or authorized for Harmony I can’t remove it without removing Harmony/ ST integration completely.

Hi everybody - this is an amazing thread filled with tons of information. I worked on connecting v2 ST hub to my Harmony hub and finally got it connected by updating the firmware and then adding it to ST by selecting Connect New -> Entertainment -> Remotes & Buttons -> Logitech -> Harmony Home Hub

This worked but then after about 2 hours all my zWave devices stopped working. I removed it and rebooted the hub and they all started working again. Weird - I assume this was caused by some type of fatal hub error or maybe by Harmony trying to take over the zWave network. So based on various articles in this thread I am going to try one of the following alternative methods:

  1. indirect using virtual switch and IFTTT
  2. send event to a HarmonyHubControl service running on a PC (from @swindmiller )
  3. add ST to harmony hub to enable cloud to cloud (I think)

All I really want to do is turn on one of four different activities and turn all off so 5 virtual switches should do the trick, so I am leaning toward #1. I already have Harmony added as an IFTTT channel

By the way, I wrote to support and they gave me the same standard answer about a new integration being in beta and that I should just wait, but I read so many posts that suggest that it is working fine now.

Any advice?

Do you own an Amazon Echo? You can do voice control through IFTTT and avid creating the virtual switches.
Here is a thread where you can get all you need from the first post.

Edit: Added the link for another thread

Yes - of course - any self respecting ST junkie also has an Amazon Echo. Good idea - I will try that next. By the way, I tried adding ST to my Harmony Hub on the Harmony side since that is something I had not tried yet. The hub was found and was added easily but the same behavior happened - after adding none of my zWave devices would respond to the ST app. So I am now removing it and rebooting my hub. I guess I am stuck with IFTTT integration options for now. Thanks again for the suggestion.

Edit: But this still doesn’t solve my need to turn off the system when I trigger from ST the go to bed action. I still need a virtual switch for that.

1 Like

I have my Harmony hub connected to ST by the official ST connection. I never experienced that problem. If you add it through the ST hub, there is a possibility it will generate that behavior. What the Harmony hub does is it acts as a secondary controller for your Z-wave stuff, but only if you have the Harmony Hub Extender as well. Maybe someone with more knowledge than mine can help you on this.

If you still can’t connect it, you can create a momentary button tile and tie it to your “go to bed” action, and have IFTTT to turn off the Harmony when that switch is turned on.

Thanks man… well I tried adding it both ways and both times it generated the same behavior of disabling all my zWave switches. Oddly enough the system still recognizes my zWave motion detectors but it doesn’t respond to switch on/off commands from the app. Last time a hub reboot brought it back to life after removing. I am in the process of doing that now and hope it comes back. This is too important to muck with since we have become addicted to automated lights but not yet to automated TV. I will try the momentary virtual switch and IFTTT next but only after I bring my main features back to life. It would be more settling for me if anyone else in the ST community has experienced this same behavior.

Update:
Okay - got my system working again after a reboot and repair zWave action. And I got the IFTTT virtual momentary buttons working. They works fabulously well so I am all set. The full integration will be nice to have but quite honestly I am pretty happy with this IFTTT solution which also works with Alexa/Echo as an added bonus.

1 Like

There’s no logical reason why the Harmony integration should affect Zwave at all. It’s not the same protocol.

That said, it doesn’t mean that there isn’t something in the SmartThings architecture that is causing your local network to get out of sync with your cloud account when you do the harmony integration, Or something like that. People have been reporting that a bunch of zigbee devices will go out, or a bunch of Z wave devices will go out, when they shouldn’t. Nothing to do with harmony, just you change one thing, and suddenly you lose half of one of your local networks.

And forcing a resynch with the cloud account by taking the hub off-line for about 15 minutes often seems to fix it, even in situations when it shouldn’t.

So I do suspect some synchronization issue between the cloud and the hub but who knows?

I’m glad you got something working. :sunglasses:

1 Like